Homey Community Forum

Soma Connect App (v1.2.3 and Test 2.0.0)

Hi Adrian,
thanks for your work! I installed the app yesterday and it works flawless with my two soma shades.

Daniel

1 Like

This answered one question for me, so thank you for this! On another perhaps related note, I want to automate my blinds in my office downstairs as well as the bedrooms upstairs. Bluetooth connectivity is not feasible to reach both areas, hence my searching and finding this post that suggests I am lacking the Soma Connect Hub. If the Hub connects to the shades within close range, would I need a second, or possibly even a third Soma Connect hub upstairs? I assume these hubs connect via WiFi to Homey? I have a very reliable WiFi network throughout the whole house, so this would be perfect. Just need to know if anyone has any advice on the multiple Soma Connect hubs idea?

Thanks! You guys rock!

The hub connects to Homey via wifi or ethernet cable. In theory they have a 40m range for the Bluetooth connection to the blinds but I haven’t tested that. My hub is only about 4m away in the same room.
One thing I do know for sure is the range of Homey’s Bluetooth is very poor. My phone can connect to my blinds via Bluetooth anywhere in my house but Homey has to be within about 2m to connect. That’s why I got the hub and developed the app.
It has been my intention to modify the app to work with multiple hubs but so far no one has asked so it just sits on the to do list.
My suggestion would be to get a hub and try it. If you find you need more than one then let me know.

I have installed the latest version of Soma Connect firmware (2.2.0) and discovered they have changed the Tilt functions.
Previously the position value was between 0 and 100. Now the settings need to be between -100 and 100 with 0 being horizontal. However, the returned position is messed up as 0 is horizontal but both full tilt position are 100, so there is no way to know if it is tilted fully up or down.

I have added support for the new setting range along with a device setting to specify if it is a shade or a tilt motor (no way to find that from the API).

I have also reached out to Soma support to query the issue with the reported position. There might be a bug with their numbers or they might have added another API call that has not be documented yet.
I have also asked if there is any way to identify the motor type as the operation is now different between the two.

If anyone has the new Soma Connect firmware with a tilt motor then let me know and I will publish the update.
If I don’t here from any users I will wait until Soma support get back to me with some answers.

Thanks Adrian! I received my Connect hub last night. I will tinker with it over the weekend and let you know. Much appreciated!

Hey Adrian,
I’m having the same issue as above described.

The first installation of the app was simple and succesful( thank you) but after a homey restart the issue started occurring even after the update of the ip in app config.
I already reflashed the system with the latest version( was already 2.2.0 before)
Do you have some suggestions?
Marco

I have just uploaded 1.1.3 to test. I have been using this for a while as it copes better with the Connect box going offline (which mine seems to occasionally).
Could you try this version to see if it better and also try cycling the power on the Soma Connect box.

Same issue. I tried to run the GET request with postman and I have the same result.
I assume is a problem before homey then…If you have more ideas is highly appreciated!

Well the error message suggests it’s reaching something. Are you sure it’s the correct IP and nothing else is clashing?
Have you rebooted the connect box?
Can you connect to the box with the Soma app?

Well, a reboot of the router magically fixed all :slight_smile:
Thanks for helping!
BTW, 1.1.3 works great with my shades!
Just a little suggestion: if you can trim IP addresses from leading and trailing spaces( from copy paste errors) it would prevent uncauught errors!

1 Like

I had a message form Soma today:

We also have an article out now on how to set up the Connect with a Shelly WiFi button (How to set up SOMA Smart Shades with the Shelly WiFi button - SOMA Smart Home). And we are also working on similar guides for HomeKit buttons and Hue buttons for example.

So if anyone needs a directly connected controller next to the blinds it looks like a reasonable solution.

I just bought a blind and connect box, it came preinstalled with 2.2.8 but I get the same error when installing on a device using old firmware.

HTTP catch : error : econnrefused 127.0.0.1:3000

Looks like it’s attempting to connect to local host with out being give to he option to enter the connects IP address.

Edit : went into the app settings and added the IP address there prior to setting up the device :slight_smile:

Did you tap on Save Changes after entering the IP address. I have just noticed the borders make it appear that only applies to the Polling.

I messed up and thought the it was added when adding the device not prior via settings.

No problem. I am looking into using mDNS to discover the connect box in the future so it should be easier.

1 Like

@Adrian_Rockall

Great APP!!

Not sure if I did it right but at first the tilt was not working up/down but after changing to shade and back to tilt it’s working perfect.

A question:
As, in tilt mode, the fully open setting is 50%. Would it be possible to add the % in the manual mode.
(when pressing the icon)

btw: FYI I received the new Raspberry version 2.2.9

I hadn’t noticed there was an update to the connect box so i will check that out. Edit: looks like 2.2.8 is the latest on the site.

Which version of the app are you using (1.2.3 or 2.0.0)?

I did have the quick action in an early version but it was ‘not to Athom guidelines’ as the device is only supposed to have one control method. To add the quick action I need to add the on/off capability which adds the power type of button. I will have another look into it to see what I can do.

The version on the website is 2.2.8 but:
afbeelding

It appears 1.2.3 from the homey app store with auto-update on.
How do I get 2.0.0? (As for now I have only used the homey app store :expressionless: )

Version 2.0.0 is still in the app store but you just add /test to the end of the normal URL, e.g. Soma Connect | Homey

Installed 2.0.0, will test later today.

1 Like