Homey Community Forum

Somfy light switches

Hello @Adrian_Rockall ,
I have 2 different light switches from Somfy connected to Tahoma.

  1. One is a RTS switch.
  2. Another one is an Izymo IO switch. This is not the same as an “Somfy receiver IZYMO io shutter”

I can’t find this one in the Somfy Tahoma App to add it into my devices.
I’m using v2.1.2
Could you add this devices?

Gues you want to address this question to @Adrian_Rockall This will call his attention.

@JPe4619
Hallo Jan, bedankt voor de tip :slight_smile:

Could you send the Device log to me so I can identify the settings/states.
Open the app, Configure app page, select the Device log tab and tap the Get Log button. Once the list has filled tap the Send Log button.
If you could also let me know the friendly names that you gave the devices you want added so I can identify them in the log.

Hello @Adrian_Rockall,

Hereby the log.
I have removed a lot of devices, while the log was too big. Only the 3 devices I can’t find in Somfy by Homey are added.

The friendly names are

  • Overkapping: this one is the Izymo switch

  • Carport: this one is the RTS switch

  • Tuinverlichting: this one is another RTS switch I can’t find in Somfy by Homey

    {
    “devices”: [
    {
    “label”: “Overkapping”,
    “controllableName”: “io:LightMicroModuleSomfyIOComponent”,
    “definition”: {
    “commands”: [
    {
    “commandName”: “delayedStopIdentify”,
    “nparams”: 1
    },
    {
    “commandName”: “getName”,
    “nparams”: 0
    },
    {
    “commandName”: “identify”,
    “nparams”: 0
    },
    {
    “commandName”: “off”,
    “nparams”: 0
    },
    {
    “commandName”: “on”,
    “nparams”: 0
    },
    {
    “commandName”: “onWithInternalTimer”,
    “nparams”: 0
    },
    {
    “commandName”: “onWithTimer”,
    “nparams”: 1
    },
    {
    “commandName”: “setInternalTimer”,
    “nparams”: 1
    },
    {
    “commandName”: “setName”,
    “nparams”: 1
    },
    {
    “commandName”: “setOnOff”,
    “nparams”: 1
    },
    {
    “commandName”: “startIdentify”,
    “nparams”: 0
    },
    {
    “commandName”: “stopIdentify”,
    “nparams”: 0
    },
    {
    “commandName”: “wink”,
    “nparams”: 1
    },
    {
    “commandName”: “pairOneWayController”,
    “nparams”: 2
    },
    {
    “commandName”: “setPictoValue”,
    “nparams”: 1
    },
    {
    “commandName”: “unpairAllOneWayControllers”,
    “nparams”: 0
    },
    {
    “commandName”: “unpairOneWayController”,
    “nparams”: 2
    }
    ],
    “states”: [
    {
    “values”: [
    “good”,
    “low”,
    “normal”,
    “verylow”
    ],
    “type”: “DiscreteState”,
    “qualifiedName”: “core:DiscreteRSSILevelState”
    },
    {
    “type”: “DataState”,
    “qualifiedName”: “core:NameState”
    },
    {
    “values”: [
    “off”,
    “on”
    ],
    “type”: “DiscreteState”,
    “qualifiedName”: “core:OnOffState”
    },
    {
    “type”: “ContinuousState”,
    “qualifiedName”: “core:PriorityLockTimerState”
    },
    {
    “type”: “ContinuousState”,
    “qualifiedName”: “core:RSSILevelState”
    },
    {
    “values”: [
    “available”,
    “unavailable”
    ],
    “type”: “DiscreteState”,
    “qualifiedName”: “core:StatusState”
    },
    {
    “type”: “ContinuousState”,
    “qualifiedName”: “core:TimerState”
    },
    {
    “type”: “DataState”,
    “qualifiedName”: “io:PairedMicroModuleWithLowBatteryState”
    },
    {
    “values”: [
    “onOffLight”
    ],
    “type”: “DiscreteState”,
    “qualifiedName”: “io:PictoState”
    },
    {
    “values”: [
    “comfortLevel1”,
    “comfortLevel2”,
    “comfortLevel3”,
    “comfortLevel4”,
    “environmentProtection”,
    “humanProtection”,
    “userLevel1”,
    “userLevel2”
    ],
    “type”: “DiscreteState”,
    “qualifiedName”: “io:PriorityLockLevelState”
    },
    {
    “values”: [
    “LSC”,
    “SAAC”,
    “SFC”,
    “UPS”,
    “externalGateway”,
    “localUser”,
    “myself”,
    “rain”,
    “security”,
    “temperature”,
    “timer”,
    “user”,
    “wind”
    ],
    “type”: “DiscreteState”,
    “qualifiedName”: “io:PriorityLockOriginatorState”
    }
    ],
    “dataProperties”: [
    {
    “value”: “500”,
    “qualifiedName”: “core:identifyInterval”
    }
    ],
    “widgetName”: “TimedOnOffLight”,
    “uiClass”: “Light”,
    “qualifiedName”: “io:LightMicroModuleSomfyIOComponent”,
    “type”: “ACTUATOR”
    },
    “states”: [
    {
    “name”: “core:NameState”,
    “type”: 3,
    “value”: “MODULE ON-OFF”
    },
    {
    “name”: “core:PriorityLockTimerState”,
    “type”: 1,
    “value”: 0
    },
    {
    “name”: “core:StatusState”,
    “type”: 3,
    “value”: “available”
    },
    {
    “name”: “core:DiscreteRSSILevelState”,
    “type”: 3,
    “value”: “normal”
    },
    {
    “name”: “core:RSSILevelState”,
    “type”: 2,
    “value”: 68
    },
    {
    “name”: “core:OnOffState”,
    “type”: 3,
    “value”: “off”
    },
    {
    “name”: “io:PictoState”,
    “type”: 3,
    “value”: “onOfflight”
    },
    {
    “name”: “core:TimerState”,
    “type”: 1,
    “value”: 0
    }
    ],
    “available”: true,
    “enabled”: true,
    “widget”: “TimedOnOffLight”,
    “type”: 1,
    “oid”: “temp10”,
    “uiClass”: “Light”
    },
    {
    “label”: “Carport”,
    “controllableName”: “rts:LightRTSComponent”,
    “definition”: {
    “commands”: [
    {
    “commandName”: “down”,
    “nparams”: 0
    },
    {
    “commandName”: “identify”,
    “nparams”: 0
    },
    {
    “commandName”: “my”,
    “nparams”: 0
    },
    {
    “commandName”: “off”,
    “nparams”: 0
    },
    {
    “commandName”: “on”,
    “nparams”: 0
    },
    {
    “commandName”: “onWithTimer”,
    “nparams”: 1
    },
    {
    “commandName”: “rest”,
    “nparams”: 0
    },
    {
    “commandName”: “stop”,
    “nparams”: 0
    },
    {
    “commandName”: “test”,
    “nparams”: 0
    },
    {
    “commandName”: “up”,
    “nparams”: 0
    },
    {
    “commandName”: “myWithTimer”,
    “nparams”: 1
    },
    {
    “commandName”: “openConfiguration”,
    “nparams”: 0
    }
    ],
    “states”: ,
    “dataProperties”: [
    {
    “value”: “0”,
    “qualifiedName”: “core:identifyInterval”
    }
    ],
    “widgetName”: “OnOffLight”,
    “uiClass”: “Light”,
    “qualifiedName”: “rts:LightRTSComponent”,
    “type”: “ACTUATOR”
    },
    “attributes”: [
    {
    “name”: “rts:diy”,
    “type”: 6,
    “value”: true
    }
    ],
    “available”: true,
    “enabled”: true,
    “widget”: “OnOffLight”,
    “type”: 1,
    “oid”: “temp17”,
    “uiClass”: “Light”
    },
    {
    “label”: “Tuinverlichting”,
    “controllableName”: “rts:LightRTSComponent”,
    “definition”: {
    “commands”: [
    {
    “commandName”: “down”,
    “nparams”: 0
    },
    {
    “commandName”: “identify”,
    “nparams”: 0
    },
    {
    “commandName”: “my”,
    “nparams”: 0
    },
    {
    “commandName”: “off”,
    “nparams”: 0
    },
    {
    “commandName”: “on”,
    “nparams”: 0
    },
    {
    “commandName”: “onWithTimer”,
    “nparams”: 1
    },
    {
    “commandName”: “rest”,
    “nparams”: 0
    },
    {
    “commandName”: “stop”,
    “nparams”: 0
    },
    {
    “commandName”: “test”,
    “nparams”: 0
    },
    {
    “commandName”: “up”,
    “nparams”: 0
    },
    {
    “commandName”: “myWithTimer”,
    “nparams”: 1
    },
    {
    “commandName”: “openConfiguration”,
    “nparams”: 0
    }
    ],
    “states”: ,
    “dataProperties”: [
    {
    “value”: “0”,
    “qualifiedName”: “core:identifyInterval”
    }
    ],
    “widgetName”: “OnOffLight”,
    “uiClass”: “Light”,
    “qualifiedName”: “rts:LightRTSComponent”,
    “type”: “ACTUATOR”
    },
    “attributes”: [
    {
    “name”: “rts:diy”,
    “type”: 6,
    “value”: true
    }
    ],
    “available”: true,
    “enabled”: true,
    “widget”: “OnOffLight”,
    “type”: 1,
    “oid”: “temp18”,
    “uiClass”: “Light”
    },
    ]
    }

Can u plz put this in code?
Select all the txt and hit the </> button .

@Rocodamelshekima. I did it

Added to version 2.1.11 (now in test)
I have tested as best I can with my simulator but as I don’t have the devices I can’t be sure it is 100%.

@Adrian_Rockall, Thank you, I’ll test it and let you know if it’ works

@Adrian_Rockall,
I received version 2.1.12 in Homey today.
When I add a device from “Somfy Tahoma & Connexoon” - “Light On / Off (RTS & io)”, no devices are found.
I also tried the “Light Controllers”, they don’t find anything either.

Do I have to choose a different kind?

Can you see if you can get the Device log?
The problem might be caused by a login issue that is currently being worked on. if you can get the logs then you are logged in.

@Adrian_Rockall
I get the device log.
Login doesn’t seem to be a problem.

What are the names of the lights?
I will look then up in the log to track down the internal names that I need to check this.

@Adrian_Rockall,

I just sent the device log to you.

They are not lamps, but switches for lamps.
The names are “Carport”, “Overkapping” and "Tuinverlichting

OK, I will look at it tomorrow.
If you want to try the new test (v2.1.15) , they should be under ‘On / Off (RTS & io)’.

Fixed in 2.1.16

@Adrian_Rockall:
After this 2 weeks, I didn’t get the version 2.1.16.

I asked Athom how to get this version, but I don’t get a response from them either.

Can you tell me, how I can test this version?

Use the test version from here https://homey.app/a/com.somfy.tahoma/test/

@Adrian_Rockall
Thank you for reply.
The lights are switched on / off successfully.
I’m going to test how this works in the flows.

1 Like

@Adrian_Rockall,

I have tried different flows and it works fine.
Unfortunately, 1 set of lamps stopped working, but that is not due to the implementation in Homey.

Thans for adding these switches

1 Like