Homey Community Forum

Somfy Tahoma & Connexoon (v2.1.62, test v2.1.62)

I can’t login anymore, although i can on the Somfy website with the same credentials…

But i get a strange message on the website, "Requested Url was rejected, see photo) but after a few seconds it works…

i have send you a log.

Could you contact Somfy about the web login as it could be related if there is an issue with your Somfy account.

Also, try disabling the app for about 30 minutes. Maybe the continuous failed logins is prolonging the issue.

I have the same, after a few days the app stopped working. And get the message failed to authenticate. On all 3 servers

Hi,
Same problem on my side, it often happened those last weeks.
Yesterday it worked, today the issue came back. Error failed to connect.
It’s boring if it’s often.
EDIT: I’ve just restarted Somfy App from Homey, and now it’s working. Strange!

Hmm, I had a problem last night as well. It seems the app stopped communicating about 14 hours ago but I am not getting any errors. The app just keeps try to connect as if it was initialised but only tries the first device every minute and gets no replay.

Unfortunately, connecting to debug restarts the app so it is working again. I have made some changes and will monitor the situation.

My Velux roof window is somehow interpreted as a curtain and not a window. Is this a known issue?

image

If you mean the type of control that is presented then then that is all Homey has for position information.

Alright, thanks for the reply. My issue is actually with HomeKit where it shows the window as a curtain, when I would expect it to show up as a window. I’m using Homeykit - any idea what could cause this?

Ah OK, Homey doesn’t understand windows.
Here is a list of classes, which are the types of devices:
https://developer.athom.com/docs/apps-reference
So I’m not sure how HomeyKit can report them as Windows. If anyone knows what class would work then let me know.

Hello,

I cannot connect me with the APP.

Have this: Failed to log in.
Error: Failed to authenticate

Have disconnect the app for more then 6 hours

What can i do ?

Have you tried to restart the app?

Most server issues sort them selves out within an hour or two so possibly an app issue.

Yes i have restart the app. I have the la test version of the app

Could you send me the information log?
Make sure it’s enabled for about 5 minutes and then tap on the Send log button.

Hello,

I send heir evening the log, ece that its suitable?

I have the possibility of ordering my awning and velux directly from the conexoon box, on the other hand I no longer have the possibility of doing it by the app with Homey and its no longer works either from Home Assisstant and its integration or I have it. used for the dashboard on the tablet.

Are you sure your login information hasn’t changed?
It’s strange that HA has stopped working as well, so it points to either a problem with your account or Somfy have changed something.

Could you try selecting a different connection url in the Configure App page. Maybe the second option (Alternative 1).

Yes my access data is correct. I reconnected to the conexoon. Connect to the somfy site and it works perfectly.

I also tested the other 2 alternatives in the app, I always have the same error message

Very frustrating. I will get in touch with my contact at Somfy to find out if they are making breaking changes. Unfortunately, as it is an unofficial API I can’t guarantee any help from them.

Thank you very much for the help, everything is good to take.

Unfortunately I am a little disappointed with Somfy with their monopoly, which at the same time provides security for access to the product. Too bad also that I do not have direct access, without going through an external server, to the products that are found at home. All these problems that we have since time will be resolved if I understand correctly.

Hello,

this morning I said to myself I was going to try to see if its working, I put my username and password and it works!

I don’t know why but hey it works …

1 Like