Homey Community Forum

Somfy Tahoma & Connexoon (v2.1.7)

I did. But once set by a flow, then at settings the input field becomes empty:

Seconds indeed.

2 Likes

Yes, it’s seconds.

1 Like

[quote=“rvdeijk, post:344, topic:35206, full:true”]

I did. But once set by a flow, then at settings the input field becomes empty:

Also on 2.1.5. Same result.

The new flow cards to toggle polling on/off and set sync speed is perfect! :clap:
Is there anywhere I can see status on pollmode and sync speed set by flowcards?
If not, maybe the app could update the input field under settings; 0=OFF else is actuell sync speed showing…?

1 Like

Version 2.1.6 (Test version)

  • Added Boost mode to temporarily increase polling speed when a cover command is sent.
    Boost mode is disabled when all the commands are complete or for a maximum of 45 seconds after the last command. Boost mode sync interval is 3 seconds (which Somfy stated is allowed for short bursts).
  • Added setting to switch off polling.
    The new setting is in the app configuration page. When a cover is moved, Boost mode is activated.
  • Changes to polling mode and sync speed now show in app settings (except in Boost mode).
  • Added support for io:SimpleBioclimaticPergolaIOComponent. This is a Pergola cover.
    This cover uses different commands and status names to other covers so needs to be verified.
1 Like

I tested 2.1.6

Great option to have, thx

Tested and works perfectly :smile:

I tried, but I’m not seeing a boost of 3sec. My sync speed was randomly set to 275, when I changed the position in the homey app I received an update in the UI (graph) between 10 and 25 sec.
However I do see the boost in the log:

  {
    "time": "2020-10-18T08:16:39.657Z",
    "source": "Boost Sync",
    "data": {
      "message": "Increased Polling",
      "stack": {
        "syncInterval": 3
      }
    }
  },

Lots of code and then

  {
    "time": "2020-10-18T08:17:10.897Z",
    "source": "UnBoost Sync",
    "data": {
      "message": "Reverting to previous Polling",
      "stack": {
        "timeOut": false,
        "pollingMode": true,
        "syncInterval": 275
      }
    }
  },

I have send the full log.
Any idea why the graph UI does not update every 3 sec. Cause that would be the purpose of a boost sync?

That was the idea. I have no way to test this as I only have RTS covers so no feedback.

I can see in your log that:
The command was processed at “2020-10-18T08:16:42.788Z”.
And the app received 2 position updates:
52% at “2020-10-18T08:16:55.246Z”
00% at “2020-10-18T08:17:10.873Z”.

It could just be that Homey’s UI is does not update fast enough even though there is about 15 seconds between updates.

Yes could be, but if that’s the case (need some confirmation from Athom) then it’s not needed to have a boost and generate extra load to Somfy?
Or are there more reasons to boost the sync speed, besides UI feedback. For example to trigger flows faster.

Those updates comes from Somfy server? Then it would mean that Somfy is not fast enough. Cause in 15 seconds it should have got 5 position updates.

It is to ensure the UI is finally synchronised, but I was hoping it would provide a nice animation.

Yes, they come from the server events. I might increase the boost interval to 10 seconds if 3 seconds is not going to benefit the UI.

2 Likes

Hi,
Same connection issue for me, and Somfy email received.
I use a Connexoon hub with my Homey to control 3 Somfy IO rollers with flows.
I don’t understand all in this post, is there a solution now?
I’ve Somfy 2.1.2 app version in Homey.
Thank you

Which connection issue do you have?

Version 2.1.2 addresses the specific issue mentioned in the Somfy email. The later test versions have more ways to reduce the connection time for most users.

Version 2.1.7 is now in test.

This version adds support for the new devices users have requested but it also increases the Boost interval to 10 seconds.

The new devices are only partially tested as I don’t have them myself to try, so I can only do basic simulations.

If you still have devices that are not supported, send me the devices log and a PM explaining which devices you would like added.
I think I have caught up with all the requests, but the last two weeks have been a bit hectic so if I have missed any then please let me know.

2 Likes

I’ve 401 error login from Homey Somfy app.
How to obtain a test app version?

In version 2.1.2 you could try changing the option for OAuth to see if that helps.
The latest test version automatically tries the different option so (hopefully) find one that works.

The devices you have added seems to be Philips Hue light bulbs and they are already supported with the Philips Hue Zigbee app. Not sure why they are now added into Somfy app? Or am I just confused by the images and text :smile:

hue:GenericExtendedColorLightHUEComponent
hue:HueLuxHUEComponent
hue:ExtendedColorLightCandleHUEComponent
hue:LightStripsPlusHUEComponent
hue:ColorTemperatureLightBulbHUEComponent

Tahoma can host them so they appear in the the Tahoma app. Therefore to get external access I guess they need to be catered for.
Personally I have a Hue bridge and use the Hue app for my Hue devices so I can’t say for sure.

Ah ok, clear. So you won’t need to bother about SDK3. You read them from the tahoma box (somfy server). Good to know :smile:
I doubt the benefit of having those Philips bulbs connected in the tahamo box. Maybe someone could explain that.

Off-topic: I use homey for the Hue light bulbs to extend the zigbee mesh.

Thank you very much ! It works with 2.1.7 test version!

1 Like

I keep getting empty device logs through. If someone is having an issue then please get in touch so I can assist you.

1 Like

I still have a rather important question, with my numerous Velux windows and their blinds and marquisette plus all my slatted blinds in the house.
What does Somfy and Homey’s future look like?

I must have a solution, to release the blinds with a remote control is one thing, but I have made automation for the veranda for protection against the sun and to regulate the temperature. Impossible to do this by hand!

Do I have another solution, Home Assistant or other? Will the API problem be the same?

HA has two modules for Somfy. One uses the official API but that has very limited device support and is also having problems with regular polling. The other uses the same API as the Homey app.
I am hoping that the changes I have made will satisfy Somfy but we are still in contact with them to clarify what is acceptable.
Unfortunately we will just have to wait for Somfy to make a decision. They can either block about 15000 (combined HA and Homey) users or come to some agreement. If they have any business sense it should be the later but one never can predict these things.

1 Like