Homey Community Forum

SONOS speaker not found, can't add again (ERROR_RESOURCE_GONE)

#1

I had my Sonos connected to my Homey for a while now. Had some trouble with a movement detection-flow, so I changed it to a countdown timer yesterday. It worked fine, until this morning, where my Homey simply couldn’t find the Sonos anymore. I tried some simple flows (if motion detected and sonos is playing, write message), but no luck. Controlling the Sonos from the Homey-app didn’t work either (network errors).

So I removed my Sonos, and tried to add it again. That’s where I got the “ERROR_RESOURCE_GONE” message after logging in on Sonos. I rebooted my speaker, and I rebooted my Homey, but nothing works.

Has anyone tried this before, maybe with some other device? Is there a fix?
I made a screen recording:

Edit: after restarting my router, I now get the error “No new devices have been found”. This is weird, because when I check in the app, it says there are no devices connected. The music is playing and I can control it from the real Sonos-app from where I’m sitting, so it’s definitely on my network.

#2

I have the same since this morning.
I have updated the original Sonos controller app on my iphone yesterday to the latest version 10.2, maybe that is causing this?
Did you also update the Sonos app?

#3

Not actively, but maybe it did it automatically. But it would also be weird if the original Sonos app is interfering, because Homey doesn’t use that one at all. Maybe I have to update the speaker? Going to check for updates now.

Edit: No updates available.

#4

Which version of the Sonos app do you have installed on your Homey?
The latest version is 5.0.10. Could you install this version and re-add your Sonos speakers to see if this solves the issue?

#5

I had the same problem this morning.
Deleted the app
Reinstalled it.

When I click on a Sonos device I get the message error_resource_gone

#6

Could you try to delete the device and re-add it to Homey?

#7

I re-installed the app yesterday, so according to https://apps.athom.com/app/com.sonos, it is the version you mention. It’s possible to delete a device, but impossible to re-add a device, as it will say “No new devices have been found”.

All this information was also available in the start post btw.

#8

Update: I tried adding the speaker again, and it worked without trouble. I’m not home, so I am not able to test the flows, but I guess they work as they did before.

#9

After updating the Homey app to version 2.3.1.306 i could add my Sonos speakers again and all works good now.
Had to edit all my Sonos flows because the speakercards were gone there.

#10

Removed the players
De-installed the app
Restarted Homey
Installerend the app
When adding the players, message:
Error_resource_gone

iOS, Homey 2.3.0
Latest version

#11

Same error here, also updated and added to Google maybe that’s the issue?

#12

Yesterday I also connected Homey to. Google

#13

If using an iphone, then update to the Homey app version 2.3.1, available in apple TestFlight. This solved the Sonos problems.

#15

Sorry found it an yes works! Thanks!!

#16

It works after updating!