Homey Community Forum

Strange MQTT Client behavior

That sounds interesting.

Do I use the MQTT Hub App to create a MQTT device ?. I’ve never really used it before .

yes - add new device and choose MQTT hub device.

Thanks. I just downloaded it.

It looks like theres a bit to learn but I’d dare say it will sort out my problems for now. The disabling of flows issue is happening on a daily basis now and is majorly screwing up my house hold. Nearly tripped over last night as my lights wouldn’t turn on… :weary:

Would you mind telling me quickly how can I add or create a Virtual/MQTT device based on the input of a 433Mhz motion sensor… ?

Whenever it trIggers it sends a MQTT message containing the text “076F2C”.

How do I translate that into making a virtual/MQTT type device ?

Thanks again …

@Russell_S A general example can be found here:

Thanks mate.

Tonight I spent some more time making sure all my settings were correct as I didn’t know much about Tasmota, using MQTT or setting up Homey when I got my system originally going…

With the original “disabling of flows” errors that I was experiencing I think that may of been due to the original code of the MQTT client as that now doesn’t occur anymore when I try to discover new Tasmota devices.

After some thought I think I might have a theory as to why these new more recent errors are occurring .

Tonight I went to check the settings of my SonOff RF bridge (Tasmota) configuration. I noticed that I had previously set logging to “all”. I did this (at the time) as I was having issues getting it going . I never changed those settings back to default and just kept using them. Tonight I put those logging settings back to normal default…

After doing that change Ive noticed all my flows wont receive any inputs or triggers anymore… I went through some MQTT client logs and noticed it would occasionally reference “tele/rfbridge1” as the topic.

I’ve always use “stat/rfbridge1” in my flows…

Tonight I went and changed all my flows to listen to “tele/rfbridge1” instead . Now they work again …

Do you think all the recent disable flow errors I was experiencing over the last few days was due to the log settings I had previously setup on my SonOff-RF bridge combined with using “stat/rfbridge1” when listening for wildcards in my flows ?

It’s too early to tell but everything seems to be runnings fine since I made these new changes …