Homey Community Forum

Sure Petcare App - (Sureflap Pet Door/Sureflap Cat Flap)

Strange, cannot log in either…

App not working! Had to go back to 1.0.14.

The authorization call was the version of my SDK branch and got mixed up somehow.

I’ve added a new release:

v1.0.20 - 08.11.2020

  • bugfix login call failed
  • bugfix logout button

v1.0.21 - 08.11.2020

  • prevent sending initial value

Ok, login is ok, but still no feeder accessible, one pic in app, grey battery icon. Ok adding the feeder, so will let my cat pass the verdict, made one test flow, cat is still out (hunting mice)

Feeder part of the app still not working, can add it, but no data when added. Only displays the battery page (greyed out, no data) and the flows page.

Can you send a log?

Diag

b64b6497-ceb9-48f8-8255-a42a24a691b6

Thanks for testing. It looks like the API is changed somehow. I’ve added an extra check for the missing properties.

v1.0.22 - 09.11.2020

  • bugfix in sending the initial value
  • simplify analysing pet data

Looks good, will test on Missy and Miss

Did you remove the apps front page? Showing 3 weights… Now it is showing weight bowl, battery and flow page.

It show either 2 weights or 1 weight (left/right or single bowl). Based on the configuration of the feeder.

1 Like

Illustrated in Grafana, so works perfectly! Both influx and prometheus as source.

1 Like

Hmmm Login page keeps loading after sending credentials…

Thanks for testing. I cannot reproduce your issue. Can you send a log to the developer?

a81cf196-8df4-4d0a-b98f-90a5fd3d59d9
Does this contain the needed debug info?

Thank you
J

Cannot find any error or bug. Did you try to reboot homey? Maybe there is some condition I do not know about.

Hello

Yes, Homey was rebooted a couple of times. I have the homey device since last week.
There are no special conditions that I am aware of…
Tried to login with a Samsung S20 and S9, once credentials were provided the page stays blank with turning half circle icon

Logging in to Honeywell Evohome app with Homey followed a somewhat similar procedure, there was no issue…
No idea why can’t login to the sure petcare app :confused:

When restarting homey app on the phone, or even the phone itself… nothing changes -> If I go to configure app, I immediately get the blank page with turning circle.

If I remove the app from Homey, then reinstall it… I can get back the login page for sure petcare, but result after logging in stays the same.