Homey Community Forum

Swimming pool thermometer - 433 MHz

Cool!
Thanks for your awesome work, as always :slight_smile:

After updating Homey to the current Firmware I reinstalled your Fibaro Fix again, but still not working. Is it because the new Firmware?

did you re-install my version? or the app store version, the fix is still not in the app store, nothing has changed in terms of zwave on homey in the latest few updates, so definitely not an homey update can break that

yeah. reinstalled your version because the sensor was not reporting since the update i guess. well thats strange.

If I have time I’ll install Caseda’s version this week.
Been having some problems with my sensor, had to remove it (it might be broken).
I’ll see what happens and report back.

[edit]
@Caseda, just installed your version, temp showed up immediately :slight_smile:
I’ll try to get Athom to include your fix.

Hi!
I am new to this forum and a beginner with Homey. I am very happy to have found this thread since I’m just trying to put together a pool thermometer, but it fails. I hope that somebody might help me forward? I have connected a Fibaro Universal Sensor to a temp probe DS18B20, following the diagrams (see attached pic), so it should be correct and all contacts should be connected properly.
In the Homey app on my smartphone (S9+ Android 9), in “Devices”, I chose the brand Fibaro and installed the “Universal Binary Sensor” by triple-pressing the button. The installation seems to have worked because if i try to do it again, I get status.already_added. Even though no new device show up in the device list. I assumed that the Thermometer should be visible there…? Does this mean that the Universal Sensor seems to be installed but not the temp sensor?
I also run the CLI command “npm i -g athom-cli” with the following result:
warning.js

  • athom-cli@2.1.90
    updated 3 packages in 8.391s

I wonder if anyone might help and give me some direction as regards to how to proceed? I would be really grateful for any idea in getting the Temp to work too… Thanks in advance!

Welcome to the community!

The temperature sensors are displayed inside the universal sensor device (hold to open in the mobile app).

The temperature sensor does need to be connected (mandatory) to the binary sensor before you include it into Homey.
So if all say a dash (-) then you probably included it into Homey before you connected the temperature sensor, or that extension cable is too long.
If this is the case you will have to remove it from Homey/reset the device by going either in the device’s settings, and click remove and follow the instructions, or go to more… -> settings -> z-wave -> remove device so it will reset the device internally (also why you got the message that it already was included) and remove it from Homey if it was there.

Hi,
Thank you for your reply and thanks for the welcome! :smiley:

I had the temp probe connected to the Fibaro Universal sensor from the start, but in the Devices menu (pic 1 below) no new device was added (where I expected a new device for the temperature probe or the Universal Sensor?). Under the menu More… > Apps >, a Fibaro app appeared (pic 2 below), but it says ‘This app does not have any devices yet’.

Today, I removed the extension cable and put the temp probe together with the sensor again. Then I uninstalled the Fibaro app, removed the Z-wave device, reset the Z-wave network, reset the Fibaro Universal Sensor, tried to install the Fibaro unit again, run the CLI command. It didn’t work to install the Fibaro. I got time out error, which could mean badly connected cables? I’ll try to get some better wire connectors tomorrow, to make sure the connections are good. Then I’ll give it another try.
I guess the CLI command should be run after installing the Fibaro Unit, to overwrite the firmware?
Thanks for the advice! :+1: :sun_with_face:

Pic 1:

Pic 2:

There is no need for installing the app via CLI when using the binary sensor, temperature fix in this topic is only for the v1 window/door sensor.

Hi @Caseda, i confirm too that the fix is working for a V1 sensor, thanks :slight_smile:

Thanks @Caseda
But I still do not get Homey to work with the Fibaro Universal Sensor and the temp probe. I reconnected all cables and checked with a multineter to see if the IN1 and IN2 cables are “alive”. I do get some data, which change when I warm the temp probe, which should mean that the Universal Sensor not dead.
(Link to the multimeter:
http://www.barebo.com/katalog/IboxServlet?p=IXK090&AID=963601)
I have reset Zwave, reinstalled the Fibaro app and trying to press the Fibaro button 3 times etc, but Homey still does not find it… I have no idea why.
Do you by any chance have more suggestions how to get the Homey to find the probe?
Thanks and best regards,
Ulrika

You do get a device in Homey after inclusion?
And not a “generic zwave device”.
Or doesn’t it find the device at all?

And connected the sensor(s) before you included it, and made sure that they are connected properly, all 3 wires.
And that it really is a ds18b20 and not an pt*** thermistor or something like that