Homey Community Forum

Switching on zigbee lamps (serie of 10) slow all of a sudden

Hi guys

Thankfully I’m not a regular on this forum. Manage to stay up and running without any help, till yesterday…
All of a sudden I have an issue with a serie 10 zigbee spots (tradfri gu10). They switch on or dim to a specific level but there is a huge lag between the command and execute also they respond sequential instead of in parallel like they used to do before yesterday.
I have performed two reboots. No luck so far.
Setup; 10 tradfri dimmable gu10 spots > switched or dimmed via a flow command > just 10 spots in one flow ‘switch on’ or ‘change dim level to x’. I have set no delay. Nevertheless it takes approximately 1 second between each spot to switch on. So the entire flow takes about 10/12 seconds. Before it took approximately 1 second and all switching or dimming ran in parallel.

I noticed I have the same issue with another flow that uses a combination of tradfri e27, e14, kaku and other zigbee devices (led strip and osram power plug).

Any idea


?

Hi Emiel,

Afaik zigbee tends to get slower when having over 35 to 40 zigbee devices paired.
Did you add some devices recently?
Did your wifi change channels? Is it on “auto” or did you lock it to a channel?
(Zigbee and wifi operate in the same frequency range)

Well, you could help others with more problems every now and then, in case you’re bored😅

A way to avoid delays of whole seconds is to create 3 flows which control 1/3 of the lights each.
Flow 1 switches on say 3 lights and starts flow 2
Flow 2 switches on another set of 3 lights and starts flow 3
Flow3 switch on the last set of 3 or 4 lights .
Flows are started x msecs after eachother, which is a lot quicker then adding a delay of 1 sec between every set of 3 lights.

Another option is to use the < group > app. It can group anything with similar possibilities, like dim & hue etc etc.
It has a build in option, to switch every item in the group with a little delay in between. It’s adjustable per msec.
So the action card becomes one card:
dim a group of your preferred lights to the value of variable [Keuken dim]

Thanks Peter!
As a matter of fact I did add two or three bulbsgu10 spots earlier last week. We have a lot of zigbee devices (mostly bulbs and spots). Never counted them but it could really add up to 35/40 if not more.
Will check tomorrow. What are the options if we run into the 35/40 devices? I knew this was an issue with Z-wave but never thought it was for zigbee.

Your second post is more referring to intentional delays. That’s not the case here. I don’t want any delays at all. It just needs to respond ASAP and for all devices in one instance/in parallel.
I will look into the ‘group’ suggestion. Do you think it will solve the issue? I have a feeling it is related to something else. Perhaps more to the amount of devices.

You can find out the exact amount of Zigbee devices quite easily from here: Homey Developer Tools

Have you checked your Homey’s system load? It sounds like it might be overloaded, which could slow down everything.

Also, if you’re still using the original Athom power supply for your Homey, try and see if replacing it with something better (name-brand USB charger that can deliver at least 2A) fixes your problems.

FWIW, the “<group>” app likely won’t fix your problems, it just makes handling groups of devices easier.

Hi Robert,
Indeed the < group > app can’t change anything about the lag which occurs when having over 35 to 40 zigbee devices.

I just want to say the < group > app does switch all devices in a group with a delay between every device, if set.
So I think it can help solve the issue to switch devices with 10 pieces at once and some random lights just won’t respond.

Tested here with the “all groundfloor lights” group. They switch on one by one.
This makes switching of a large group of devices more reliable.

OP doesn’t want to add delays and was wondering if <group> would solve the issue without having to use them. It doesn’t, that’s what I was referring to :slight_smile:

(FWIW, having to add delays to switch multiple devices is not a solution, it’s a workaround. Homey is pretty bad at sending multiple commands at the same time, which isn’t helped by Homey not supporting Zigbee groups, so it has to send separate commands to each light instead of just a single one for a group)

I know, but I’m trying to think of solutions or workarounds. I’m not very boolean so to speak :wink:
Sometimes approaching things a little different and reading about workarounds can give new insights in my experience.

But if OP don’t want to add delays, there’s no other option than removal of zigbee devices one by one, until the lag disappears.
So problem solved.