Homey Community Forum

Tasmota MQTT application

Sorry, it looks like I can’t fix this easily at least for now. Flowcard triggered by Homey SDK itself once I changed property. Of course, I can add delay to check if the property didn’t switch back but it will influence everything. So I will live it this way and will try to find some workaround in next version.

Hello,
I have noticed recently, that when I remove the Tasmota device from Tasmota’s MQTT app (ver 0.8.5) (Homey (5.0.0)) and add it again (with Tasmota’s MQTT app), then for the power measuring device (e.g. Sonoff’s POW2, or Athom’s ZEU socket) the Homey’s energy tab is not recognising the meter readings from these devices anymore (even when they are presenent in the Tasmota device’s app’s GUI, and Insights).

The visible differences I have noticed are that the Tasmota’s devices meters’ positions (in app’s GUI) have changed (prior removal of the device, the upper left corner started with a ‘voltage’ etc, then after reinsertion it starts with a ‘power meter’). Also, under the Tasmota device’s additional settings’, there are ‘additional sensors’ (named “total”, “yesterday” etc) listed for the device after the newer insertion, while the same device had this field empty prior removal).
(These devices have currently Tasmota v.9.3.1on them, but it was the same also for v.9.2.0.)

Has anybody else also noticed anything like that? Are there any suggestions of how to get the meter readings back to Homey’s Energy computation? And would there be an option to change the position of the meters’ icons in the Tasmota device’s tab (so that it would show at least voltage and current in the upper part of the window)?

Thank you in advance.
Janno

Hi, thanks for the detailed report. It looks like my fault. Thing is that energy in tasmota reported the same way as sensors so I wanted to have unified code to process sensors and energy. I will not dig dip into details but apparently, Homey uses energy values for devices only if they used with specific properties names. Will try to fix this asap.

Oh, that sounds really perfect! I wasn’t sure about if it was about Homey (5.0) or Tasmota or anything else…
Other than that, one additional feature You could think of, might be introducing the (Sonoff’s) “L1MusicSync” enable/disable (or also settings) also to the GUI, which was introduced to Tasmota recently…

Hi Pavlo,
thanks for your work. I’m very grateful because you makes live better for Tasmota-Sonoff users like me. And thanks also for your recent implemetation of sensors.
Yesterday I successufully tasmotized a Sonoff Zigbee Bridge, and joined an (zigbee) Aqara Water Leak Sensor. Then I added the bridge to Homey through your app. I thought that I could be able to control the water sensor from Homey, but the bridge says “No available controls - This device has no available controls for display”. I’d like to use the water sensor in some flow of mines.
Sure someone could say that I could add the water sensor directly to Homey, but a) my building (a school) is very large, and the Sonoff ZigBee Bridge with is capability to bridge wifi<->zigbee would be the best solution, and b) the two (Sonoff Bridge and Aqara water leak sensor) are wonderfully cheap (from Aliexpress).

I don’t really sure what this setting does, and how it should be used. Can you explain, please? Is it available only for Sonoff L1?

I have mixed feelings about this device. On one hand, it should be relatively easy to add sensors (such as Aquara temperature, door contact, or water leak) but on another hand, it would be a huge pain to add all controlled devices as Zigbee lights. So I am not sure if I want to open this Pandora box and start supporting zigbee2tasmota. I wouldn’t be able to support this full scale for sure. I will think about it. Anyway, even if I will decide to implement this it will take some time so don’t expect it soon.

afaik, “L1Musicsync” enables the microphone usage via Tasmota (for Sonoff), so that the L1-device (the ones, which have a built-in microphone) flashes its lights based on surrounding sound, e.g. music… I would assume that some people are using this solution behind a TV-set, if not making any addressable LED-strip solutions. Kids would like that as well ;). L1-device is the RGB-LED controller.
https://tasmota.github.io/docs/Commands/#l1musicsync
There is also a review of the L1 Lite (lower power, indoors) version:

Thanks for your fast reply. I understand.
If I can be of some type of support in it (I’m a dummy user however), when you possibly try, please let me know.

Thanks! I will think about supporting it. Not really clear to me how to detect that this feature is supported.

Actually, I already took a look at these zigbee2tasmota things and it looks like it could work for the Zigbee sensors the same way (or with minimal changes) as wired sensors. Now I am working on sensors related modifications so it is a good time to try to make it more general. This solution wouldn’t be pretty (for example to make it generic I will need to use a sensor address like 0x7C5A instead of name) but it will work. So I ordered Sonoff Zigbee bridge (will arrive in 10-14 days) but I don’t have any water leak sensors. It would help if you will provide me MQTT payload related to Zigbee for your sensors. It should look similar to this (this one is for temperature sensor):

MQT: tele/%topic%/SENSOR ={“ZbReceived”: {“0x8F20”: {“Name”: “Kitchen”, “Voltage”: 2.995, “Battery”: 98, “Temperature”: 21.01, “Humidity”: 53.68, “Pressure”: 1004.04, “PressureUnit”: “hPa”, “Endpoint”: 1, “LinkQuality”: 88}}

You can find this in the console of your Zigbee gateway.

Hi Pavlo,
you’re really a smart guy!

Here the payload related to the Aqara Water Leak sensor:

MQT: tele/tasmota_9C20F7/SENSOR = {“ZbReceived”:{“0xD9A3”:{“Device”:“0xD9A3”,“BatteryVoltage”:3.12,“BatteryPercentage”:100,“Xiaomi_64”:0,“Endpoint”:1,“LinkQuality”:152}}}

Thanks again!

Sorry,
the previous was the payload in a dry condition. Here I add what happened when I put the sensor in contact with water:

17:12:10.091 MQT: tele/tasmota_9C20F7/SENSOR = {“ZbReceived”:{“0xD9A3”:{“Device”:“0xD9A3”,“ModelId”:“lumi.sensor_wleak.aq1”,“BatteryVoltage”:3.12,“BatteryPercentage”:100,“Xiaomi_64”:0,“Endpoint”:1,“LinkQuality”:126}}}
17:12:17.815 ZIG: {“ZbEZSPReceived”:“450000040100050101000100007CF0D8A3D9FFFF09191800010000FF000002”}
17:12:17.817 ZIG: {“ZbZCLReceived”:{“groupid”:0,“clusterid”:“0x0500”,“srcaddr”:“0xD9A3”,“srcendpoint”:1,“dstendpoint”:1,“wasbroadcast”:0,“LinkQuality”:123,“securityuse”:0,“seqnumber”:124,“fc”:“0x19”,“frametype”:1,“direction”:1,“disableresp”:1,“manuf”:“0x0000”,“transact”:24,“cmdid”:“0x00”,“payload”:“010000FF0000”}}
17:12:17.820 ZIG: ZbZCLRawReceived: {“0xD9A3”:{“0500<00”:“010000FF0000”,“ZoneStatusChange”:1,“Endpoint”:1,“LinkQuality”:123}}
17:12:17.824 MQT: tele/tasmota_9C20F7/SENSOR = {“ZbReceived”:{“0xD9A3”:{“Device”:“0xD9A3”,“0500<00”:“010000FF0000”,“ZoneStatusChange”:1,“Endpoint”:1,“LinkQuality”:123}}}

Hope it helps.

Thanks, for the input data it should help!

Meanwhile, I almost finished fixing power monitoring and support for analog inputs. Reworked almost all code related to sensors, now it is more logical, compact, and faster but probably will consume more memory. Also made preparations for support of Zigbee sensors. If you are using devices with energy monitoring like Sonoff POW2 and added it in version 0.8.5 they will stop working you will need to remove them and add them again, sorry for that (devices added earlier should work). The test version is here: Tasmota MQTT | Homey
I didn’t tested it a lot yet so be warned it can be buggy. And most likely I will not publish it as release (want to add Zigbee sensors support before releasing the new version)