Homey Community Forum

Tasmota MQTT application

@pavlo, I have the problem that the tiles are not shown as disabled, for example, when a switch is disabled.

Is it an error or do you have an idea what the problem could be?

Hi @Joka,
I suppose by disable you meant turned off? If you have multiple switches under one device tile will be showed as turned off if at least one switch is turned on, only if all switches turned off - tile will show that device turned off.

No multiple switch, only one switch (actually a plug with tasmota) is connected to the device tile. The plug is also configured with the Sonoff app. This displays the switch status correctly.

It should not be like this, I will try to reproduce problem and fix it

You should be able to reproduce it with these steps:

  1. Push the tile longer to open the on off dialog of the device
  2. Switch on the device
  3. Go back to the tile view
  4. the tile should not shown the correct status

The tile shows the correct status if you switch the device on off in the tile view!

@Joka thanks for detailed steps. I was sure this thing works. It looks like Homey team changed something in events processing. Anyway, I think I fixed it. Please check beta version 0.6.1 here Tasmota MQTT beta

Works like charm, thanks for your fast fix pavlo!

Hi pavlo, me again :wink:

I think there is a bigger problem with the mqtt listening.

I use the Then -> turn off flow command as an example.

  1. Bug: If I turn off a switch physically it triggers the mqtt command and the flow four times. One time would be correct. I checked this with push notifications. And also cross checked it with the SonOff App from Robert which handels it right.

  2. Bug: With the Then -> turn off (example) the app seems to trigger also the periodically sensor/tele signal and handels it like a real cmnd. Which leads to a real flow trigger each time. And again, I cross checked this with the SonOff App from Robert which handels it right.

Please check these problems, because they are serious.

Don’t missunderstand me, I realy appreciate the feature set in comparison to Roberts app, but it has to be reliable.

And regarding to this problem there is no difference between the 0.6.0 and 0.6.1 version.

THX

Hi @Joka,

I am happy that somebody reporting bugs so no problem and also it is really good that you reported it today. Afraid next couple of weeks I will be unavailable.
About bug: I have a strong feeling that all of this caused by some changes in latest homey fw, because I tested those use cases and they worked fine. Anyway, I think I fixed it. Please, try 0.6.2 version Tasmota MQTT beta

2All, just want to share my plans I will be unavailable till 20th of September. After that, I hope to have a little bit more time for new functionality development. I have now Sonoff iFan3 device and Sonoff TH10 with temperature sensor on my hands and I plan to add support for them (fans and at least some sensors).

1 Like

I will test the new version!

I’m on homey fw4.2. But updated my tasmota devices to 8.4 and have a feeling that they changes a few things, because I had to configure features via the console which worked before out of the box.

THX

The two Bugs are fixed, thanks again!

Hi everybody,
Version 0.7.0 is on beta now you can try it here Tasmota MQTT 0.7.0 beta. I added support for devices with fan tested only with Sonoff iFan03 so if somebody has iFan02 (not sure if there is any other device with fan support), please try it and write here if everything OK. Also, I added 4 different icons for different types of devices (light bulb, power socket, power strip, and fan). Icons will be added automatically only for newly added devices so if you want it for the existing device you will need to remove it and add again (sorry no other way). Hope you will like new version.

Did somebody already tried the tasmota app in Homey v5?

I can’t get it to work and I guess it is the MQTT client is the issue, it connects to my broker, but doesn’t receives anything.

Sonoff works fine with my switch except power measuring

works for me.