Homey Community Forum

Teckin Steckdosen geflasht / Probleme mit Einbindung / MQTT

Hallo Zusammen,

habe für kleines Geld meine Teckin Cloud Steckdosen flashen lassen. Leider bekomme ich die Geräte nicht über Sonoff eingebunden.

Hier ein paar Screenshots meiner Konfig, vielleicht findet ja jemand von euch spontan den Fehler.

Versuche das Gerät als Generic Tasmota einzubinden. Beim einbinden fordert das System einen Softreset und endet schließlich im Timeout.

Danke vorab für Ratschläge

Grüße
Daniel

Du brauchst noch die Tasmota App sowie die MQTT Client App.
Mit der Sonoff App gehen Tasmota Devices nicht.
Zumindest hab ich meine Tasmota Devices nicht über Sonoff einbinden können.

1 Like

Danke für die Info.
Gibt es irgendwo einen Leitfaden wie der Client konfiguriert werden muss? Ich verbringe schon den halben Tag mit Trial and Error :frowning:

Ohje, ich hab auch ewig gesucht. Weiß aber nimmer so genau, wo ich due anleitung her hatte.

Ich kann aber gerne morgen mal meine Konfig hier posten.
Heute reichts mir leider nimmer.

das wäre super :slight_smile:

Als erstes würde ich mir einen MQTT Client für Win(FX)/OSX(MQTT Explorer) /Linux besorgen, so kannst du auf dem Borker sehen ob sich alle Geräte sauber anmelden.

Du hast den grundsätzlichen Weg:

Steckdose --> Broker
Broker --> Client --> entsprechende Homey App (in deinem Fall Tasmota)

Auf dem Homey muss zusätzlich zum Broker die MQTT Client App laufen!

Würde folgende Schritte durchgehen:
–> MQTT Client am Rechner an Homey MQTT Broker anmelden um eine Live Übersicht zu haben
–> Homey Client App Installieren
–> In der Client App gibts du die IP deines Homeys an, Port 1883, ggf. User und PW
–> Kontrolle via MQTT Client am Rechner ob sich die App sauber meldet.
–> Tasmota App installieren
–> Steckdose einstecken
–> Kontrolle via MQTT Client am Rechner ob sich die Steckdose sauber meldet.
—> Wenn sich die Dose sauber meldet, nochmals abziehen, Geräte inclusive starten und neu einstecken

Tequila hat es schon ganz gut beschrieben.

Ich setz dir hier jetzt mal meine Konfig rein.

Ich habe folgende Apps auf dem Homey installiert:

Als erstes konfigurierst du den Broker. Da musst eigentlich nur einen User anlegen. Den Rest kannst erstmal auf Standard lassen. Den angelegten User brauchst du dann im Client sowie für jede Steckdose.

Dann gehts weiter zum MQTT Client auf dem Homey. Hier musst du die Homey IP sowie den Standard Port 1883 eintragen. Weiter unten dann den eben angelegten User im Broker.

In der Tasmota App musst du gar nichts konfigurieren. Evtl. musst die nur nochmal neu starten, wenn du den Client konfiguriert hast. Die Tasmota App nutzt ja diesen, um mit dem Broker zu kommunizieren.

Die Steckdosen musst ja auch konfigurieren. Hier mal eine von mir.
Da musst du natürlich wieder dein MQTT Broker (also Homey) bei Host eintragen.
Den angelegten User ebenfalls.

1 Like

Danke euch beiden! Auf den ersten Blick habe ich das alles so gemacht. Ich muss jetzt leider gleich weg vom Rechner und versuche das morgen in Ruhe nachzuvollziehen.

Habe einen Explorer installiert und sehe die Steckdose.

image

Habe parallel nochmal Broker, Client und Tasmota App frisch installiert.

Zum ersten Mal bekomme ich nun das hier angezeigt. Bei der ersten Installation der Apps gab es diese Meldungen nicht.

image

Grundlegend scheint es ja zu funktionieren, da der Explorer die Steckdose ja sieht. Seh ich richtig, oder?

Sieht mir eher nach einem Broker Fehler aus? :thinking:

wenn ich über den Browser die Steckdose per Webgui schalte passiert das im Logfile des Broker
image

so ich habe es endlich geschafft.

Problem waren die Steckdosen selbst, ich hatte selbige mit dem Teckin Profil konfiguriert. Die Dosen haben auch im Webgui wunderbar funktioniert. Gestern habe ich dann das Tasmota Generic Profil verwendet und mit den Relais selbst etwas gespielt bis alles im Gui wieder funktionierte.
image

Positiver Nebeneffekt: Die Tasmota App findet die Dosen mittlerweile :slight_smile: