Homey Community Forum

The sad IR - infrared misery

Athom still did not fixed the issue

You might want to add a Wifi controller to it and use this app: https://apps.athom.com/app/nl.climate.daikin

I :heart: it.

Still no improvness on the IR-function in Homey??

This is very Very sad.

I ordered my Homey yesterday and just got it by mail just now. I’m testing the IR but nothing seems to work. The IR use is one of my biggest usecases. How can such a company where connectivity is it’s core business not fix this bug since February?

I can still return it within 30 days. If there is no solution I have no other use for this and will return it. Unfortunately with a bad review (for my case).

You can complain to us, but we are not Athom. So report this to Athom support if you want them to do something with it.

That it isnt working as expected is ofcourse disapointed, and yes if the advertice with it then it should work. So i agree with that.

But what i personaly dont understand, and there for just wondering. If you decided to buy a 300/400 euro domotica controller, did you invest some of your time to read reviews about it, and special about the things your gonna use the most? Or read forums or whatever, just to make sure its the right thing for you.

We cant say, that it isn’t a not known isseu. And that it isnt discussed on whole internet!!

Again just wondering.

1 Like

Just as @RoyWissenburg I’m also curious. You mention you bought Homey where IR should be the biggest usecase.
In that case (if you really don’t need a domotica controller) why didn’t you buy a decent IR controller for about 1/8th of the price of a Homey?

1 Like

The best way to solve this issue is to complain via support@athom.com. I send an email two weeks ago and they told me that it is a known issue for a long time but they don’t know when they are going to solve it.

Lets all send an email and hope for the best :wink:

Homey have failed to fix the ir issue for 6+ months and they are ignoring anyone asking for updates.

The problem is not hardware since it can send (uding IR apps), and even record (try the dev interface). The problem is that it for some reason can’t remember what it is recording and thus can’t send it. It really should be an easy fix, it makes no sense why they won’t do it.

Maybe you should hand them the fix so they can apply it.

Not sure what I did to earn your criticism, nor what it adds to the discussion?

The fact is that Athom has known of this problem which more or less invalidates a complete feature set of their device for a very long time. It can also be proven that is is not a hardware issue with neither reading nor sending signals, it can also be seen that the recording app reacts to the incoming signal so the app is functioning up to that point. It’s not a strange conclusion to draw that it is a big chance the problem lies after receiving the signal and storing the value, or when reading it from where it is stored - an area which in most applications should not pose a serious problem to fix.

Please also note that I say “should”, not “is”. I don’t have access to the source code but I can draw conclusions from an analysis of capabilities and behavior. Finally - since Athom is not open source there is no way for me to “hand them the fix”. But if Athom gave me access to their source code I’d be happy to give it a go. Until that time all I can do is to send them my detailed analysis (which I have done) and remind them that they have paying customers unable to use one of the main features of their device.

The fact that they after 6+ months only have the reply “working hard on this” with no further update is a clear indication that they are in fact not working hard on it. I’m guessing they feel IR is low on their priority and if so I’d love for them to be open and honest about that. Then at least I’d know what to expect.

Again, I don’t get why you are opposed to asking them for a fix and instead prefer attack the person asking?

2 Likes

It’s not criticism, I understand that you must have knowledge because you say it should be an easy fix. So you must have an idea what to do. And it is in all of our benefit if you supply that fix to Athom so they can implement it quickly.
If it is not that easy as you think, it’s gonna cost them time and resources and then everyone else gets mad that the Zigbee stack still isn’t rewritten, or that their devices are not added yet and so on…

1 Like

A seasoned software developer can gauge issues like this and comment on how difficult, or easy, a fix should be. That’s still possible without in-depth knowledge of the system.

Gauging the complexity of an issue and actually providing the fix are two different things. For one, to be able to supply a fix, you need access to the source code.

1 Like

Its funny how community is blaming user requesting Athom to fix the feature that should be working by default. Some kind of Stockholm syndrome? If you look on official Athom web, its one of the features they do marketing on Homey: “Control your TV through Homey! Because Homey features Infrared, all popular TVs are supported, including Samsung, Philips, LG, Panasonic, Sony and many more.
Yes, only one who should be blamed is Athom.

2 Likes

Not a community possibly some members but not the community.

Dont you think if it isa easy fix, they would fixed it already :roll_eyes:

If this is gonna be another “Call each other names” topic then this topic will be closed.
Let’s be nice to each other, there is so much trouble in the world to worry about!
Off-topic posts will be deleted without further notice and that includes reactions to this post.
If u like this post just hit the little heart icon below this post. If u don’t like this post please send me, or any other moderator, a PM.

3 Likes

Well, that part IS working as expected for all TV’s that have their own app. Nothing lied about that.

The complaint here is about the recording function, which imho is something completely different.

But hey, just shoot me for liking Homey instead of constantly (b)(f)laming Athom…

Didnt work for me. Only one of many attempts executed on Samsung TV. But not a deal, this is not a feature I bought Homey for.

Updating with the following reply I got from Athom.

I’m happy to hear that it’s made it’s way up their priority list. If they are gather devices for testing I’d assume they even have a potential fix in place. Then again the claimed they were “working hard on it” 6 months ago so I’m not ready to call it a win just yet.

Let’s see how it plays out.