Homey Community Forum

ThermoFloor / Heatit App (v2.0.2, BETA v2.1.2)

z-wave
app
#81

Hi.

After updating to Homey v2.0 and installing a Z-TRM2(fx) the same day, my z-wave network stopped working. It took about 24h, and I am not sure if it is v2.0 or the Z-TRM2(fx) that is causing this. I have tried to reset my z-wave network and my devices, but the same happened after reinstalling them. Within 24h eveything stopped responding.

Anyone else with similar problems?

1 Like
#82

I have had similar issues. So I removed the devices and disabled the app. Butt still there are some issues with the z-wave link for V2.0. I have to restart homey do to other z-wave devices not working! So i’m not sure this issue is directly tied to this app.

#83

Hi,

I just installed two Z-TRM2(fx) using app beta version 2.1.0 on homey version 1.5.13. The inclusion went fine, I can controll the device and it seems to be operating fine. I have the same problem as stated by SpaceCosmos. I can not get any temperature readings. I have three indicators showing up for temperatur: “temperature”,“external temperature” and “floor temperature”. Neither gets any readings. I get readings for “State”, “Power”, “Power Meter” and “Voltage”.

#84

If you all read a couple of answer up you will see

1 Like
#85

Yes, but is there some place where we can track the progress on this Z-Wave core issue? Thanks

#86

You need to ask Athom about that… Because from my knowlege there isnt any open bugtrackers anymore around homey core. Its just the apps thats made by the community like this one that have bugtrackers on github.

#87

Hi, same problem. After inclusion the Z-TRM2fx functioned properly, but soon other devices failed to communicate. Fibaro and Everspring Z-wave devices were partly functioning,
Eurotronic valves failed completely. Comms errors with all z-wave devices.
Resetted homey, that did not work. Disabled the app and did a homey reset, it didn’t help.
Removed the device, that did fail with a timeout. The device is still present in the z-wave mesh as unknown device. That finally solved my problem for now.

May be an app / device problem on the z-wave network. Do you use multiple apps and different vendors? Any ideas what might cause this problem?

#88

Hi, Great app.
I have one problem, after two-three hours the app isnt updating the power and acumulated kWh. It just says for example "4 hours ago". So I dont get real time.
Also there is no number at floor temperature.

I was wondering when this will be fixed? Otherwive I have to take the fuse from time to time
to see the power and accumulated energy kWh.

Thank you

#89

Hi there, is there any news on support for the HEATIT Z-DIN 616 controller? I have 2 of these today, and planning on more. If I can be of any help with this I would be more than willing to contribute both with donation and othervise…

#90

I’ve just uploaded the v2.1.1 (BETA) update to the app store, adding support for the Z-water:

#91

Q&A time:

I’ll transfer the issues to a public repository for developers; so you’ll be able to track progress.
While adding support for the Z-water, I also notices other S2 related issues… Like not being able to add the S2 security Device Specific Key.

Can you create an issue at the apps Github page and post the Z-wave logging; so I am able to investigate. I do see some issues related to S2 security; but that should not block any communication to other devices.

The power numbers should update on regular interval; also visible in the latest Homey app version. Is this still applicable? Temperature reporting has been addressed before, see ^^

Can you share the Z-DIN 616 controller ID’s (manufacturer ID, productID and productTypeID) when you try to include one of them to Homey as generic Z-wave device?
I only have the corresponding LogicGroup device, with the ID’s I can add support for it.

#92

Manufacturer ID = 564
Product type ID = 3
Product ID = 274

I have also uploaded 3 screenshots with the complete advanced settings from the included z-din. The device is essentially 6 relays in 1 device. There is no usage monitoring… Tell me if I can supply more information

#93

Thanks, just to be sure… this is a Heatit branded version or a Logic Home Control branded version?
The Manufacturer ID (564) refers to Logic Home Control and not Heatit (411).

#94

The version i have is defenetly heatit branded (se enclosed picture). But after your information I have looked at the Logic website (I had never heard of this brand before), and downloaded the user manual. I am now quite convinced that the product is actually a Logic product with heatit stickers. I actually think this might be the case for all the Heatit z-wave products except for the thermostats… I looks to me that you have also created an app for Logic products, I presume it would make more sense to add this product there under its logic name (ZIF5028). Again, please let me know if i can be of any assistance in researching or providing information that might help!

#95

@csaether Yes, I’m developing both apps and was aware of the rebranding.

I’m clairfying with Logic Group development is accidently the incorrect manufacturer ID is used or not.
The Z-water and ZIF5031 do use the same product(Type)ID’s and different manufacturer ID’s.

#96

And now available in the app store.

#97

@TedTolboom from another forum (HomeSeer) I was reading about equivalent pairing and temperature issues with Heatit Z-TRM2fx. Regards to the Temperature not reporting, they have found out that if they deleted/removed “Group 2” they got the temp measurements to report/work. Have you tried this?

#98

Thanks for the feedback @Awangens
I will try if this works also on Homey…

#99

@Awangens can you share a link to the topic?

#100

This is a Norwegian page so you might need to you Google translate on the page!