Homey Community Forum

ThermoFloor / Heatit App (v2.0.2, BETA v2.1.2)

z-wave
app
#101

New addition to the FAQ:

0 Likes

#102

Thanks, tried this but it didn’t solve the issues…
I will send my Z-TRM2fx today to Athom for further analysis…

0 Likes

#103

Brief update on the issue with missing temperature reporting.

Athom analyzed the Z-TRM2fx I send them and found a containment to utilize the temperature reporting.

It appears that during the inclusion the device is not reporting all supported command classes (among others the Multilevel Sensor CC) as it supposed to do. I’ll pass this info back to ThermoFloor.

But we found an approach to still “listen” to the reports that the device is still sending, which will be implemented in the next Homey SW release (Homey SW 2.0.5).
Fortunately, I will not require to remove and re-include the devices.

I will be testing this approach with the current devices as soon as possible and if indeed successful, I will be updating the drivers and release the remaining devices.

2 Likes

#104

Tip: for those who have problem pairing the Z-TRM2fx, move the homey as close as possible before trying! (the older TF 021 was pairing without problems at longer distance from Homey)
After 30-40 failed attempts pairing my Z-TRM2fx when homey was placed in other room 7-8 meters away, I moved the homey to bathroom (1 m from thermostat) and it paired on first attempt, then when it`s first paired, distance seems to be no problem

Great app!
Good luck solving the temp reading issues for Z-TRM2fx

0 Likes

#105

Any progress on the missing temperature reporting @TedTolboom ?

0 Likes

#106

Could anyone here that has experience with Z-Water, create a guide how it is set up in Homey? Preferably with virtual thermostats and not the Z-TRM2fx if possible. Thanks!

0 Likes

#107

Added a bunch of thermostats today. Mostly worked, but got an issue with two of them. Seems like it stopped pairing during Retrieving command class versions (5/12). . It stopped on that message, then I got an error. When I try to pair again I get status.already_added. Any ideas? I moved the Homey right next to them as well.

0 Likes

#108

@Hauken, try to exclude the thermostat before you try to pair the thermostat again…

0 Likes

#109

@TTXy: How do I exclude the thermostat? I excluded it from Futurehome before, and the include and exclude-mode on the thermostat seems to be the same. :thinking:

0 Likes

#110

Try to reset the device. It involved holding in the touch buttons for a while. Cant remember which ones, but you can find it in the manual I had to do it a couple of times to successfully include them.

0 Likes

#111

Go to https://developer.athom.com/tools/zwave and remove your device. Make sure it does not have any power (unplug your power cables) and wait for a few minutes. Then use the remove option from within the developer site.

0 Likes

#112

Hi Ted

Any news on the temperature reporting?

0 Likes

#113

I just uploaded v2.1.2 to the BETA branch of the app store; waiting for Athom’s approval.
This update will fix the temperature reporting of the Z-wave thermostat (FW 1.92), Z-TRM2(fx) and Z-Water when you are using the v2.1.2 version of the app in combination with Homey v2.x (!)

See detailed changelog, including actions from user side to get the temperature reporting working:

Please let me know if this is indeed resulting in working temperature reporting at your side.
If this is confirmed, I will promote v2.1.2 to stable.

0 Likes

#114

Hi Ted

I have now tested Z-TRM2 (fx) with the v2.12 Beta and the setup as described in change log. I I now receive data on current temperature from floor sensor, but i get no data of consumption of electricity, total power consumption, Active / idle etc. only temperate.
Any suggestions?

Br
Jonny

0 Likes

#115

I have three Z-TRM2 (fx) with the v.2.1.2 beta. One was re-included with the updated beta, the other two i just updated the settings as described. I get random read of data on floor temperature, state, power, voltage and power meter. It seems like the data is not updated as frequent as it should. I am still struggeling with the devices freezing and all communication from homey with the devices fail. This happens once every day or two for all three devices. I can still use the devices with the buttons on them. Only way to get them back online is to cut their power for more than 30 seconds by using my fusebox.When they restart they are working. No restart of homey is needed. Not sure if this is a homey issue or the devices. The freezes has been happening since I got the devices, and is not a new problem with the latest beta app.

0 Likes

#116

I am having the same issues at you describe, Christian.
The Z-TRM2 (fx) are “falling” out one by one.

I had the same issue with the same thermostats I my last Wave hub, the FutureHome.
The solution there was to NOT include the thermostats as secure S2, but in S0.

I just want my thermostats to work.

Ted, is there a way to include the thermostats in S0 way? (I did not type in the code/password for the thermostats in Homey)

Arnfinn

0 Likes