Homey Community Forum

Timed flows do not execute, most of the times

I have a weird thing going on. Flows that start on time do not execute most of the times.

I have a few flows like this:
WHEN time is XXX
AND day is XXX
THEN …

The then part is usually light on or off. Which is easily detected when a flow doesn’t run. I also encounter connection errors when saving a flow or when I start the app. I thought that could be a problem for those flows. But I can’t imagine that flows based upon switching something on or off are more reliable?!

Maybe sharing some of those flows can help solving your problems. I encounter the same problems with saving the flows and starting the app. But this does not have any effect on the flows which have to run.

If you have several flows starting at the sane time this can be sometimes a problem if it ate to much flows at the same time

It is really not more than
WHEN time is 7:00
AND day = weekday
THEN turn light X off

Strange!
Do you use this flow already a long time? Or is this a new flow?
Has the problem always been there? Or did the problems start at a point?
Is the problem still present if you have done a PTP?
Which firmware is installed?

Someone made a nice post about just that!

Add some papertrails cards in the and and then section.
You will be able to trace if the flow executes at all

Also strange! :wink:

Strange post or strange that peeps give so less info?

Neither.
It was meant as a joke. I know your post and I think it is very helpful (look who gave you a :heart:), but I didn’t thought about linking it.

PS: I corrected the post. :wink:

1 Like

I have the Dutch version, so I’m not sure how the English version works, but are you sure you have the weekday test? In the Dutch version the weekday test would translate to “Today is a “ for weekdays. “Day is” could also be the day of the month test, so it would then run only once per month.

@Edwin_D I checked this. I have also the Dutch version. The flow card states “de tijd is 7:00” en “vandaag is een weekdag”.
@Rocodamelshekima it’s hard to remember if it worked, when it stopped. I am on the newest non beta firmware. There have been some PTP’s recently, no lunch. Also, a paper trail card isn’t visible in my logs.

Than it’s is weird indeed. Is the flow disabled? Is Homey running on a wrong time/timezone? If you don’t get any papertrails it probably isn’t that it’s running at another time either.
Is there an action in the flow that fails and stops the rest from executing (such as the papertrails logging rule? Missing variables, links to other flows that are broken? Or are you one of those people that reboots Homey every couple of hours (at 7:00) ?

Does Homey think the light’s already off? With KAKU or virtual switches this one’s bugging me at times. If the light is turned on by something outside Homeys view, and the state in Homey is off, it will ignore the command. But then again, I’d expect the papertrail log to show up.

Can you post the flow please?

If he did read the post from the link he would also named his FW version instead of saying “newest”.
Some peeps like to guess, me not anymore.
Why is it so hard to name FW version and share a (screenshot of the) flow?
Why would it be so hard to tell what lamp is connected in the AND part ?
Why would it be so hard to say what happens when we hit the test button?
Mesa done guessing.

I completely agree with you. Sometimes I don’t understand it either. Especially when you pointed already with your finger at it.
Nevertheless I try to give some people a “second chance” and still try to help them. Especially if it is an unusual problem.

Sure, good idea.

That is my personal attitude. Everyone else can handle it differently.

1 Like

Agree!

The last stable release, since May, is firmware 4.2.0. I made also a screenshot te be sure.


The same for my flow.

When testing, everything is checked green, except for the WHEN part. And the lights, as I manually turned them off already. There wasn’t a log entry on 7:30. But there was when I hit the test button.

With my test flow I have no problems.

Homey FW 5.0.0-rc.38

Have you checked the real time (more -> settings -> general -> about) and the Location (more -> location) of your Homey?