Homey Community Forum

Toevoegen Sonoff Basic Tasmota

Beste mede gebruikers van de Homey,

Ik heb gisteren een 4 tal Sonoff basics ontvangen. ik was al voorbereid op het omflashen naar Tasmota en had hier de ook de juiste middelen voor.
Flashen was zeer goed te doen en dit was dan ook in een mum van tijd geregeld.
Echter, ik krijg het niet voor elkaar om ze toe te voegen aan de Homey met de Sonoff app.

Even een aantal stappen die ik uitgevoerd heb.
MQTT Broker geinstalleerd op de Homey
instellingen in de broker bekeken.
op mijn Windows systeem verbinding gemaakt met de broker middels MQtt.fx
verbinding komt probleemloos tot stand.
Middels de browser verbinding gemaakt met de Sonoff en hier de MQTT instellingen goed gezet.
wanneer ik de Sonoff met de browser en en uit zet zie ik de status juist veranderen in MQTT.FX, ik denk dat ik hieruit op kan maken dat de verbinding tussen de Broker(Homey) en de Sonoff goed zijn.

toch zie ik niets verschijnen als ik een Sonoff toe wil voegen in de Sonoff app. en wit scherm met draaiend tandwieltje en de boodschap dat ik de sonoff die ik toe wil voegen moet (Soft)Rebooten.Hierna krijg ik een timeout 3000 sec.

ik heb al een aantal topics gelezen maar tot op heden voor mij geen 1 met de oplossing voor mij. ik hoop dat jullie mij kunnen helpen :slight_smile:

En voer je die reboot van het Sonoff apparaat ook uit? Overigens bestaat er sinds kort ook een specifieke Tasmota app, die is wat makkelijker in gebruik en wordt ook actief ontwikkeld.

Hey Robert, zeker. zowel een herstart als een power cycle door de stekker er uit te trekken.

Thx voor de tip, ik ga ook de andere app maar is proberen :wink:

ook de andere app komt met een timout. Zucht… ik ben lost. ik zal zometeen een printscreen van de hele buts uploaden.

Ik ga er even van uit dat de Homey apps ook ingesteld zijn op 192.168.178.73 voor de MQTT broker. Ik weet niet precies hoe de andere Homey app werkt m.b.t. het detecteren van apparaten, maar de Sonoff app werkt dus alleen maar als je het pairing proces opstart en, zodra je de melding krijgt te (soft)rebooten, het Sonoff apparaat opnieuw opstart.

Je moet er ook even op letten dat in de Tasmota configuration de “Module” configuratie goed is (dus dat ie is ingesteld als een Sonoff Basic).

Ik heb ook onlangs een Sonoff bridge toegevoegd en ervaarde dezelfde problemen ik 'm niet gepaired kreeg in Homey. Wat hielp is om direct na toevoegen via de knop Homey de Sonoff opnieuw op de starten. Dan werd hij wel gevonden.

Ik vermoed dat de App zoekt op een MQTT birth message die enkel bij het opstarten wordt verstuurd. Uiteraard moet wel alle settings voor MQTT en de broker goed zijn ingesteld.

Hey Vangilles jij bedoelt met deze zin denk ik. “via de knop Homey de Sonoff opnieuw op de starten. Dan werd hij wel gevonden.” Homey = Herstart. en met die knop bedoel je die rode herstart knop op de begin pagina ?

This thread has been moved to the non-english forum, if you have any problems with that please feel free to contact me or another moderator.

Ik bedoel dat je via Homey het device wil gaan toevoegen middels de Sonoff app. Na het selecteren van de juiste device (op knop klikken) scanned de Sonoff app dan naar nieuwe devices. Zodra het scannen is gestart (of vlak daarvoor) haal de stroom van het Sonoff apparaat er af en zet direct daarna de stroom er weer op. Bij mij werd het apparaat toen wel gevonden en had ik geen time-out.

1 Like

VanGilles
jij bent mijn persoonlijke HELD. ik had geen heil in je oplossing. daar ben ik heel eerlijk in.
Alles was dus indd goed ingesteld en dat zijn uiteraard wel de voorwaardes.
voor de personen die dit probleem ook hebben. en alle logging en troubleshooting gedaan hebben er er zeker van zijn dat het MQTT stuk in orde is.
Open in Homey de SONOFF app -->selecteer het juiste device(in mijn geval de Sonoff Basic) --> vul alle MQTT instellingen in. (je kan bij host ook 127.0.0.1 invullen als je Homey ook de MQTT broker is)
druk op volgende en trek 1 seconden voordat je op volgende druk de stekker uit het stopcontact en steek hem er weer in. En jahoor daar was ie. TASMOTA gevonden :slight_smile:

Hoop dat mensen die het zelfde probleem ervaren hier iets aan hebben.

1 Like

Ik heb gisteren ook geprobeerd om sonoff toe te voegen maar dat was dus niet gelukt.
Vandaag weer geprobeerd en bij de broker telkens ip adres van Homey ingevuld, stekker eruit, stekker er in. Druk op verbinden en zo 4 achter elkaar gekoppeld.
Werkt prima.
Alleen als je kijkt in de eigenschappen van de sonoff apparaten staat er bij IP adres het adres van de Homey, klopt dat?

Je zult wel een MQTT broker app moeten hebben draaien op de Homey. Dan kun je wel het adres van de homey kunnen gebruiken.

Ze werken ook gewoon alle 4. Kan ze normaal gebruiken. Alleen ik had verwacht dat bij de eigenschappen van de Sonoff het eigen ip adres zou staan en niet het adres van de Homey.
er draait ook een MQTT broker op.