Homey Community Forum

[TUTORIAL] Setting up MQTT on Homey for configuring Home Assistant for dashboard purposes

No one?
@HarriedeGroot Is this something you can clearify for me?
So I know how it should be addressed…. By Duux or in another way…

Whats the capability definition as displayed in the developers dashboard?
https://tools.developer.homey.app/tools/devices

It needs to be setable to be able to control it. This needs to be implemented by the Duux smartfan app.

Wow, you are as quick as always! Thanks once again for your reply!
I believe Duux has to implement it then?
See below.


Hmm, looks like the fan speed is editable from there…
Are you able to control the fan from de developer tools?

Can you show me the homeassistant /config for the fan (mqtt HA discovery topic)?
And is there an HA input_number available for the fan?

Yes, I have now discovered that the fan speed is settable from the developer site.

I hope this is what mean (sorry if not…)?

Eeeehhh….? :wink: Should it be in the screenshot above? If so; then there isn’t…

There is only a state_topic.
Shouldn’t there also be a command_topic?

Did you check topic: homeassistant/input_number/…

Should I find that on the same page at the HA entity?
I see no “command” there.
Can you direct me where I should be able to find it?

Try mqtt explorer?

Found that one too, I hope… :wink: Hope this helps?


(cannot scroll to the right, but if it helps, I would be more than happy so send more screenshots)

I see command_topics for onoff and horizontal- & vertical mode, but not for fan-speed.
But that one is registered as a sensor, the other ones are switches, so that’s the problem perhaps?

Dug a little deeper. It’s probably a shortcoming of the MQTT Hub. The homey device is clearly labeled as a ‘fan’ (device class; first screenshot).

The hub should translate this into a HA MQTT fan config. But it’s provided as a sensor, which is ready only.

Ah, I see.
Thanks for the effort!

Is it something you can easily fix?

Snelle oplossing is om zelf een mqtt fan toe te voegen aan de HA yaml config. En daarbij even naar de juiste topics wijzen.

If I knew how, that probably would be the fastest way… :slight_smile:
But (un)fortunately the hot weather hasn’t arrived yet; so is this something that will/can be corrected in a future update of the MQTT Hub? No hurry of course.

i’m really new to home assistant and try to understand everything, and read a lot of information.
Is it possible to do a step by step for me where i put information in the apps?

I have Homey, and installed the hub, with HAD set to ON, the rest is by default good i thought.
Then installed on Homey MQTT client, IP adres from homey or HA? Port 1883. All other things are greyed. Username/Wachtwoord ? from which ? home or ha, or can i make it my self?
Then installed MQTT broker port 1883, rest default greyed, and press start broker

And then the part from HA on a raspberry pi, installed the MQTT (purple color icon), everything automatic, but when i modify its nog the same as home. What must i fill in : ip adres from homey/HA ? Same username/wachtwoord i used with homey apps?
Or install another app in HA

Sorry i read to much information. Who can put me on the right way with the info i need?

  • The MQTT broker is the central instance for MQTT message exchange. HA and Homey-MQTT-Client must connect to the broker
  • Install MQTT broker (e.g. on Homey with Homey App MQTT-broker).
  • In HA, install the MQTT integration (HA-MQTT client), connect to the broker (Homey-IP, port 1883).
  • In MQTT client app (Homey), connect to the broker (Homey-IP, port 1883)
  • Install MQTT Hub on Homey, go to app settings, activate the hub, start broadcast.
  • You should see the Homey devices as sensors/switch/light… in HA under settings/entities.

To check the broker data you could install a MQTT client like http://mqtt-explorer.com/

thanx, for the info. it is working now. great!!!

How did you get all the nice items? like the plex thingy, and the groups for the lights?

Check here for some inspiration!

1 Like