Homey Community Forum

Tuya Cloud app

Hi Jurgen,

Do you think that, over time, the kWh meter could be supported?

@Henk_Renting, this devices is probably not supported by the API this APP is using.

@Jan_Peeters, the API doesn’t support energie values. If they come in the future, I don’t know, only Tuya can answere this question.

@Rene_van_Duijkeren, there are several time limitations on the API, discovery once in 10 minutes, authentication once in 10 seconds. So probably something with the last.

2 Likes

Dear @Jurgen_Heine, is it possible to add:

  1. Tuya wifi gas/water valve
  2. Tuya wifi gas sensor?

@Pavel_Karzov, Both are nog possible at the moment. See opening post.

please who can help me?

I installed a plug using the manual above. Now I would like to create a flow that when the power changes I get a notification.

You can do this in the Smartlife app, but I would like to do it via Homey. How do I set this up?

How do you know if the app has connected to the tuya-server? I just get “Reconnected to gateway” with with correct and incorrect credentials.

I have problems connecting my wifi-oplug (Deltaco SH-OP01), I can see it in the TuyaSmart app.

It is not possible to use both the Tuya Cloud app and the Tuya Zigbee app for a Zigbee device since a Zigbee device can only be paired with one Zigbee Controller at a time.

First of all, thanks for the clear set-up guide. I managed to add my Tuya led strip to homey, it is now visible among my other devices. However it has a red triangle with an exclamation mark and when I click it, this error is raised: “(temporary) unavailable”.

Does anyone else have the same problem?

P.s. I also added a filament light, but this time using the tuya (not cloud) app, using the device id and key. This lamp is visible among the devices as well, but raises the same error, now in Dutch: “Dit apparaat is tijdelijk onbereikbaar”. Recognisable for anyone?

Sometimes Homey will lose network connections for unexplainable reason. Try restarting the apps to see if that solves it.

1 Like

Thank you for the fast response!

I guess I needed some patience… the led strip works now: I closed the homey app and smart life app and waited a bit.

I added the filament lamp the same way as well (through the Tuya Cloud app instead of the tuya app with key + id) and even though it shows the error triangle (I guess it’ll disappear just like it did with the led strip), it already works with the flows it’s in :grin:

1 Like

I agree when using Tuya Zigbee app. The devices are paired directly to Homey then. For Zigbee devices in my opinion the best way to do.

So i have this Tuya dimmer:

Let’s shop together on AliExpress with new user coupons
Your € 2,53 in coupons are here!

I addes this device to the Smartlife app as a lightbulb. Setting a dim level in the Smartlife app works like supposed to from 0,1% to 100% brightness. Dimming in Homey is working, but somewhat strange. It seems as if the proccess of dimming from min to max brightness, which normally is from 0.1% to 100%, is now 0,1% for min to about 30% for max brightness. And after 30% the dimming starts again at min.

Someone any ideas?

Regards,

Dennis

There are problems with the brightness with some devices, I am working on a setting to fix this.

@Jurgen_Heine thank you! Will patiently wat.

Regards,

Dennis

Hello,

New guy here.
I’ve downloaded Tuya Cloud app; followed the set-up directions (I use Smart Life as business, as my light bulbs are there).

In smart life I have 4 light bulbs, and when I try to add a new device through “Tuya Cloud” in Homey, it can’t found any light bulbs.

I have tried the following things :

  • Disconnect/reconnect from : Tuya, Smart Life,
  • Restart the app : Tuya Cloud in Homey settings,
  • changed password on both Smart Life and Tuya ( using the exact same one)

What can be wrong please ?

Thanks