Homey Community Forum

Tuya Cloud app

Did this ever get support some how in this app?
Thank you

Hi I found the issue. I used my Google account to create an account in the app. I deleted this one and created an account with email and password now I can find my lights. Thanks

1 Like

Is there any thought on adding the (a) lightstrip? I can add it, but there is no color. Running into some issues with the other Tuya app, so though about enquiring how things are going with this app. Would rather use this one tbh because it is a lot less hassle.

Jurgen, my app stopt again.
I did send the latest logfile.
ba95b05c-f92d-4fc4-9173-e39d505e0788

@Hugo, sorry to hear it’s not solved for you either. As I told to runner, I have to investigate why it’s still not working. In mean time, till I fix the error, I suggest make flows to restart the app after crash and if nessary schedule a restart every night.

@Martijn_Hoogenbosch, unfortunately this is not possible. This app uses an unofficial Tuya API. This API does not pass all data (correctly). They don’t support this API and don’t want to adjust it yet.

1 Like

At least it is not every day anymore.
So it is beter than it was before.
And the restart flow does not work. My Homey does not see when an app is crashed and therefor not restarting, but for me it’s no problem.

Hello,

Thanks for this app. I have an issue, and was wondering if it’s just me. I have a tuya touch switch which I’ve added using this app, but if I physically operate the switch, the status of the switch doesn’t reflect back in homey. For example, if the switch is off, and I turn it on manually, the switch status stays off in homey. Is this a known limitation?

Thanks

@kalpik, unfortunately this is a limitation. We can only get status once in 5 minutes and the returned status is not reliable.

Thanks, makes sense :slight_smile:

Same for me here. App does not crash everyday now but every 3-4 days. Restart after app crash flow does not work and a scheduled restart app at 17h neither.

Manually restarting app in homey seems to be the only thing that works.

Made a new crash report before and after:45b47e08-ea2a-4545-8150-c0d49329602a and a4a949ee-f439-447b-a06f-21564c0b47f2

Hope your able to pinpoint and fix the issue.

Thanks in advance!

There is a new version in test channel
In this version I have fixed an error with expired accestoken not renewed in some circumstances. @Hugo and @runner780, this could solve your problem.

Got a tiny question; is there an explanation on why there is such a huge delay? When I turn on a lamp through the Tuya app itself it is pretty much instant. When I do it through homey it feels a but sluggish. I’m using the TuyaSmart app.

This app uses a cloud connection, so through internet. Your Android app can connect locally with your lights. Local access is possible with other Tuya app, but harder tot set-up.

Right, so the (iOS in my case) TuyaSmart app connects directly to the strip / bulbs. Didn’t know that. And yes I know there is another Tuya app, I’m using that one for controlling the LED strips which work just fine (including color :wink: ).

Only the light bulbs don’t work through that app. Don’t know what’s wrong, but it is not accepting the KEY and ID within TuyApi, nothing the Developer can do about that.

Thanks

Hi Jurgen,

I did not have any problems anymore, but did install your latest version to try.
I will let you know.

1 Like

Hello Jurgen, v0.0.11 made it worse. Now app is crashing multiple times a day again. Any way to revert to v0.0.10?

Here’s the before and after diagnostic report 38feec31-e70e-4781-9dc8-2b2d8b28aaa3 and b1203562-073f-4da2-b03d-e2402827f605

Gonna revert back to v0.0.09 first. hopefully you’ll find a fix soon.

@runner780, actually it’s an improvement. Instead of meaningless bugs, I now see more of what is going wrong. It looks like something is going wrong with “Smart Plaffoniere”, the returned colortemp is out of range. This is resulting in a lot of error messages, see below. Can you delete this device in Homey and watch a couple of days if this is solving your error.
2020-11-20 16:56:05 [err] [ManagerDrivers] [light] [0] Error: out_of_range
at Remote Process
2020-11-20 17:01:10 [err] [ManagerDrivers] [light] [0] Error: out_of_range
at Remote Process
2020-11-20 17:11:20 [err] [ManagerDrivers] [light] [0] Error: out_of_range
at Remote Process
2020-11-20 17:16:25 [err] [ManagerDrivers] [light] [0] Error: out_of_range
at Remote Process
2020-11-20 17:26:35 [err] [ManagerDrivers] [light] [0] Error: out_of_range
at Remote Process
2020-11-20 17:31:40 [err] [ManagerDrivers] [light] [0] Error: out_of_range
at Remote Process
2020-11-20 17:41:50 [err] [ManagerDrivers] [light] [0] Error: out_of_range
at Remote Process
2020-11-20 17:46:55 [err] [ManagerDrivers] [light] [0] Error: out_of_range
at Remote Process
2020-11-20 17:57:05 [err] [ManagerDrivers] [light] [0] Error: out_of_range
at Remote Process
2020-11-20 18:02:11 [err] [ManagerDrivers] [light] [0] Error: out_of_range
at Remote Process

Jurgen,

As I said before, I still don’t have any problems anymore.

Hi all,
I use Tuya cloud for my lamps and have xiaomi sensors.
I’ve got some flows that at night time light on Tuya lamps on Xiaomi sensors changes. Works fine almost anytime but sometimes when I open the door, nothing happens. I try 3/4 times and it works. Same thing with an occupancy sensor from Xiaomi with a tuya switch.
I tried to use automations in Homekit instead Homey flows and I’ve got the same results. Works almost fine but…
Any reason ?
Thanks