Update Homey but I have Aeotec custom app installed


#1

I would like to update Homey
but I have Aeotec custom app installed via CLI
that supports LED strip

My Homey is 1.5.3
and now there is finally available Aeotec beta 2.0 app that supports LED strip.

So I would like to update homey
to latest firmware and lates apps
and Aoetec beta.

How do I do it?
and not loose any settings
or devices
or need to re-add devices.

Is there a way?
Thanks.


#2

You will never get a guarantee that updating wont break anything.
but the update from 1.5.3 (from 18 Sep 2017) to 1.5.12 as latest Stable should normal give no issues and bring a lot of Fixes and good.

Updating the App depends on the developer.
If it is the same App you installed using CLI that was once first in the store it could update without problems.
I don’t see Issues in the version History that you should re-pair so try it…
Installing from Store OVER the CLI installed version will keep all devices and Settings (and they function if the new devices still match the old one’s)
For New capabilities on existing devices You often have to remove and repair.

WARNING:
If you remove the App or downgrade / upgrade from:

  • Alpha to a Beta or Stable
  • Beta to a Stable
    All devices and settings are removed

#3

Installed Aeotec beta 2.0 from store, that overwrote old CLI installed app.

Then I pressed install 1.5.12, waited to download 245.4 MB and BOOM!
dark screen, please wait do not turn off the power said homey
waited, some purple light rolling
after few long minutes, maybe more than 5
then looong yellow light but all went well

new FW new Aeotec app
me happy

all good :slight_smile:

I have a lot of fibaro devices
should I go with beta fibaro app?

thank you!


#4

As Dijker mentioned, once you go to beta, to go back to ‘stable’ you will need to remove all your devices and re-add them. This can be particular painful with Fibaro in-wall switches and dimmers.

As someone who is currently running the Fibaro beta, (which is very good) I would just wait it to become stable and you will automatically get updated. Unless you are having issues with Fibaro already.


#5

thanks … I guess I will stay as it is with Fibaro … not having much (if any) problems.