Vibration alarm in device card


#1

Got myself some vibration sensors but noticed that if you use “devices”-card in “when” and the “an alarm turned on”-card there is no option för vibration alarm. Can this be fixed?


#2

Maybe wise to give some more information than this if you want to get help.
It may be handy to state brand, type, app used, etc…


#3

Hm I think we missunderstand each other.

I want Athom to add ”Vibration alarm” in the devices-card for ”An alarm went on”.

That card should work for all devices having vibration alarms regardless of brand.

All though I have the aqara smart sensor.


#4

In that case you should contact Athom directly, bit strange i know but thats how it is.

You could have knowing that if you had read the welcome post here on the forum.

See point 11


#5

Hi COP,

You are right, but only for the default capabilities in Homey’s library.
Technical answer: In the case of the Aqara vibration sensor, the Vibration-, Drop-, Tilt-alarms (as well as the measure-tilt, -vibration) capabilities (and the corresponding device flow cards) are custom defined (app only).

But I had in mind to add them to Homey’s library; so I used the same conventions Athom also uses. And requested the designer of Athom to create the required icons…

I just created a Pull Request on the Homey Library to add them (aka the formal request to Athom): https://github.com/athombv/node-homey-lib/pull/135

I expect that this one will be approved relatively fast, due to the conventions followed and icons already available…
Question will be in which Homey SW update this library update will be released… That’s up to Athom to decide.