Homey Community Forum

Virtual Devices

app
official

#1

Virtual Devices can simulate anything without using an actual interface. Well… of course within the limits that Homey provides.

There is more information, including How-to’s on GitHub Pages: https://arjankranenburg.github.io/virtual-devices/

Please report bugs on github: https://github.com/ArjanKranenburg/virtual-devices/issues

Questions can be asked here or on Slack (@arielaxed)


Homey 2.0.0 Community App Compatibility List
Heimdall - Let Homey watch over your home
#2

Note that the old forum can be found here:


#3

Hi New user here. Just added the VD app, great, good job.
Also made a small donation for your effort.
I have a question if you can answer, i saw somewhere that somebody said they added there own icons to your app and loaded it onto the Homey. I get how to load the app onto Homey, but how do I add icons to the VD file?


#4

Hi Adrian,

Thank you very much for your kind donation!

I’ll try to set-up a help-page with instructions for this, but in short it will be something like:

  1. Download the Virtual Device code from GitHub

  2. Determine which driver to add an icon: mode, multi, or virtual_switch

  3. Add an icon in .svg format to the assets directory of that driver

  4. Add a line with 'getIconNameAndLocation('switch’),’ to the driver.js of the chosen driver. You’ll see where to put it.

  5. Load your version of Virtual Devices like a developer does, i.e. from the command-line:

See https://developer.athom.com/docs/apps/tutorial-Getting%20Started.html but skip step 4 (you don’t need to create a new project).

Let me know if and where you get stuck.

With kind regards,

Arjan


#5

Many thanks. I’ll try this out this week when I get some spare time. Cheers.


#6

Hi, any reason the Virtual Devices are not available through Alexa SmartHome Skill? Is this a Homey issue?


#7

Not that I know of. I don’t use Alexa (yet).

Are other Homey devices available in Alexa skills? Or only certain types?

Virtual Devices are just like regular devices, except for the physical device itself :smiley:

On the other hand: I didn’t do anything special for Alexa, but I would be surprised if that’s needed.

/Arjan


#8

Thanks Arjan, had a reply from Homey support and they said it is the Virtual Device App issue, not a Homey issue.
Any chance of fixing this, I find the Virtual devices great, but need them to be functional via Alexa for voice control. Happy to make a donation so you can buy one to test with, or I can order one and send it to you.

Kind Regards
Adrian


#9

That’s very kind of you but let me investigate a bit first.

I assume you installed the Homey-skill? I read here that it already works for switches:


Switch is not a capability in Homey, so I guess he means an onoff-capability. It could very well be that the Homey-skill does not support all capabilities, but onoff should be the first to support.

It could also be that it discovers only certain classes of devices, e.g. lights or sockets. Did you try it with those?

And here I read that the language matters, of both Alexa’s and Homey’s:


#10

Hi Arie,
Done some more investigation myself.
So it seems that on/off plugs and lights virtual devices will work and are displayed within Alexa Smart Home Homey skill. But other VD devices such as TV, Blinds, Buttons, Virtual Modes or Multi Modes, do not.
You are right, this seems to be Homey related, as we have added Somfy RTS blinds to Homey and these do not show within Alexa either.
I’ll get in contact with Homey again and find out why or how you can add functionality for, Especially for AV (tv and receiver) and Blind support with Alexa. Blind (window coverings) support is essential for us.
Thanks Arie for you quick response.

ps if you havent tried using an Amazon Alexa you really should. A couple of these thoughout a home are amazing for voice control, intercom solution and mulitroom music control (Spotify premium account needed)


#11

How can I set a value when I created a virtual device with a measured temperature?


#12

You mean this?

mmnlk
use the tag from your temp meter


#13

Thanks, it’s now working. Just needed to select the correct sensor and device.


#14

As far as I can determine Alexa does not support covers (curtains, blinds, etc). It has no class for developers to use. Until Amazon add that class Alexa can not support covers from any manufacturers. I use Tahoma and link that into Alexa but it only exposes scenes and not devices. So I have created Alexa routines for each window to call the scenes that operate the cover. E.g. a routine called “open bedroom blind” that calls the open bedroom blind scene and the same for close and then repeat for each cover.


#15

Hi Arjan, can you make the capabilities of the sensor device setable?
I use virtual sensors to show variables from Homey-scripts in Insights. Right now I need a token/tag and a flow to get the value stored in the sensor.
I’d like to minimize the use of flows and tags to relieve my heavily overloaded Homey :smirk:.


#16

Do you want to set it with Homeyscript, like Bassiebulk in:

I can try to overwrite the default settings of athom. Not sure if that will work.


#17

Yes, that’s what I’d like to do.
Exactly the same problem as Bassiebulk.


#18

Hi,

Last week I changed some flows to use VD instead of Better Logic variables, but it’s not working as expected.

I have a multi-mode device ‘Zon’ that has mode ‘Sunset’ and ‘Sunrise’. I use 2 flows to set the mode, like this:

I have 2 VD-devices ‘Sfeer Binnen’ and ‘Sfeer Buiten’ that switch on some lights inside and outside when the sun sets, like this:

This only works for the ‘Sfeer Binnen’ device when the sun sets.
But in the morning, when the multimode is set to ‘Sunrise’ it turns ON ‘Sfeer Buiten’!?
I have no flow that does anything with ‘Sfeer Buiten’ when the mode changes to ‘Sunrise’.
I do have another flow to turn off another light at sunrise, this doesn’t work either.
All very weird stuff :smirk:

I just noticed something strange in the Android (preview)-app:

Both ‘Sunset’ AND ‘Sunrise’ are set to on!?
Do I have to do something special with the device, or is this a bug somewhere (VD or Android-app)?

Thanks!


#19

Not sure if it is the same, but it reminds me of this issue for Athom:

Does it work when you create the flow with the desktop app?


#20

Instead of using the card “multmode is exact” in the and colum. Try to use the logic card with a tag.

Thats the only way i got the mult mode changing to work. Not sure its the fix for you, but i would give it a try.