Homey Community Forum

Weather Underground PWS app (release version 2.1.17 & test version 3.0.4)

Hi Adrian,

Thanks for your help, I just mailed WU Support why my PWS is not listed/found and is not usable with the API key.

I’ll let you know if I hear from them!

1 Like

I think it has to do with WUs QC. A new station and with rapidly changing values (from indoor to outdoor) doesn’t pass WUs QC. I think it will pop up in a day or two…
https://support.weather.com/s/article/Are-personal-weather-stations-on-Wunderground-monitored-for-quality?language=en_US&type=wu

1 Like

I have published a test version for you to try.
If the station ID is not found then it will ask if you want to add it anyway. It seems to work OK when I added your IROTTE135.

Hi Adrian,

This version works instantly, even without asking if I want to add the station. A BIG thank you!!

Krisstenswe, I hope my station will pass the QC, I read something about that this morning on another board.

1 Like

Guess what?

The question wasn’t asked because it is listed in the search now. How bizarre :slight_smile:

1 Like

Not sure if it is just a coincidence or because I force added it to homey or because you emailed support. Whichever it was it is good :slight_smile:

1 Like

Have a nice weekend Adrian!

Verzonden vanaf mijn telefoon dinges

-------- Oorspronkelijk bericht --------

1 Like

Try to email WU support, last time they have fixed it after reporting it.

1 Like

Willi try it.

Btw, anyone knows why WU sometimes do not display highest temp. of the day? Is it “WU works as designed” ?

"temperatureMax": [
    null,
    29,
    24,
    24,
    27,
    28
  ],

Could you explain a little more please. Are you looking at the current data or the forecast?
Do you mean the display in Homey is not showing the highest value?

Yes, from time to time, Max temperature of the day (current - Tonight) is not displayed :frowning: - eg. when checking now, it’s again showing up.
But looking on your app log, seems that value is even not provided by WU - shall I report it to WU ? Anyone else observed this behavior ? I was using Max temp. value to start irrigation (or not) for particular day in the morning…this is how I have discovered it.

I will look at the code this evening. I know for certain things WU stop reporting today data after around 3pm but my app should automatically switch to show tonight data.
I will look to see if they have any similar rules about max. temperature.

1 Like

Please where can be a problem.
After reseting the app it runs for few seconds and then this

  • Weather Refresh: Unexpected token p in JSON at position 4

Could you enable the log and send it to me when the error has occurred.

More > Apps > Weather Underground > Configure App, log tab. Make sure the tick is blue to turn the log on.

For few days after several restarts it worked but now

App Started
2021-10-12T15:00:52.143Z

2021-10-12T15:00:52.912Z

  • Done retrieval of data

2021-10-12T15:00:52.917Z

  • HTTPS Error: 204

2021-10-12T15:00:52.929Z

  • Weather Refresh: GetURL Error: 204, No Data Found

Edit: it’s 20:30 and it runs now…

Error 204 basically means that the weather station hasn’t sent any data for over an hour so there is no information to fetch.

Hi Adrian!
Some thougths I have:

  • In some earlier versions I had the possibility to choose for example ‘Gust’ as ‘Status indicator’ in ‘Forecast’- In version 3.0.3 I can’t choose anything - it’s grayed out. Is this a bug or is the option removed?
  • I have manually set speed units to m/s. In the unit ‘Station’ it shows wind speed and wind gust as m/s in both numbers and text. If I manually change from m/s to km/h, the numbers change (they are recalculated) and show the wind speed in km/h, but the text still shows m/s. Bug or does it have to do with Athom determining the units?
  • In ‘Forecast’ it always shows wind gusts in km/h regardless of whether I manually set speed units to m/s or km/h. The numbers will not change (recalculate) either. Maybe this is raw data from WU and displayed “as is” in the app …?

I have removed the “Forecast” as a device and reinstalled it without any difference.
Homey version 7.1.4.

The cloud version of Homey had some major issues with the custom capabilities that start with measure so I renamed them. The problem was it tried to create the ‘standard’ flow cards based on measurement greater than and measurement less than, etc. But they are of no use to the weather forecast as the correct flows need to have the reporting period specified. This meant that the app had two lots of these cards and the automagic ones didn’t work. I have reported that to Athom so time will tell if they manage to fix it.
The option to choose which item show up as the status only works with capabilities that start with measure. So my new custom ones are no longer available.

I will look into these as maybe Athom have changed something that stops the units text from being changed. I know they frown upon this behaviour as they want everything to be ‘standard’ and have concerns about compatibility in future version if they need to have different units for certain locations (USA) where they prefer imperial units instead of metric.

Again I will investigate as maybe I have forgotten to change something in that device.

1 Like

Adrian,
I have tested version 3.0.4 and this version solved the problems I reported earlier regarding speed units and conversions in both ‘Forecast’ and ‘Station’ - Thnx! :pray:
I hope Athom do their part in the near future so we, once again, can see options in ‘Status indicator’ in ‘Forecast’…

1 Like