Homey Community Forum

Will v5 firmware support light link (direct association for zigbee)?

The ability to directly associate lights to switches for zigbee is called light link and currently not suppored by Homey. You need the Phillips Hue hub or similar for that functionality. Does anyone know if firmware v5 will support this?

Thank you

Zigbee LightLink is not the equivalent to direct association within Z-wave. ZLL is an Zigbee application profile, specifically for light devices.

Within the current release of Homey v5, it is not possible from the UI to create a direct link between two Zigbee devices / create a Zigbee Group / create a Zigbee scene.

It is possible to create a direct connection between e.g. a remote and one or more bulbs if both are supporting Zigbee LightLink Touchlink and both are part of the Zigbee network of Homey.

Does that answer your question?

1 Like

Do you have any information about how to enable direct connection between a HUE light and remote that both are paired with homey? My wife is not happy that the light switch sometimes does not work and “just” have to reboot the homey or something like that.

:rotating_light:WAF alert!
Let’s see how we can solve it; Which remote are you using?

2 Likes

The one on the right in this picture. The rectangular one with on/off and brighter/darker. I have managed to link the remote to the light in its own network without the homey before. But I’d gone to have it both connected to homey for use in flows (dimmed light at night) in addition to working straight from the remote.

I reset the bulb and remote in order to add them to the homey.

Quite simple, when both devices are added to Homey.

Found the instructions in Dutch:

Dan kan je je lampen eenvoudig toevoegen door je afstandsbediening dichtbij de lamp te houden en 15 seconden de aanknop (I) ingedrukt te houden.*

So translated:

move the dimmer switch to close proximity of the bulb and press the ON button for 15 seconds

1 Like

Thank you! I did it the wrong way. I had them linked at first, but the link disappeared when I return reset to add to homey. Did not think to link them again. I assumed they’d fall out of the homey then.

Don’t thank me yet, only if the misses approves the solution :wink:

Tried it today and unfortunately it dit not work. I added the bulb to homey first. Then I held the remote close and hold down the on button. The bulb blinked and now works with the remote. But it left the homey network (see image). Tried once more after adding the remote to homey first. This time it did not leave, but does not work the the remote either. So ended up with the old approach using the homey and flows again.

Did you first pair the bulb and the remote to Homey and the tried the Touchlink approach?
In your description, I’d suspect that you didn’t add the remote to Homey. In that case, the remote will force the bulb to it’s network.

I did not include the remote first on my first try. But on my second I included the remote and the bulb to the homey first.

Is some zigbee fubctionality similar to z-waves direct associations possible within zwave? If so, is it planned to be enabled in v5?

Topic is a bit old I’m resurrecting it a bit, sorry about that. I’m looking for possible solution to my problem. I would like to find zigbee based solution that would allow me to control the light wirelessly (actuators controlling the light) even if homey is down. This implies direct control from remote to actuator.

Anyone knows if this is possible and if someone actually done it already on homey? If yes which products did you use?

Either above or I’ll have to replace it with hardwire but before starting with powertools and cabling I wanted to ask one last time. Thanks for the ideas…

Look here: at least with Hue devices that support Zigbee Light Link Touchlink, you can bind Hue remotes to Hue lightbulbs so they can be controlled directly. IKEA devices should also support this. I don’t know if you can assign a remote to multiple lightbulbs, though (although I suspect that should work fine as well).

Hi Robert, I saw reply from Ted of course, however later paaland said it doesn’t work. So I was hoping someone can from hands on experience confirm this and this devices are actually working like that 100%.

I would like to avoid spending xyz amount of money just to understand I’m unable to configure it… O_o

With homey all is a bit in grayish zone. :joy:

Because touchlink relies on proximity to connect (easy to link to the wrong light), not all devices seem to support it and/or do not advertise if they support it, and because I did not see any other way to disconnect other than reset/repair, I chose to buy z-wave.

Associations are supported by all devices I ever got my hands on. However, with the support for S2 security this is now also problematic. Associations only work if the security level of the devices is the same. I used to use the Walli trick to add everything unsecure. This now no longer works and there is no alternative known to disable S2 security.

New remotes now incluse using S2, Fibaro dimmers unsecure, and they will no longer talk to one another using associations :- :sob:

ZLL isn’t supported by every device, but binding in Zigbee is ubiquitous (but all devices do “advertise” whatever they support). It’s just that Homey doesn’t have any way of setting up bindings. In other words, it’s not the protocol that’s missing features, it’s Homey.