Homey Community

Xiaomi / Aqara Smart Home - Zigbee App (v0.4.3)

app
zigbee

#41

I also cannot pair my new devices: No Zigbee device found…

  • aqara human body sensor (2)
  • wireless switch (2)
    I’ m running 0.4.1 and homey 1.5.12
    I’ ve already installed 8 devices with this app ont Homey. I’ ve also installed 1 other zigbee device via Phillips Hue app on Homey. Besides Homey I also have 2 hue bridges running (i dont know if this is important).

Is there a max # for zigbee/xiaomi devices in Homey?


#42

I suspect that the inclusion process is timing out and the devices goes to sleep before the inclusion process finishes…

Can you try, when including these devices to follow these (additional) steps:

  1. Include the device at close proximity of Homey
  2. Follow the inclusion instructions
  3. Once the blue led is blinking, keep pressing the button once every 2 seconds
  4. It should show a message like “interviewing cluster x of y”, every time that this message changes, press the button…

#43

Thanks for the quick reply!

  1. I hold the device almost against the homey.
  2. Only this instruction is given, there is no next step:
    20
  3. i’ll tried that many times, but I think it is only usefull when the app is in the next step
  4. That step isn’t coming up. ( anymore; I recognize this step from the previous correct paired devices)

I restarted the app, restarted homey, tried to remove 1 device, but that didn’t succeeded (did not tried to remove the device using pairing mode on device). Anymore tips?


#44

Did you try to remove the device by going to Settings > Zigbee > remove device > put the device in inclusion mode / wake-up the device?

Alternative, remove the battery from the device and retry removal / inclusion.


#45

I had the same problem when adding a device today, added my findings to the issue on github.


#46

I succeeded in removing the device with ‘pairing/inclusion mode’. After that, I can add an other device!!

As mentioned before:
I’ ve already installed 8 devices with this app on Homey. I’ ve also installed 1 other zigbee device via Phillips Hue app on Homey. Besides Homey I also have 2 hue bridges running.

Those 2 Hue bridges contains 30+lights and 20+ accessoires

It looks like something is ‘full’? The app? The homey? Zigbee?


#47

There is a limitation that you are only able to add 20 battery powered EndDevice's per (non-battery powered) Router device. See also https://github.com/athombv/homey/issues/2160

As far as I’m aware this is within 1 Zigbee network… so having 2 HUE bridges / other zigbee networks should not matter.


Ikea zigbee / Xiaomi mesh?
Ikea zigbee / Xiaomi mesh?
#48

Because it was also not possible to add a device via de philips hue zigbee app on Homey, I decided to reset the zigbee network (homey settings --> zigbee --> reset zigbee).

Now I can add al my devices!! (and must fix the flows)
My Sunday is a happy Sunday. Thanks for the support!


#49

Enjoy your happy Sunday!


#50

So i’m having some trouble using my Aqara human body motion sensor…

Perhaps my thinking is wrong, plx helpz! :wink:

I have the Aqara Human Body sensor in my kitchen.

Flow 1; Start the kitchen timer

Flow 2; Reset the kitchen timer

Flow 3; Turn on the lights

Flow 4; Turn off the lights

So, the issue…when i walk into the kitchen, the lights turn on (score!)
But, if i move around in the kitchen…the lights go out after around 90 seconds.

Sensor settings under devices:
image

This is not what should happen :frowning:

What am i doing wrong?


#51

U need to set the timer when motion goes off.
When motion–Turn on the lights and stop the timer
When motion is off–start timer
When timer=empty–Kill the lights


#52

3 x EndDevice
8 x Router
1 x Coordinator (Homey)
2 x EndDevice vc Router

I do not think that the # of EndDevices is a problem. Especially because after not being able to pair my new (4x) Xiaomi Mi ZigBee - Aqara Wireless Remote Switch Double (WXKG02LM) with Homey, I succeeded to pair 2 x Xiaomi Mi ZigBee, Aqara Human Body Sensors. And it works fine.

Paul


#53

@Paul, not being able to pair or pairing is successfull, but the device is added as “generic Zigbee device”?

There are some more reports that Xiaomi / Aqara changed the ID’s of the devices (without changing the product number)… therefore during inclusion the right app / driver can not be found.
First tests show that simply adding the additional ID’s doesn’t result in a working driver… so it appears that more has been changed.

Can you post a screenshot of the Device information (ID’s)?


#54

image

Like this ?


#55

:tired_face: yep, same issue… WTF…


#56

That is too bad, Ted!
Why on earth do they change device ID’s? Other controllers must also have issues with changing ID’s…

I am sure you will be able to solve it again (like with the same ID mess with the Eurotronics Spirit valves).

Good luck!!


#57

So, it appears that Xiaomi / Aqara made some breaking firmware changes to the Aqara wireless switches (known today)… without changing the product numbers…

A quick fix (adding the new ID’s) to the existing drivers does not result in working devices…
#backtosquareone

That means that I’ll need to get my hands on the new affected devices, to create new drivers and also to be able to provide support. Ordering at Ali, taking lead time and uncertainty on which version I will get, is no option.

So, best option is to call for community support… (that is you!)

I’m currently looking for community members that have the following devices, which they are willing to send to me (in the Netherlands):

  1. Aqara Wireless switch (WXKG11LM) which has the Product ID (in Homey): lumi.remote.b1acn01 > provided by @Mustang
  2. Aqara Wireless Remote Switch Single (WXKG03LM) which has the Product ID (in Homey): lumi.remote.b186acn01
  3. Aqara Wireless Remote Switch Double (WXKG02LM)which has the Product ID (in Homey): lumi.remote.b286acn01 > provided by @Paul

Can you send me a direct message on the forum or on Slack ?

In addition, I’m also looking for some sponsors that are willing to support this activity / app through a paypal contribution and that will help to compensate the members sending these devices to me; so they can order a replacement and so that I can add support for these devices…

Who is willing to support?


#58

20€ +
Thanks for your work


#59

Can’t help with the mentioned devices, but did make a donation.

Good luck Ted


#60

@TedTolboom , i´ll be happy to send it to you ( the smart switch), just give me an adress :slight_smile:

Hilox with issue no. #90 in github

Update: i see now that Mustang provided you with one so hopefully my 20EUR will make some difference :slight_smile:
I dont have the other devices.
Thanks for your work. (Y)