Homey Community

Xiaomi / Aqara Smart Home - Zigbee App (v0.4.3)

zigbee
app

#143

Hey Ted, my switch is working now! Thanks for your work man! :+1: :vulcan_salute:


#144

Thank you Ted, it work perfectly with my switch (Double WXKG02LM ver.2018).
Great work :+1::+1::ok_hand::ok_hand:
This double switch gives me now 9 posibilities (scenes) to make flows !!
Thanks again.


#145

i added an aqara human body sensor; motion detection works but the lux isn’t updated.

Any idea how i might resolve this? or can it be a hardware error?


#146

Hi, i am new homey user now for 1 day… and happy zigbee app user…
i was wondering if i also could connect the gateway to homey… reason is i can use it as a speaker with some pre-set xiaomi sounds… and , change the lamp color etc… is it supported by this app? i use the gateway v2


#147

The Wireless Mini Switch is working now, thanks. Xiaomi are preparing for a US/EU launch of their new Homekit-compatible Aqara Hub, and it’s been a royal mess. Thanks to you and Homey I can now pinpoint the problem - the WKXKG11LM I got are of the sensor_switch.aq2 kind.

This despite being advertised as 2018 model AND showing a cryptic label on the packaging stating:
“Aug 30th, 2018
E-K02-B08-101
212232601”

and “Q/QLML004-2015” in the included Chinese manual.

This thing is not Homekit compatible and I have only been able to add it to the Aqara Homekit without getting an error only since one week ago. In other words, I can use within the Aqara Home App in automations but it won’t be exposed to Homekit, unlike the Aqara Door/Window sensor and the Aqara Human Body Sensor that I can see and use in Apple’s Home app. Before then, I would get a pairing error even trying to pair it with the Aqara Homekit Hub.

Sorry for the long rant, not too Homey related, but maybe it helps in some way.

Now to my question: The switch which now works with Homey devices, when “Added” inside Sprut Homekit Homey App, ends up shown in Apple’s Home App as “not supported”, therefore unusable. All other devices are revealed to the Home App (Sonos, Fibaro, Philips Hue direct via Zigbee, etc) - are exposed to Homekit without any issues.

Is there an easy fix? Or is this best asked of the Sprut Homekit developer?

Thanks again for your great work!


#148

It’s a (known) limitation of the Aqara human body sensor to not send Lux reports by itself, only when motion is detected… is this also the case, or is Lux not updated at all (also not when motion is detected)?

Welcome and thanks for the feedback.

No, it is and will not be possible to add the Gateway through this app.
I’m focussing on the Xiaomi/Aqara devices that are using the Zigbee protocol and connected directly to Homey’s Zigbee network (to make use of a combined and more powerfull Zigbee network).

Thanks.

The reason that the door and motion sensor are properly recognized in Homekit, is that they have within Homey a default capability (alarm_contact and alarm_motion) which can be ‘easily’ linked to the corresponding capabilities within Homekit… Same holds for a wired switch (onoff capability). But in all cases, the Home(y)kit app within Homey is creating the translation table between Homey capability and the corresponding Homekit capability.

The remote switches basically act as a remote control (aka scene trigger), but don’t have a (standard) capability within Homey… and are only using flow triggers, since these remotes only have a momentary state change. I’m not aware how and if remotes / scene controllers are supported within Homekit.

I would suggest to contact Sprut if and how these remote switches could be implemented into his app.


#149

This app is great! Can I create a flow to get a notification when the door is open and another door is still closed? I’m using the Aqara Window/Door sensor.

Thanks!


#150

Yes, I had the same problem. Just start to pair and after blinking twice hit the pair button every second. For me it worked fine.
Found the solution on tweakers.net :blush:

Edit: in the manual it says the led should blink thrice, but that doesn’t happen, only twice.


#151

Yeah, figured as much :frowning:

The weird thing is; i use 2 more sensors and they DO report the correct LUX data.

Perhaps this unit needs a firmware update; too bad i don’t have the xiaomi hub to perform the firmware updates :wink:


#152

Just to check… you sure all three are the same version?
So including the small sensor window above the PIR window and normal button (and not pinhole button)?

There are no device firmware updates for these devices… also not through the Xiaomi hub


#153

jup, pretty sure :wink:

currently they do show corresponding lux levels; but when it gets darker the lux levels don’t change on the Hallway sensor


#154

I have the same problem. After updating the light sensor, it responded only when it was motion. I have solved the problem. Remove the device and pair again. Now it works normally.


#155

just a question; why is the minimum reporting-time 60seconds?

I have a hue motion sensor as well and i can set this much snappier!
image


#156

One for the FAQ…
Because the device itself is blind for 60 seconds and will not re-trigger a motion alarm, when running in normal operational mode. Just after inclusion, the device is in debugging mode for 2 hours, and it will report motion triggers every 1-2 seconds. So it is a device limitation.

So far, there is no option to change this (also not for other home automation platforms)…


#157

ahh, thanks for the answer.
Having a hard time configuring them correctly in my flows…
i use one for the dinnertable (mounted on the ceiling) and more often the lights go out because the sensor did not update the motion/reset the timer

Just got a whatsapp-message from my GF, demanding i rip those sensors off tonight :confused:


#158

So the light sensor no longer responds. When I pair it again, it works. After some time, the lighting update does not change …My sensor settings were initially. Do not know what the problem is.


#159

@TedTolboom Hi Ted, I wanted to share this observation: since I changed the frequencies of my WLAN router (ground floor, channel 6-10) and repeater (LAN AP, first floor, channel 1-9) my Homey Zigbee network seems a lot more stable: in the attic (1 floor straight above the repeater) it was impossible to use a Xaomi HBS before, despite the 2 IKEA TradFri spots 2 meters away from it.
Since I moved the WLAN repeater frequencies to 1-9 (because I erraneously thought Zigbee was in WLAN channel 11) the HBS in that part of the attic works perfect. Which is strange, because I meanwhile have understood that Zigbee is a.o. in WLAN channel 1. It connects via a TradFri bulb at the first floor.

Since the frequency change some weeks ago so far I’ve only ‘lost’ 1 Xiaomi door sensor and 1 TradFri bulb out of 83 Zigbee nodes in total (IKEA Tradfri and various Xiaomi sensors), while before it was a lot worse.


#160

@Theo_Deckers
Could you please explain what channel 6-10 and 1-9 are.


#161

Support is planned Xiaomi Aqara S2 Smart Fingerprint Door Lock?


#162

Hi Ernst,
It’s about the WiFi/WLAN channels: both WiFi and Zigbee operate in the same 2.4 GHz frequency band and that may cause interference.
In this article I read:
Normally, we get three WiFi channels to work with (utilizing 1, 6, and 11), but to make room for ZigBee, we may have give up channel 11
Most WiFi routers have a setting for the WiFi channel to use, in my case I now have for my router at the ground floor


and the repeater at the first floor:

which leaves WiFi channel 11 free for Zigbee.

When looking at the WiFi channels displayed by my Fritzbox router I noticed that my Ziggo modem/router still uses channel 11 and coincidence or not, that’s in the area of the house where I still ‘lost’ a Xiaomi door sensor since I changed the frequencies, so I’m thinking about switching off the Ziggo WiFi to see if that makes it even better.
Of course there still may be interference from WiFi routers of neighbors.