Homey Community Forum

Xiaomi / Aqara Smart Home - Zigbee App (v0.5.5)


Yes, thanks for the great work Ted! I sticked the sensor on the ventilation bar of the Velux skylight: ventilation bar closed has tilt angle of ~ -48 degrees, ventilation bar open is ~ 0 degrees, skylight locked with latch on larger ventilation opening is ~ 48 degrees and unlatched at larger open positions have a tilt angle larger than 48 degrees. Depends of course on angle of the roof which in my case I thought was 45 degrees, but it looks like it actually is 48 degrees :grinning:
One of the 4 tilt sensors paired immediately, the other 3 took more attempts, but I think this is due to the large number of Zigbee devices in my network. But in the end all 4 succeeded.
One temp sensor and the Cube unfortunately still stubornly refuse to pair after many attempts over multiple months (while they do pair with a Homey with a smaller Zigbee network). One day I’m going to factory reset and try to add them as the first devices unless the new Zigbee implementation comes earlier than that I find the time to do a complete new install :wink:



Wow. Awesome stuff



For awnings (zonwering) with an arm that moves from vertical to horizontal you could use it to measure how far it is open. Maybe even for folding arm awnings (knikarmscherm), but those arms move a bit different so I’d need to test that.



Ah right that is pretty cool!

I see an usecase now. When having a videodoorbell and the delivery man/woman is at the door when you are not home. Open the garage door till angle is X…

Hmmmm gonna think about that :grin:




The xiaomi aqara human body sensors always fall out. Does anyone have any idea how that is possible. I use this in the Heimdall app. Or is this a Xiaomi problem?



@Ben I see you posted this in both threads, please see my response here



Pretty certain this is a known issue with the ZigBee core in homey which needs rewriting

Bit of a pain as I have a number of these too that keep dropping :frowning:



Maybe the vibration sensing could also be used to detect if the washing machine has finished centrifuging?



what I mean by failure is that I currently have two sensors in the room and one in the toilet and one in the garage and one on the landing. The 2 in the room I have no problem with and also not in the toilet. Heimdall recorded everything well except for the one in the garage and overflow. When I have paired it on the landing and garage, everything goes well for a while and heimdall registers everything but after a while nothing is registered by heimdall. I’m going to take out the battery again and again on new pairing everything goes well again and over time I have the same problem again.



Same problem here. I have to re-pair part of my Zigbee devices (mostly Xiaomi sensors but occasionally also IKEA Tradfri bulbs or spots) every now and then. Then the whole network works fine for some time and after one or two weeks some start disappearing again i.e. they are still visible as a device but don’t react anymore.

I’m trying to detect some pattern in it and must say that some devices disappear more often than others, especially the ones further away from Homey, although earlier this week one disappeared that is located very close to Homey.
This weekend I had 5 or 6 that did not report anymore from exact the same moment on, but unfortunately I have found no clue what happened at that moment.



Exactly the same here. It’s mostly the same devices dropping. Usually a wireless Xiaomi switch that’s further away from Homey, but right next to the 2 Tradfri spots it controls and that actually work from Homey, so mesh range should be sufficient. Or a Xiaomi PIR that’s in the hall, also pretty much next to Ikea bulbs.

They usually require a re-pair or simply setting them in pairing mode without doing anything else in the Homey app. Unfortunately the PIR is sticking to the ceiling, making this a tiresome affair :stuck_out_tongue:




That is interesting!
Could you confirm that this doesn’t brake flows? So, the device ID’s are not changed.



Yep, although it didn’t work every time. I tried it with the switch. Twice it worked this way, once it failed and I did had to pair and fix the flows.



Thanks for the confirmation. I will try that next time!



if this is a problem at homey why do not we hear anything from Athom Homey?



ok i was succesful in pairing using the plugwise in the shed… i have a terrible wireless connection over there and i was able to connect it.

is it possible that my unifi access point interferes with the pairing process?



Good evening,
i’ve readed this post carefully because the xiaomi switches i’ve had, are stopped working after the update.
i have deleted them and added them but then i see i only have the option of 1 press or activated scene.
the options 2, 3, 4 presses long press and release are gone.
is there something i do wrong here?



Because Athom is for Zigbee focussing on re-writing the Zigbee core, see e.g.

This will be one of the updates after v2 has reached stable, so v2.1+

Could well be, depending on which wifi channel the unifi access point uses. Homey uses channel 11 for Zigbee. See some explanation on WiFi / Zigbee coexistence: https://www.metageek.com/training/resources/zigbee-wifi-coexistence.html

It was not needed to delete and re-add the Xiaomi switches.

As mentioned in the changelog, I removed as announced the old DEPRECATED trigger cards:

The new trigger cards (also named: “A scene has been activated”) have a autocomplete field and will show the applicable options:

1 Like


Thank you very much, :slight_smile: i didn’t see that.



Interesting, only putting them in pairing mode: I need to test that next time because that saves the trouble of each time having to update the flows.
This already got a bit better since I started to use a variable for each lamp, because in that way I ‘only’ need to update 3 flows per lamp: the one where the variable switches the lamp and the two feedback flows (logging ‘lamp switched off’ and ‘lamp switched on’).