Homey Community Forum

Xiaomi / Aqara Smart Home - Zigbee App (v0.5.5)


I have included the double Wallswitch (L, L1, L2) on my Homey with fw 2.0. It shows only one icon in my app which switches only the legt switch. When I want to use the right switch I have to open the icon where I can see switch 1 and switch 2. It is not possible to change the namens of these switches.

Is it possible to split the Icon into switch left and switch right?



Q&A time:

Wow, someone is actually reading the readme :grin:
This is actually for co-developers wanting to make a contribution to the app. I’ll see if I can rephrase this sentence (or remove it completely)

Not related to v2. In the next app update, I plan to activate the battery reporting.

Did you try to remove the device and let it time out? In 1.5.x this was the option to remove “lost” devices.

Thanks @Sanderrr and @JaccoStraaijer. Really appreciated and these contributions enable futher development to this app!

@JohanE That is correctly noticed, but actually unchanged behaviour compared to 1.5.x.
This is related to a limitation in the current Zigbee implementation of Homey; no support for multichannel nodes that allow creating a child device for a secondair switch. So this will only be resolved with the Zigbee re-write.
With some creativity, it can be resolved. :wink:
Create a virtual switching device for the right switch and link the states of the virtual switch to the right switch through two flows (virtual to right switch and right switch to virtual).



Q&A time (part two):

I appreciate your suggestion, but I don’t think this will be something Athom will be doing on short term.
And no, you;ll need to step up big time to really get on my nerves. :wink:

There is only one limitation in adding Zigbee devices and that is that you are only able to add 22 endDevices per routing device (including Homey as controller). So without any routing device (mains powered Zigbee device directly connected to Homey), 22 is the max. There is no limitation that takes into account the type of device.

How many devices did you include so far and what other Zigbee devices (in Homey’s network) do you use?
How do you conclude that Homey does not react to motion sensor after 2 are installed?

@danone @Rob @Tb1 is this still present?
As far as I am aware, nothing changed from Zigbee perspective (or the micro controller) in 2.0.0.
And trigger cards have all been tested on 2.0.0.

I did see several reports of failing IKEA Tradfri devices. Do you also use them as routing devices in your mesh?

I’ll try to reproduce this weekend; if time and wife permits.

1 Like


Hello, someone over here knows when the battery status will be available ? Or the next update ?



Poke Athom. It is up to them to fix a Zigbee issue. The dev of this app is waiting for the fix, too.



@Robert_b89 please read up a few comments

That is incorrect. This update is available, I need the time to, next to solving / answering all “issues” on 2.0.0, test and debug the battery updates on all devices.


Battery levels on xiaomi devices

Oh! So good, I must have missed something then.
Thank you!
Let’s buy you some time.



Yes, issue still present. Maximum 4 out of five motion sensors report motion alarm. It seems that always the last one triggered does not report motion.
I have ptp Homey for more than 30min.
There are no powered zigbee devices in my house. Only 13 battery powered sensors all Aqara, among them 5 Aqara body sensors.
I have brought them all close to Homey without any joy.



Thanks for the tip which resolved the problem. For me it was a new problem because I just started as a Homey user. In the past I have used Vera and after that I switched over to Fibaro. Due to the different protocols I am now using Homey. It brings me back to the pioneering days with Vera :wink:



I’m not seeing any open/closed insights, is this correct or does it have to do with my devices ?



I’ll try to reproduce this weekend.

Ah, the fun times are back!

That’s a change in Homey 2.0.0.
Boolean capabilities are not shown in the insights page. They are shown on the device details:



So - let say I have a ‘friend’ and he placed a temp sensor into a freezer in a sealed bag (safety first) and then after several week (and an upgrade to v2) it started reportng -100c and then just stopped.

Click in ‘his’ pairing button does not start the pairing blue light.

In your infinite wisdom, can anything be done to bring ‘my friends’ sensor back to life? Or has it moved on to a better place?



was afraid of that…
wanted to check if the drop in temperature was due to the fact that the door was open…
(thanks Athom)

There needs to be a way of capturing this without creating a flow for each Boolean device… :frowning:



I suppose you your friend already switched out the battery?



I think you mean ‘my friend’ :stuck_out_tongue: , yeah swapped it out.



Received 2 xiaomi sensors today. Humidity and vibration. Only can’t add vibration sensor, it times out when adding device. No Solutions yet for it? Or tips I can try?



@Dennisvm8 Can you try, when including these devices to follow these steps:

  1. Include the device at close proximity of Homey
  2. Follow the inclusion instructions, (press the button for 3 seconds)
  3. Once the blue led is blinking, keep pressing the button short, once every 2 seconds
  4. It should show a message like “interviewing cluster x of y”, every time that this message changes, press the button…
    this takes some time because there are a lot of parameters to transmit.


Thanks it worked. Messing with the button while pairing should have done the trick👍



You can send it over to your friend as he likes to tinker with electronic stuff and he might fix it, or better of give it to your friend as a present :heart_eyes:

Seriously, (both above and follow) if the bag was not properly sealed the humidity could have killed your sensor. Sometimes it works just to put it in a bag of rice for few days (open up the battery compartment) or send it to your friend.



Same issue here, 2 out of 3 motion sensors report a motion. All sensors are Zigbee connected. I tried several actions but no solution.