Homey Community Forum

Xiaomi Flora sensors are not updating

I have added my Xiaomi Flora sensors within Homey app. But only when I start Homey itself the values are being read from the sensors. And then nothing anymore.
So a reboot will give me sensor reading, and then it gets quiet!
I have seen that in the past there

I have a early model (2016 Backer) version of Homey with firmware 4.2.0 and all the plant sensors are the same latest firmware 3.2.4

Has anyone experienced the same issue?

With kind regards,
Paul

On the app reviews in store, many people have the same problem.

“Hi. The app is stoppning to work, it not update mi flora status after the last time i reboot homey.
Developer: it is caused by a Homey core bug. Athom fixed this issue in Homey v5.0.0”

1 Like

Maybe just maybe want to read the correct topic.

1 Like

Well Roy,
I have seen all the toppics and yes even the one you posted.

But Everyone that has issues has the older V2 of Homey, and not the Backer one from the beginning.
And I can’t upgrade to the 5.0.0 version so it seems. It reports the 4.2.0 as the latest firmware.
Thats why I posted the question.

Don’t assume anything, but base yourself on the facts!

By the way, if you use the miflora/vegtrug app on your phone, it looks like the connection between Homey and the sensors is dropped!
But I still need to test this correctly.

Just wondering why you cant ?

And found why.
In a time long. long ago (2016) I had the developer environment active.
But i have since boxed it for a time because of some house moving we’ve done.
And now out of the box and resetted the whole Homey it only did go to 4.2.0
Now with experimental updates again enabled I could upgrade to the latest 5.0 firmware.

So hopefully the issue is now solved with the sensors :smiley:

Thanx Roy for pushing me, and the rubber ducking!
Paul

1 Like