Homey Community Forum

Xiaomi mi flora sensor/ropot app

app

#43

How is the homey v2 compatibility??


#45

Broken, a bug report is already send to Athom.
The BLE implentation is not working properly.


Homey 2.0.0 Experimental discussie [NL]
#46

Hi Looks like i have a simular problem to Marius. I have 4 Flora sensors and a couple of times now the system stops talking with the sensors. Dont matter distance or if i reset och re-add them. A restart of the Homey solves it for a couple of days and then it stops again. How did you solv it in the end? and do you guys have any ideas why it behaves like this?

Mi Flora firmware : 3.1.9
Mi Flora App : 2.0.18
Homey : 1.5.13

Got this from the log of the conn failed flow.

2018-12-16 06:56:33 [Flowers] Ted Flora Sensor 1, failed connection to peripheral: Error: Unknown Connection Identifier

// Ted


#47

I’ve looked into the issue again and i’ve found some case where it can be possible that the timeout won’t set after an exception. I’ll have to look closer to that and run some tests.

@Marius_Arnesen, did you still encounter the some problems?


#48

@Teddy @Marius_Arnesen

I’ve just released 2.0.19-alpha to the store.

### v2.0.19 - 21.12.2018
  * removed html report to prevent cpu warns
  * changed version number strategy because it failed with on 2.0.0
  * try to resolve `not setting a timer on exception` issue

Do you have access to the alpha channel? Otherwise PM me your emailadress that you use with Homey, then i’ll add you to the list.

Have you access to the alpha channel? Please give me feedback on the latest release.


#49

I’ve just released 2.0.19-beta to the store.

### v2.0.19 - 21.12.2018
  * removed html report to prevent cpu warns
  * changed version number strategy because it failed with on 2.0.0
  * try to resolve `not setting a timer on exception` issue

#50

Getting this error while trying to add sensor in latest app version, homey v2


#51

@Koktail I have the same issue - is this an issue with the app or currently with Homey 2.0 (on rc11)?


#52

@Laurens, @shahzadsk the app version v2.0.19 is not compatible with v2.0-rc-x and will be still available for < 2.0.

I’ve been working hard to try to make the app 2.0 compatiible from the day 2.0 came out in rc. I have rewritten most part of the app. But there are still issues with BLE however. I’ve already added issues to Athom.


#53

@Koktail thanks for the explanation, no worries will just wait for the v2 support

Thanks for the great work on this app


#54

Thanks for the prompt reply and work on this app @Koktail


#55

so if i read correct we are going to have a stable homey V2.0 SOON, with bluetooth not working??


#56

I’ll think thats the case indeed. Athom said that they are working on the issue and that is will be resolved soon.


#57

I’ve just released v2.1.0 alpha to the store.
Homey 2.0.0 firmware is needed for this release.

Note: There is still an issue with the BLE as described in: https://github.com/athombv/homey-apps-sdk-issues/issues

v2.1.0 - 11.01.2019


#58

Great just updated, could add it! Now waiting for readings but that’ll work


#59

right, the readings did complete and provides information. But only for one time. The last refresh was two days ago. Is there a way to force it to update?


#60

You can restart the app or Homey to force a index.


#61

@Koktail I have been running the last alpha version on v2.0 stable sins erlier today and it habe been running very good. No issues so far :slight_smile:


#62

It does only update one sequence is it? The next sequence there is an BLE error.


#63

Advertisement


For the people that don’t follow a lot of threads on the forum: I’m asking for support for a second Homey to make my home automation stable for myself. Every small donation is very much appreciated! :hugs:

Please do not feel obligated to donate. if you are not in the position or if you want using the app for free it is your right to do so.