Homey Community Forum

Xiaomi Mi Home App for WiFi devices

That would mean it has a different model identifier then I have been told (which is ceiling10). Could you check the hostname of the light in your router to see if that gives any indication on the model identifier used.


i have a weird problem with the standard yeelight color bulbs that have been working forever:
using a simple “turn on light” works good, the light turns on, but the on/off state is not updated in homeys devices list, it still thinks the light is off. so i cannot use a “if light x is ON, do this”.

i dont if this is a known problem, this thread has become so large, i cant find anything on it in past weeks…

That is unfortunately what I expected and what means I do not know what is causing this. Do you know how to run the app from the command line? That would help troubleshoot this issue.

Never heard of it before, have you tried rebooting Homey?

The same thing happens to me, I have a plex flow that turns on a rgb yeelight but it appears to be off at homey. 2-3 weeks ago worked perfect.

I can try…

Hi, is there support for the Desk Lamp? Thx, Johannes

Will there be support for the nee xiaomi ir remote?

Wanna use it for me airco’s :slight_smile:


No and new products won’t be added as development of the underlaying miio library has stopped.

Sorry, this is to sad. is it any development plans?

You can ask the author of the miio library here: https://github.com/aholstenson/miio

(I did not code this library myself)

extra info: when changing brightness after turning it on, it does change to “ON” status.
rebooting doesnt help.

Was the „yes“ related to the Desk Lamp? And if so, what device do I add? Could not find the lamp when adding a new device. :grimacing:

As a Yeelight. The app should automagically detect it as desk lamp.

Now I found it and it works :grinning:


There are problems in your code.

if(result[i].model !== ‘ceiling4’ || result[i].model !== ‘ceiling10’) {
must be
if(result[i].model !== ‘ceiling4’ && result[i].model !== ‘ceiling10’) {

After this homey finds Meteorite lamp correctly.
But ambient light still doesn’t work.
But if I add:
result[i].model = ‘ceiling4’;

Homey adds the lamp as round lamp but almost everything works ok - light, ambient light (color changing), night mode…
Just one problem - I cannot dim ambient light.

Thanx, I’ll fix that and will probably fix the ambilight as well.

v2.11.11 - 2019-06-21

  • FIX: fix for support for Yeelight Meteorite