Homey Community Forum

Xiaomi Mi Home App for WiFi devices

Let me try with the latest git version tonight… the last one didnt work and i hadn’t touched it since

“Didn’t work” is not much to go on for me. It’s not strange it does not work at first since I do not have these devices and am writing support just on how I think the device works. So it requires testing and debugging from people that own the device. If you want to have any chance on these devices being supported there is more effort to put into. But if you don’t care much anyway I’d rather spend my free time on something else myself and will remove support.

1 Like

Yes, unfortunately I can’t get past homey getting offline after running the app in CLI…
Just tried it and still getting the same. Wished I know more on how to debug it…

Thanks for trying anyway! Appreciate what you have done so far for the app!

I got my Roborock S50 a week ago and added it to Homey without a problem. But unfortunatly it doesn’t react to my flows. When a flow is triggered everything related to the Roborock keeps spinning and nothing happens. Could this be related to this issue?

Quick question, i am thinking of getting a new robot vacuum. Either s50 or s6. But i read that some people are having problems, timeout problems and so forth. Are these problems fixed? Or should i go for something else?

Probably yes, communication between Homey and MiJa / miio devices will never be completely stable I’m afraid (unless Xiaomi decides to open up their API (which will never happen) or someone writes a better library to communicate with the miio devices (which is not very likely as well).

See my answer above, as mentioned in the app description not garantees can be given because this app uses an undocumented and unsupported API with a library that is not maintained anymore. If you need garantees that your vacuum cleaner can talk with Homey you should not buy a Xiaomi.

Does the RoboRock S50 automaticaly return to dock after executing the action “Start vacuuming” or do you need to program that as an extra action?

It will return if it’s done cleaning the room.

Hello Phuturist!
New Homey user for 1 week and a runaway from Zipato.
This will be another “can you fix this” question :roll_eyes:
But I have tried to search for this question before but I cant find some request about it before.

This product is the one :smiley:

What can I do to help whit the implement this?
I can also send one to you!

/H

This is a Bluetooth product while my app only communicates with WiFi products. So it’s not gonna be supported by me, but perhaps someone else could build a specific app for it.

It’s posted in the request topic for some time already and it has some likes but it only depends on the willingness of a volunteer who will do the job. Homey Community App Requests

v2.13.0 - 2019-10-06

  • NEW: add support for Xiaomi Mi Fan (ZhiMi and Dmaker models)
2 Likes

Hi! Just to report it’s actually working for my earlier generation smartmi fan! Great!
Thanks a lot! Putting this here incase someone’s looking for information.

SmartMi/Zhimi Pedastal DC Fan with removable battery.
Device ID: 74668718
Model info: zhimi.fan.v3

1 Like

Can’t install app …?? Says incompatible software version but I have latest version 2.5.2 of homey

The lastest version of the app requires Homey firmware 3.x. You have three choices.

  1. Switch to Homey experimental channel and install Homey firmware 3.x RCx
  2. Wait till Homey firmware 3.x is released to the stable channel, my guess is this wont take long anymore
  3. Install the previous release from the Shelly app using the command line as described here .

I have two EU Versions from a Mi Gateway V3. I can’t connect them to homey. I fill in the correct Ip address and the correct token… Did anyone have the same Problem? My roborock s50 runs very well…

Unfortunately, I have the same problem. How did you solve this?

The app was released with a dependency on Homey firmware v3, which is now being tested. Sadly, you’ll have to wait for that firmware to become stable before you can install the app (either that, or upgrade to the experimental channel, but there are certain implications if you do so; alternatively, you could try and install and older version through the command line).

Someone knows please if DIM level should be reported back to Homey even if changed his remote control? For me it seems it’s not working.

With what device are you experiencing this?