Homey Community Forum

Xiaomi Mi Home App for WiFi devices

Feel free to submit a pull request. The miio library is not maintained anymore and I lack the skills to implement it myself.

Also related to the unmaintained miio library. Not much I can do with my coding skills.

hi, I’ve seen this post and I’m in an unusual things I think, I’ve found the token 32numbers and letters and the local ip but I can’t connect:
x timed out after 30000ms but the token I think is correct (SmartHome 3486:[DEBUG]-12-03 13:53:45.795 processResult in result={“code”:0,“message”:“ok”,“result”:{“list”:[{“did”:“274877648”,“token”:“655348313xxxxxxxxxxxxxxx79713430”,“longitude”:“10.74417090”,“latitude”:“42.93104830”,“name”:“Mi Control Hub”,“pid”:“0”,“localip”:“192.168.x.xxx”) but doesn’t work, why? thanks

Looking at the name of your device it’s probably a Xiaomi gateway you are trying to pair. As it seems, Xiaomi has changed is disabled the way of communicating with the gateway and it does not work anymore with my app. I will probably drop support in a next release.

I’m in contact with a developer that has built another Xiaomi app which does have proper support for the gateway. I offered him to take over ownership of my app so he can continue to support existing users and merge his improvements. He is thinking about it but is also in contact with Athom because he actually wants his own app published in the app store (which Athom is reluctant to do since the overlap with my app). This could eventually lead to a solution for you one way or the other.

2 Likes

thank you Phuturist, I hope you can continue the support , thanks again

I lack the time :confused:
Seems the cli app is maintained still and running on python, perhaps this is something to look at.

The python-miio is a completely different library and unusable for Homey since Homey “talks” nodejs.

Hi - I am trying to install my Xiaomi vacuum into Homey. Homey want’s a tolken - but I see no where to get a token in the Xiaomi app?
Is there a (easy) way to install my vacuum?

No easy way, read the instructions in the first post of this thread to retrieve the token.

Okay - will try, thanks👍

Hmnn - tried to read in the top op thread - but really did not seem to find a how-to-connect your Xiaomi to the Homey?

Took me 5 sec to find the link you need in the first post👍

Hi, feel bad coz this always worked for me. But what happened to me is that my chineese Mi control Hub worked fine until now. In Mihome app I was trying moving it to EU server which is not possible for some time and only limited to CN server. However I managed to do it with an old version of Mihome app which alowed discover gateway on EU server. I had a reason to do it. Then I wanted to put it back to CN server and connect back to Homey. So i found the token again and since then when when adding device in the homey app it always finishes with Timed out after 30000ms. Tried so many things going there and back but no luck. Before it was connected to homey with no problem :slightly_frowning_face:

Hi, tried to add my new Roborock S5 Max. This is result. I suppose the model is not supported in app.

If you know the device ID I could add it to the list of recognized models. Perhaps basic functions will work than.

Is it this? roborock.vacuum.s5e

That looks about right, I’ll add it when I have some time and will let you know.

1 Like

Hello Guys, maybe someone can help me. I have just configured the mii home bridge, I was using some of the Aqara sensors directly connected to homey but It is quite unstable, so want to use the bridge to connect the sensors to and then control it with homey. So I have an iPhone and extracted the token, everything fine (already have an Roborock s5 that is working perfectly). But when I try to add it to the configuration of homey I get an timeout. I cannot find anything useful like logging that could point me in the right direction. Using the bridge in home assistant is working so I know there is some kind of communication to the bridge.

Same for me. Cant get my Mi Hub connected again :slightly_frowning_face: my Humidifier connects without problem.

Hi Jan - thank you very much for your suggestion. But even though I am implementing smart home platform in my house - I am not super familiar with how to install from a link like you send me?