Homey Community Forum

Xiaomi Mi Home App for Yeelights & Mi Home WiFi devices

app

#186

That is indeed a know issue I can not solve: https://github.com/jghaanstra/com.xiaomi-miio/issues/27


#187

Thank you very much, I also connected a robot vacuum cleaner.


#188

Hi, thanks for the great work on this app.

I have a color yeelight bulb and I’m trying to figure out how to set it to some shade of white through a flow. From devices I see a ‘sun’ wheel that I can use and it lights up in warm-cool white noticeably brighter than selecting a color. But I can’t figure out how to do that from a flow if previously it was set to a color. Anyone have an idea ?


#189

I think I figured it out! I need to set the temperature together with brightness. Somehow temperature on its own wasn’t working.


#190

Hi, having trouble adding Xiaomi Mi Evaporative Humidifiers (square ones, is this v2?)

My Philips Zhirui Candle Lights work great, so I know the app to be working fine.

Here’s the procedure I used:

Reset device
Connect to its wifi
Get the tokens by using the “miio discover” command.
Pair humidifiers with the Mi App - mo errors.

Both humidifiers are on “static” reserved DHCP addresses (by MAC address, confirmed, pingable)

But I can’t then for the life of me add the humidifiers, getting these errors when tapping Test Connection:
“Could not find that PairSession”
“Could not connect to device, token might be wrong”

I did this twice, resetting the devices and getting new tokens, but still.

Anything I should look at?

Thanks


#191

Just had 1 Yeelight crashing so it didnt connect to wifi at all.

i had to reset it.
once i did that. I added it to my google home and my alexa, and next up is the Athom Homey.
But when i tried to add it, through the homey app it keeps saying “searching for devices” and then oing “no new devices have been found”

is anybody else seeing this?


#192

Restart the Xiaomi Mi Home app on Homey and make sure you have enabled the developer or LAN mode for the yeelight. Then try again.


#193

Thanks for the response… lan control /developer mode is already active, and restarting the app doesn’t work
Neither does disabling and re enabling


#194

Are you sure you have removed the old device from Homey? If it detects that the device has been added already it wont show up in the pairing wizard (since it’s already added).


#195

Unfortunately yes… :frowning:

Removed device from homey… and removed device from the Yeelight app.

added it again in the yeelight. Turned on LAN control and went to homey. restartet the app. and tried adding it.

No luck :frowning:

hoping there are other’s in here who might have a yeelight who dare to remove it and reset the buld to factory and try to re add it :slight_smile:


#196

FIXED

miio discover

cli method was simply giving incorrect tokens.

iPhone Backup Viewer method revealed correct ones so both Humidifiers are connected.

Instructions for iOS users here

PS Could you kindly update the icon for version 2 humidifier (the square one) - you have it right on the App home page, but when adding, and once added, the icon is for the round v2. Would make it a but neater-looking.


#197

This is already pending in the app store for some days. It’s awaiting the approval by Athom.


#198

v2.11.0 - 2019-02-07

  • FIX: improvements to pairing templates for firmware 2.x
  • FIX: code refactoring in drivers (replace callbacks with promises)

#199

Hi, im trying to connect xiaomi Philip downlight but it keep saying could not connect to device, handshake timeout. I have the correct token and ip address. how can I recolve this?

is it possible to connect the downlight to the router? I found out that once the device connected to remote connection, I will have the above problem.


#200

Any chance the new Xiaomi Mijia / Yeelight Bedside Lamp 2 can be controlled with this app? The one that’s Homekit-compatible (can be paired with Homekit directly or, with more functions, controlled with the Mi Home app)?

Thank you


#201

All Yeelights use the same protocol. I might have to make a small update for this model to be recognized but that will not be a problem. So yes.


#202

And thank you again


#203

Are you able to add yeelight again if you remove a device?! I’m still not able to add…


#204

Hi all, thanks for you work!
I have couple questions:

  1. I have been trying to connect to Mi Gateway (v3) via Homey and had no luck. I’ve used correct token and ip address (I am sure because I’ve got success with this ip address and token via Domoticz and Raspberry Pi). Could somebody clarify what I am doing wrong?
  2. Are you going to add support of Xiaomi Ir Remote Control?

#205
  1. Don’t know, it should work. What is the error you see when you try to pair it.
  2. Nope, the miio library which I use has no support for this and I dont own this device myself so I would also not be able to integrate it with Homey. You could start by chipping in here but the author of the miio library does not seem to support the library anymore: https://github.com/aholstenson/miio/issues/67