Homey Community Forum

Xiaomi Mi Home App for Yeelights & Mi Home WiFi devices

I am not sure why we are getting different results but I have an S50 on current firmware and it is working perfectly.

Odd!

My S50 is visible in Homey, the token is excepted but flows don’t work. The App developer wrote he too is having issues. Are you on the latest firmware?

I will check the firmware mod options @Phuturist wrote about. In the meantime I just use the planning option in the Mi Light App.

Yep, latest firmware.
Could it done on which server you are connected to?

European server here.

My Homey updated to the latest experimental f/w and the Android App updated too. I tried to control the robot via the App and…it worked.!

Is there a idea of supporting the Xiaomi Meteorite table light? Would be great :slight_smile:

Adding it won’t be much trouble, I only need to figure out the light identifier and make some small changes in the code. So yes, it will be added.

1 Like

great news, i will buy one and can support testing :smiley:

For the S50 I’m using coordinates to clean different zones and one time in the week coordinate the S50 to the dustbin.
When I finished creating all the flows, it works for a short period.
The coordinates doesn’t works anymore. I believe X<–>Y are replaced.
It’s here someone in the community with this same behavior? The map view is changed in the Mi home app.

Yes, the S50 Gen1 doesn’t save the map. It is generated on every clean up.
So unfortunately, the map can change and your coordinates aren’t working anymore.
I was thinking about creating two flows, because the map chances always between two options. But didn’t do it right now.

Gen 2 save the map and it’s working fine.

I believe the map is regenerated when you use the official Xiaomi Mi Home App. If you only use that once to create a full map and then use Homey and Flolevac you should be set.

v2.11.5 - 2019-04-14

  • NEW: support for Yeelight Meteorite Pendant Light (YLDL01YL)
  • NEW: condition card for night mode for Yeelights that support this feature

Hey guys,
Is it possible to update plugin for support Xiaomi SmartMi Air System? It’s wall mounted purifier.

Have you already tried pairing it as Airpurifier? It might just already work. And if you did and it didnt work, what where the errors?

It’s not likely that completely new devices will be added to the miio library but an new product in an existing line (like the airpurifier) might already be supported.

I can cross check during easter holidays :slight_smile: Good point!

2.11.6 - 2019-04-16

  • FIX: update night mode capability when Yeelight ceiling light is controlled by external source

I followed the procedure complete again for my non rooted android phone, and I have the Roborock S50 working again using the app! So that’s great news!

Anyone else experiencing issues with a Mi Home vacuum? This used to work, now I receive timeouts after 30s.
Double checked the IP address which is fine, controlling the vacuum via the regular app works.
Xiaomi Mi app 2.11.6.

Hmmm, it worked for some moments, but not anymore now…

It really looks like that the token is changing in the new firmware or something like that… Too bad xiaomi!

A couple of post back I wrote the same. The developer replied that rebooting his router solved the S50 issues for him.

In my case, with a working token and a reboot, I still have connection issues.

I use the Xiaomi App for scheduling now.

Same here. Reboot of the router didn’t solve it.