Homey Community Forum

Xiaomi Mi Home App for Yeelights & Mi Home WiFi devices

Thanks for the fix. But dimming ambilight still doesn’t work (bg_set_bright).

Yeelight Meteorite light has Night mode which is not available in the update.

You seem to know your way around the code and GitHub. Would it not be easier if you just make the changes, test them with your light and submit a pull request?

It will not be easy for me, sorry :frowning: I’m absolutely not familar with Homey programming.
I just tried to send {“id”:1,“method”:“bg_set_bright”,“params”:[1, “smooth”, 500]} command by your app and it worked - changed the ambient light brightness. But I cannot imagine how to implement this in app dialogs. :frowning:

My Roborock S50 has a multiple personality disorder, at first it was only English and German, now also French has been added :crazy_face:
Can we somehow help with the therapy?

The app is only translated in English and Dutch. Any German and French comes from Homey itself for the default card for capabilities. This is something you should report at Athom HQ.

Hi Jelger!
About a year ago you opened an issue https://github.com/aholstenson/miio/issues/145 that I was involved into the investigation. It was regarding Philips Eyecare Lamp.
Yesterday I noticed a pool request https://github.com/aholstenson/miio/pull/238 that looks like a fix of that bug.
Do we have any chance that you include this lamp support by your application?

Thank you.

1 Like

Good find @AlexVVVx

That would be cool!

I have uploaded a new version of the app to Github. Can one of you guys test this with a CLI install and let me know if the fix is working.

I have successfully installed the application with a CLI install, setup the lamp and got this error - Could not connect to device, token might be wrong. I am not sure if my token is correct so I will continue tomorrow.

Thank you

1 Like

@AlexVVVx and @Phuturist

I have the same problem:

  • installed the older Mi App
  • retrieved the token via non rooted phone
  • installed the Xiaomi App via CLI (named com.xiaomi-miio-master.zip)
  • started the ‘add Philips lamp’ wizard
  • pasted the IP and the TOKEN
  • returns an error ‘token might be invalid’

UPDATE
I have downloaded the date.txt file to my Mac and opened it in a text editor. Searching for the token, I see multiple instances. Perhaps I used the wrong one!
No more time today, but to to be able to check all listed tokens this weekend!

UPDATE 2
I had two Philips Eyecare light tokens in my log file on my phone. Tried both with the IP that was given to the lamp. No luck.Both return an error stating the token might be invalid.

I have just extracted the token and new one is different from the token that was used initially. Now I have a new error message during the Lamp setup: device.eyeCareMode is not a function
It looks like that the token is correct and we have another bug in the code. The error message is different from one I faced initially last year.
I will try to have a look into the code.

Could you try again using the latest version from Github. Just pushed some changes to Github.

To continue the conversation from GitHub :wink:

Recently the app does not recognise or refind my Yeelight Desk Lights anymore, even after multiple resets of the device (and enabling LAN mode in the Yeelight app) it is not finding it…

All other Yeelight devices are still OK.

Great! It is working!
Not perfect but I can turn on//off the lamp and change brightness.
The problem is that the application icon is getting gray in about 5 second after last activities and brightness bar is reset to 0. But when I touch controls they are become active again.
Looks like we are moving in the right direction.
Please let me know if you need any other assistance from my side.

Thank you!

Could you try restarting the app and then try to pair again. And is the Yeelight on the same LAN as Homey?

Could you run the app with athom app run and let me know if the console gives you any more hints why the device shows as offline after 5 seconds.

Question
I do not see the Philips Eye Care2 lamp in the Yeelight App. So, I can not set the LAN mode. Is that required?

I can check this too, tomorrow. Thanks @Phuturist

I see nothing special in the console:

C:\temp\com.xiaomi-miio-master>athom app run
✓ Pre-processing app…
✓ Validating app…
✓ Homey App validated successfully against level debug
✓ Packing Homey App…
— App size: 4.14 MB
✓ Installing Homey App on Homey (http://192.168.142.188:80)…
✓ Homey App com.xiaomi-miio successfully installed
✓ Running com.xiaomi-miio, press CTRL+C to quit
— Profile your app’s performance at https://go.athom.com/app-profiling?homey=5aa77f6e973aff2c0d896239&app=com.xiaomi-miio
─────────────── Logging stdout & stderr ───────────────
2019-07-14 23:14:00 [log] [XiaomiMiioApp] Initializing Xiaomi Mi Home app …

Did you let it run for some time? If the device offline it should surely spit something onto the console log. I have uploaded a new version on Github that might give more information.