Homey Community

Xiaomi Mi Home App for Yeelights & Mi Home WiFi devices

app

#44

After update v2.8.2 the roborock vacuum worked fine but when updated to v.2.8.3 it doesnt work anymore.
I saw that there was an issue opened but closed about this. Should I open a new issue? Robot won’t accept commands for most of the time.

Can I downgrade?


#45

Please stop posting issues both in the support thread and on Github. You can downgrade using a CLI install and the releases found here: https://github.com/jghaanstra/com.xiaomi-miio/releases


#46

Sorry about that. Deleted the app and CLI-installed v2.8.2, works fine again. Thanks!


#47

SO it seems that the powerplug not being available was the problem, havent had any crashes since removing it.
But this problem didn’t exist before your recent updates to the app. Hope you can resolve it someday…
thanks for the help!


#48

Hi Phuturist,
Is there already some news about the Ceiling Light?
Setting the lowest possible setting in moonlight colors isn’t possible yet.


#49

Could you explain what you are doing to actually set the lowest dim in nightmode. I cant really find anything in the code that would prevent this. I have checked with the contributer from parts of this code and he had no clue as well. He thought you may not have actually turned on nightmode when trying to set it to the minimal dim. Are you using the special send command card to achieve this with a command similar as below

{"id":1,"method":"set_power","params":["on", "smooth", 500, 5]}

When you have used this command it goes into nightmode and you can set the dim to 1% with the change dim action card for the minimal dim value. Perhaps I should create an action card for this, that would be a bit more user friendly. :thinking:


#50


It’s quite hard to explain how and what I did so I took some screen shots. The third light from top is my ceiling light.
Is it perhaps not correct how I turn off the ceiling light? For the bulbs this way works fine.
After you shared the code I tried it and for the brightness it works, only the counter is too fast.
Perhaps you also know how to change the timer or where I can find the manual for this light.

Edit: When I say now “Good Night” the Ceiling goes to moonlight and nearly 1%. On the end of the flow it goes back to bright light. To be clear, I want it moonlight 1% all night long.


#51

Not my meaning to steal this thread, please advice if it has been posted elsewhere. But I have a Roborock v2 and I can’t find a way to retrieve the token from it. I have tried several guides and also MiToolkit v1.6. Among others this guide https://github.com/…/com.x…/blob/master/docs/obtain_token.md

I can only retrieve a file that is 1kb large. It does not contain anything interesting. Any help or pointers would be great!


#52

That it goes back to bright after the “change brightness over time” card timer has completed seems to be a bug in the Yeelight API (have not tested that myself). If you set it to keep the state it should not switch back to bright light.

I’m not sure how to achieve what you want, best is to look into the API description yourself and use the send command card. It’s pretty well documented: https://www.yeelight.com/download/Yeelight_Inter-Operation_Spec.pdf


#53

Have you followed the tutorial by the letter including running an older version of the Mi Home app since the latest versions dont include the tokens anymore.

Here is additional information on how to retrieve the token: https://www.home-assistant.io/components/vacuum.xiaomi_miio/#retrieving-the-access-token


#54

Yes I did follow this one:

Windows and Android

To fetch the token follow these instructions depending on your mobile phone platform.

  1. Configure the robot with the Mi-Home app.
  2. Download and extract the MiToolKit.zip.
  3. Enable developer mode and USB debugging on the Android phone and plug it into the computer.
  4. Change the MiToolKit language to English if you need to.
  5. Click “Extract Token”
  6. On the phone, you must confirm the backup. DO NOT enter any password and press the button to make the backup.
  7. Once you have confirmed the backup the token extraction will begin, it should appear in the MiToolKit shortly.

Now while retriviing with the MiToolKit I do get the error: “unhandled exception”. I still extracts the file, but it is only 1kb large. I used my old Samsung Note 2 for this. Only thing I am uncertain of is: “1. Configure the robot with the Mi-Home app.”

I mean I had already configured the robot on my Samsung S9 and the newest Mi Home App, but I did try even starting the robot with the Note 2 before I tried retrieveing the token so I am quite uncertain as to if I needed to reboot the robot before configuring with Note 2 or what?


#55

I have no experience with this toolkit. I would just install an older version of the mi home app and reinstall the robot. Then extract the token from this as described in the instructions. Everything I know is in there, so I can’t really help you any further.


#56

Hi guys,

I’m considering buying a new Xiaomi vacuum cleaner 2 S50 2018 model.

I like to know if I’m able to control it using with homey AND using it with the original app…

Do I need to choose? Or can it be connected with both of them at the same time…


#57

It can be controlled by Homey and the Mi Home app at the same time.


#58

Tanks! And the last question; After I have downgraded the Android app in order to check the token of the vacuum cleaner. Can I update again to the newest version? And do I need to pair the device every time the firmware of the cleaner has been updated?


#59

You can upgrade the app again without issues. Your device will be saved in the Xiaomi cloud. And no, you only need to retrieve the token again when you reset the device. Upgrading the firmware will not change the token.


#60

Allright thanks a lot! Ordered myself a brand new vacuum cleaner. I hope it will arrive soon. YIHAAAAAAA!


#61

There is an alternative app for Android, developed by a german guy nicknamed “Flole” (https://xiaomi.flole.de/ ). The app is generally german, but it can be switched to english via “Einstellungen->Use English as Language”.

Once you are connected to your vacuum you can select “Map”, “Zoned cleanup” and draw your desired zone like in the original Xiaomi app.

If you then long press on “Cleanup” it will copy the respective parameters (for example [[21459,23801,25009,24301,2]]) to your clipboard.

found it on hass forum


#62

@PhuturistI bought myself two new Yeelight smart Led’s v2 (10 Watt, 800 Lumen)
They work fine unless the options “Wijzig helderheid over tijd” and “Aangepast commando Verstuur commando (geavanceerd)” for turning on the lights don’t work. Turn off the light’s with these options are working.
Perhaps it might be interesting for you.


#63

Finally got my white LED strip working with the iBox 2 controller and Mi Light FUT036 Single Dimmer LED Controller.
It paired without problems with Homey, but there was just no reaction when I switched the Mi Light White Bulb in Homey on or off or changed the dim level.
I was really puzzled as I read that other people had it working, but when I started to add it as other MiLight bulbs instead of the White Bulb as an experiment I found that with the RGBW bulb it DOES work.
Now looking back at the description of the FUT036 controller, although it is single color, I noticed the RGBW in the name, so after all it makes sense :frowning: