Homey Community

Xiaomi Mi Home App for Yeelights & Mi Home WiFi devices

app

#64

You have posted this in the wrong topic. This is the support topic for Xiaomi Mi Home devices and Yeelights. Mi Light is a different brand.


#65

Oops, you’re right. Apologies, I got confused by the ‘Mi’ in Milights.


#66

Hello. Since a couple of days Homey can not connect to my Mi robot 2. I’m getting an error: “Network communication is unavailable, device might be destroyed”

I’m still able to control the robot using the mi home app. So the device is working fine. It has also still the same ip adress.

Any idea what this could be?


#67

It seems Homey lost the connection with the Robot. Although it should automatically restore the connection it seems this is not happening. Could you restart the app and see if that restores the connection.


#68

a app restart will bring it back, im restart the app right before my cleaning time starts


#69

A restart of the app did bring it back to live. Is this a known bug? Do I need to restart it every day?


#70

I’m not experiencing this myself. I can only explain it due to flaky WiFi connection of the robot. Even then it should reconnect in time. I can create a debug version for you to install which you should run from command line. This would give me extra info.


#71

Hello all,

since a couple of days, my homey won’t recognize my Yeelights (RGB 600lm ) anymore. They are still in my devices in my homey, but he can’t reach them… anyone the same problem or even better, the solution for this problem?

image


#72

Have you tried restarting the app already?

If so, it looks like either a network problem (did the IP addresses of the lights change?) or a problem with the developer mode. Have you checked this in the Yeelight smartphone app?


#73

@Phuturist Thanks for your swift reply, but the IP is still the same. I even tried to reset the bulb and try to add it again to homey. First the proces seems to be good, and the light is added to my devices. But a few seconds later, the connection is broken… it’s strange because there is nothing changed since it stopped working ( WiFi, lights, homey )

What can i do to check the lights? I’m in the office right now and the yeelight app has lost the devices completly… very strange now I see this. Has to be a connection between these two issues?


#74

Perhaps a firmware update did not go as planned and the bulbs where reset. I had this once myself. If this is the case that probably means the developer mode has been switched off as well. Not sure if this would still allow to discover the devices however. I’m not sure what else you can do.


#75

I did a reset of the bulbs in my bedroom, but even after this the bulbs disconnects from homey.
Adding the bulbs works like a charm, but after the setup the connection breaks… I don’t get it why this occurs.
LAN-control is on, It’s the same as developer mode right?


#76

I don’t know either. Do you know how to do a CLI install so I can get some debug logging?


#77

Is there any way to do a brightness check on the Yeelight?

e.g. I want to say
when… button pressed
…and… light brightness is <20%
…then… set light brightness 100%
…else… set light brightness 15%


#78

Sure, just use the global tags (dim capability).


#79

Ah, of course… one of those brain fart moments :wink:


#80

Just experienced same issue as MiteZZ. 2/3 yeelights is “offline” in homey. Have not changed / updated anything manually atleast in several days, now when I got back home they’re offline. The ledstrip in my bedroom work as expected. They’re visible in both Xiaomi Home and Yeelight app, and work as usual.

When I PTP on the bulbs, left them off for 1-2 minutes, they came back alive in homey. In my case, they had changed access point to the basement (Google WIFI), but is now back on the right AP. So this might be caused when / if it jumps to another AP? Dunno, just wanted to tell.


#81

v2.9.0 - 2018-10-06

  • NEW: add homealarm state capability for Xiaomi Gateway (state does not get synced when changing it through the Mi Home app yet)
  • FIX: keep custom capability night_mode for specific Yeelights in sync when changed through Yeelight / Mi Home app

#82

Hi,

For getting the token of de S50 (Roborock), I’ve deinstalled the Mi Home app from my Android and installed the 5.0.19 version of the app (like stated here: https://github.com/jghaanstra/com.xiaomi-miio/blob/master/docs/obtain_token.md ). Then I resetted the wifi from the roborock, logged in de android app (chose Europe region), and added the roborock again. But after all this, I still get an empty Token back in the mioo2.db.

Do I need to reset something before I can find the Token? Factory reset the device? Clearing files from my phone? Creating new Xiaomi-account? Or something else??

Thanks!


#83

That all seems right to me, not sure why the token is not available. Perhaps Xiaomi has introduced another measure to make it hard to directly control any miio devices … :thinking:

Cant really help you I’m afraid.