Homey Community

Xiaomi Mi Home App for Yeelights & Mi Home WiFi devices

app

#104

Haven’t had chance to do this yet, but I’ve now changed my network to a new mesh WiFi setup and am back with all devices showing offline

So IP address on them all has changed but in theory nothing else
Yeelight app finds them
Alexa finds them
Homey shows them as offline

Edit: Just to add - no new devices found when I run a scan, so it’s not that they’ve reset themselves


#105

Well, you can’t compare my amateur coding skills with these companies. Once a light is saved within Homey it’s saved with the corresponding IP address. Once this changes the connection is broken, apparently the Yeelight app and Alexa do a new discovery to update changes in IP address. This is currently not built into my app. I’ll see if I can add this somewhere in the future but it’s not too high on my priority list.


#106

Ah, this probably explains a lot of the issues then…
If it’s based on IP address then we all probably need to assign static DHCP routing to these devices too?
Surprised this hasn’t been an issue for more people!

Also, just to add, not criticising your coding at all - appreciate all the work on the app - just really really frustrated as I’ve been through my 30 odd flows twice now only for the devices to disconnect and be b0rked again!

Edit: @Phuturist is there any way for me to update the IP address of the device? (maybe even via CLI?) to save me having to redo all my flows again!?

Edit2: Also, can you tell me how I can add these devices now? I have tried to add them again via the devices and even after having removed the old one it’s not finding the bulbs (LAN mode is on…)


#107

The IP is currently saved in the data object of the device. I dont think it’s possible to edit/update this any other way than with a Homey app. Seeying the issues you are having I will move this to the settings object and make it available for editing under the device settings. But that’s of no use to you right now.

Try restarting the app after removing the bulb before doing a new discovery. That should clean any temporary data which can cause the light to not be discovered.


#108

Thanks, that will be helpful I think!

I’ve tried restarting the app, to no avail :frowning:

Any other ideas?


#109

No I dont, sorry.


#110

:disappointed_relieved::disappointed_relieved:

Guess I’m hard resetting them all again at the weekend


#111

Hello

I tried all the methods to find the token of the bridge, without success (1, 2, 3 …) and I realized that there was more simple: ( Activate the mode develloper)

Android:

Gateway

  1. About
  2. Several click on plugin version
  3. Hub Info

]!
]!
!

Cordially


#112

Just reset one and it’s STILL not being found :frowning:

Could it be due to the fact that they are on 192.168.1.x where as homey is on 192.168.0.x?


#113

Yes, could very well be. The Homey app sends a discovery message during pairing. It will probably only be send in the same subnet.


#114

Any way to change that or brute force it?

I’ve had no issues getting Sonoff or any other devices to communicate this way, and having Homey on the different subnet is important for the security functions I use it for…


#115

Don’t know, I’m not even sure that’s the case. You could look into it yourself though, the Yeelight api is well documented.


#116

Is this helpful? Couple of ‘solutions’ linked?


#117

By the looks of it you could hardcode your subnet into the discovery function to have it look in that specific subnet. For this you would need to fork my repo and add it yourself in /lib/yeelight.js.

I did find out that it could also be a router setting and I have also added a specific command to could fix it as well. Could you try a CLI install and see if that fixes the issue already.


#118

Thanks. Have family here this weekend but will try and have a go if I get chance (gotta actually work out what I’m going with the CLI as well!)


#119

So, sorry to follow up on this, know I’m dominating the thread here, but wanted to let you know I have actually centralised my system with the mesh network doing all of the routing now so there is only one subnet being used for all devices… after resetting all my Yeelights once more (due to a new wifi change) fingers crossed everything seems to be working as hoped now

Thanks for the troubleshooting help - not sure we ‘fixed’ the actual issue but it’s certainly now fixed in my setup via simplification :slight_smile:


#120

NEW TOPIC :wink:

@Phuturist

Are you able to advise what’s wrong with the flow below - doesn’t seem to be doing anything at all :frowning:

Am I using the card wrong?

I want it to light up to full over 30mins at 6.30am…


#121

Have you tested it with a shorter time range to see if your settings work? I just tested the card with Yeelight and it worked fine.


#122

Just tried and same… Nothing
Even took the time conditions out to ensure that it’s not that, says passed but nothing

On off etc all work great

Edit. Just tried with one of my other bulbs, card seems to do nothing there either :worried:


#123

And are you sure your lights support a Kelvin temperature of 6500? Some Yeelights only go to 6000. Try setting it to 3500 for instance.