Homey Community Forum

Xiaomi Mi Home App for Yeelights & Mi Home WiFi devices

app

#144

Hi,
Could you please comment of the colour range of the lamps. Are they cool white only or can you configure them to emit a somewhat more “yellow” / “warm” colour.
Br,


#145


#146

OK, thank you. Let’s suppose I didn’t find this picture in the internet :slight_smile:


#147

I have a Yeelight desk lamp. It is recognized by the app when I try to add the lamp as a Homey device. After that nothing happens when I try to switch the lamp on of off. Is this a known problem with this device?


#148

Nope, all Yeelights should work fine. Could you try restarting the Xiaomi Mi Home Homey app and try again. And have you made sure that developer mode or LAN mode is enabled for your desk lamp.


#149

@Phuturist: I did a reset of the lamp and enabled LAN mode. Problem solved. Thanks!


#150

Maybe a question which is already asked here, but I can’t find it:

How can I add my Yeelight strip to Homey? I can’t find an manual for that, and since Homey tells me that there isn’t found a new device, I can’t find where to start.

I’m able to control the strip via the Yeelight app, but better is to control it via Homey. It’s not necessary for me to control the strip from both devices.


#151

Please read the instructions in the opening topic or in the app store description.


#152

with the new app it’s not possible to get the token. IF i want to keep the new app but get the token are there other options? Can i still get the token from the old app? and add it and after that install the new app?


#153

found a workaround. Install Memu android emulator and installed a spanish version of the app on it.
stole from this comment on other website:

I didn’t succeed getting the miio tokens on Windows with the MiToolKit tool and the old Mi Home version on Android.

I end up using a modified Mi Home app that I guess it’s similar to the ones already discussed here, as it also shows the token on “Network Settings”.

After signing in into the app it also creates a “devices.ini” file on the phone, inside a folder called “plugin” at root level. The file includes a list of devices with their type, name, IP, MAC and token. In case any device doesn’t show up, maybe you will need to open the device on the Mi Home app first, it happened to me with the Xiaomi infrared device.

The app can be found here https://npirtube.com/mi-home-app/ (the website is in Spanish).

The version I used is the last one available from their website, 5.4.29

Link to download site removed as we can not validate the integrity of APK files distributed this way…
If you have any problems with that please feel free to contact me or another moderator. > @Dijker


#154

Just wanted to say that everything is working fine in Homey 2.0. I’ve discussed the Mi Power Strip before with you, the usage / wattage is now working nicely too. I’m also using the Yeelights, and i’ve bought myself a Roborock Vacuum S50 (couldn’t resist the Black Friday offer on Gearbest). The Roborock is also working nicely, except for the “Could not complete call to service” message that appears regurlaly. But i already red over here that this has another cause. Keep up the good work! :slightly_smiling_face:


#155

well call me crazy but i can’t find anything. sorry
Can you please post a link?
I searing for 2 days on the internet now how to get a token without any luck.

I have no android phone or tablet. I have no jailbroken iPhone.
So i tried this one: https://github.com/jghaanstra/com.xiaomi-miio/blob/master/docs/obtain_token.md
whit my iPhone IOS 12.0.
But i cant find my backup file. I can only find a map whit 50 maps in it. not a single file


#156

You can try to install an Android emulator and use that to retrieve the token.


#157

thanks for the suggestion. unfortunately it did not work out.
I have tried a few Android Emulators but without success.
NOX: will not open (i don’t no why)
BlueStacks: will not open because of problems whit Hyper-V enabled or disabled. i have tried a couple of times.
Microvirt MEmu: same problem as BlueStacks. even gives me a blue screen of dead a number of times.

i running Windows 10 whit a i7-8700K

I have tried again to make an iphone backup but I only get to see this: https://imgur.com/gallery/QqpNFt1

it is 0:30 AM now over here so i give up i am out of options. Please help.


#158

There are no more options left I’m afraid.


#159

What about rhe option using Wireshark?
Worked for me in the past.


#160

Hello. Trying to add Purifier PRO and when testing connection get an error message " device.power is not a function"


#161

The probably indicates your model is not supported yet. Do you know the miio identifier? You can use the miio CLI to find this out.


#162

As written on the app page - * Xiaomi Air Purifiers 2, 2S and Pro (tested). So I hope it should work, I have the Air Purifier Pro. Could you please link to what CLI is? tried to search but didn’t find. Thank you


#163

Xiaomi is constantly realising new models and upgrades with new device ID’s. Unfortunately every new id needs to be added to the miio library which I use in the Homey app. Missing devices need to be identified first. The link below explains how to do this.