Homey Community Forum

Z Wave Repeater

Hallo zusammen,

ich hab bei der Suche leider nichts passendes gefunden, obwohl ich denke, dass die Frage schon 1000 mal gestellt wurde…

Was würdet ihr um ein stabiles Z-Wave Netz zu bauen als Repeater empfehlen?
Einen Plug (Fibaro etc) oder den Aeotec Repeater?

Macht das von der Performance her Unterschiede?
Leider sind beide Varianten nicht richtig günstig (ca 55 EUR) gibts das auch günstiger?

Am besten fährst Du, wenn Du gleichmässig verteilt in jedes Zimmer 1 bis x Plugs, UP-Module etc. verbauen tust. Mit einem Repeater ist es nicht getan, zumindest nicht wenn mehr als ein Zimmer abgedeckt werden soll.

55 € sind ein bisschen hoch angesetzt. Hier bekommt man z.B. 3 Fibaro Wall Plug für ca. 120 €, oder einen für knapp 43 €. Vermutlich kommt noch Versand dazu, ich meine 3,99 € per DHL innerhalb Deutschlands.
Der Aeotec RE 7 ist dort für knapp 35 € zu bekommen.
Ein Repeater wäre für mich allerdings auch die letzte Wahl, weil durch einen Repeater die Steckdose nicht nutzbar bleibt.
Weitere Plug-Alternativen könnten der Aeotec Smart Switch 7 oder der NEO Coolcam Smart Power Plug sein. Diesen bekommt man bei AliExpress für unter 30 €.

Hallo, entschuldigt bitte die verspätete Antwort.
Also ich habe jetzt den Aeotec Repeater 7 im Einsatz. Verbaut im Keller.
Diesen Einlernen ging ohne Probleme (im Keller), Homey steht im EG.
Allerdings habe ich mit einigen Rauchmeldern (Abus Z-Wave) Probleme beim Anlernen.
Gibt es eigentlich irgendeine Möglichkeit die Reichweiten bzw. den Verbindungsstatus der Geräte (Zigbee, Z-Wave) nachzuvollziehen?

Ja, gibt es.
Bitte diese Seite aufrufen und mit deinem Account anmelden:

https://tools.developer.homey.app/tools

Dann Klick auf Zwave oder Zigbee

Die Zahlen in den farbigen Kästchen zeigen dir, welchen Weg das Routing nimmt.
In deinem Fall würde ich Homey den Stecker für 15 Minuten ziehen. Dann wieder einstecken. Das Routing baut sich neu auf. Schau nach einer Zeit nach, ob dann alles ok ist.
Es hilft auch oft die batteriebetrieben Geräte stromlos zu machen. Wenn Sie wieder Saft bekommen, suchen sie sich eine neue Route. Die Rauchmelder würde ich direkt neben Homey einlernen. Dann Batterie raus, zum Einsatzort bringen und die Batterie wieder rein.
Falls du in der oberen Übersicht, Geräte mit dem Namen unknown findest, ist da was schief gegangen und blockiert vermutlich das Einlernen. Melde dich dann nochmal, ich beschreibe dir wie man sie löscht.

Homey unterstützt leider kein Network Wide Inclusion (NWI). Wenn es bei strombetriebenen Geräten trotzdem teilweise funktioniert, ist es bei batteriebetriebenen Geräten aber eigentlich zwingend erforderlich diese in direkter Homey Nähe zu inkludieren.

Eine andere Möglichkeit eine Verbindung eines batteriebetriebenen Z-Wave Gerätes am Einsatzort wieder herzustellen bzw. die Verbindung zu reparieren ist die “Heal-Methode”.
Dazu ruft man die Z-Wave Seite in Developer auf, klickt in der entsprechenden Gerätezeile am rechten Rand auf die 3 Punkte, weckt den Sensor auf (bitte im Handbuch nachschauen wie) und klickt dann auf “Heal”. Das Z-Wave Gerät versucht dann eine neue Route aufzubauen. Bei Einblendung eines grünen Banners hat es funktioniert, bei einem roten Banner hat es nicht funktioniert und deutet schon fast auf eine zu große Entfernung zum nächsten Repeater hin. In diesem Fall kann man versuchen das batteriebetriebene Gerät näher zum nächsten Repeater zu bringen und den oben beschriebenen Vorgang zu wiederholen.

Funktioniert soweit, es sind alle Geräte bennant und alle haben eine Route. Habe vorhin den Homey auch über ne Stunde stromlos gehabt.
Allerdings sind die Geräte nicht durchgehend nummeriert. Es geht z.b. von 1-9 und dann mit 12 weiter. Komischerweise weisen manche Geräte dann ein Routing über Gerät Nr. 11 auf, obwohl das wie gesagt in der Übersicht gar nicht existiert. Akualisieren bringt auch nichts.
Macht das für euch Sinn?
Kann man außerdem nachsehen wie “stark” der Empfang der Geräte ist?

Dass die Geräte nicht durchgehend nummeriert sind kann von fehlgeschlagenen Inklusionsversuchen und von gelöschten (exkludierten) Geräten kommen, das ist also nichts Ungewöhnliches.
Dass ein Gerät über eine nicht mehr vorhandene NodeID routet darf und kann eigentlich nicht sein. Funktioniert das Gerät denn einwandfrei? Wenn ja, dann würde ich es definitiv Athom melden. Anschließend würde ich die “Heal-Methode” mal anwenden um eine neue Route suchen zu lassen.

Bzgl. der Empfangsstärke habe ich auf die Schnelle mal ein paar Fibaro Handbücher angeschaut. Mit einigen Geräten kann man einen sogenannten “Z-Wave-Netzwerkreichweitentest” durchführen, wobei eine LED dann verschiedene Infos anzeigt:

Vermutlich ist so ein ausführlicher Test aber nur mit Aktoren möglich.
Allerdings kann mit dem Fibaro CO Sensor auch ein einfacher Test durchgeführt werden:

Die Abus Rauchmelder haben aber keine Möglichkeit die Reichweite bzw. Konnektivität zu prüfen.

Darüberhinaus gibt es eine Software namens “Z-Wave Zniffer” mit der man das gesamte Z-Wave Netzwerk prüfen kann, u.A. die Entfernung zwischen zwei Geräten. Ob man anhand der damit gewonnenen Daten die Signalempfangsstärke ermitteln kann, weiß ich nicht.

Ob die funktionieren weiß ich gar nicht so genau. Es handelt sich um 2 Rauchmelder.
Ich habe vorhin mal an einem anderen Rauchmelder die Test Taste betätigt. Sofort hat mein Flow ausgelöst und auch die automatische Meldung vom Homey.
Nur steht jetzt 3 Stunden später der Rauchalarm (nicht die Akustik) im Homey an.
Ich habe keine Ahnung wie ich das zurück setze. Wenn mir hier jemand helfen könnte, dann kann ich anschließend auch die 2 Rauchmelder testen, die über die vorhandene Geräte Nummer geroutet werden.

Wegen der Signalstärke mit irgendwelchen LEDs ist mir zu umständlich, hätte ja sein können, dass man das irgendwo im Homey nachgucken kann. Danke aber trotzdem für deine Mühe!!

Ob generell eine Verbindung der RM besteht, kann man mit der Test-Taste, wie Du es ja schon gemacht hast, überprüfen. Wenn man die Test-Taste drückt und eine Verbindung besteht, erhält man umgehend zwei Push-Nachrichten auf dem Smartphone. Eine mit “Es wurde Rauch erkannt…” und kurz darauf (1-2 s später) eine mit “RM erkennt keinen Rauch mehr…”. Dazu benötigt man übrigens auch keine Flows.
Dementsprechend sollte in der Homey App bei dem Rauchmelder der Rauchalarm auch nicht mehr aktiviert sein. Entweder ist es nach wie vor ein Verbindungsproblem, oder die Batterie hat während des Tests schlapp gemacht.

Wie geschrieben, das ist auch meistens nur bei Repeatern/Aktoren möglich und selten nur bei Endgeräten wie Rauchmelder und anderen Sensoren oder Fernbedienungen. In Homey selber ist es nicht möglich.

Bei Aeotec RE 7 ist es auch möglich, nützt Dir aber natürlich nicht bei der Überprüfung der Rauchmelder:

In Developer → Wireless → Z-Wave → Spalte “Route” kann man auch sehen, ob ein Gerät verbunden ist oder nicht. Wenn dort “Unknown” steht dann ist es ziemlich sicher, dass dieses Gerät keine Verbindung mehr hat. Bei batteriebetriebenen Geräten kann diese Anzeige aber zeitverzögert sein, da dies u.A. vom WakeUp-Intervall abhängt.
Erklärung: Homey sendet immer wieder mal Anfragen an die Geräte, ob diese noch erreichbar sind. Bei strombetriebenen Geräten wird umgehend ein OK gesendet, falls diese erreichbar sind. Strombetriebene Geräte sind dauerhaft online.
Batteriebetriebene Geräte sind aber die überwiegende Zeit im Tiefschlaf und können in diesem Zustand keine Daten vom GateWay (Homey) empfangen. Deshalb werden die Anfragen von Homey in eine Art Warteschleife abgelegt. Sobald das batteriebetriebene Gerät aufwacht und erreichbar ist, werden die Befehle aus der Warteschleife an das Gerät gesendet und Homey erhält ein OK falls dieses erreichbar ist.
Sollte nach mehreren Versuchen (leider kann ich keine Zahl und auch keine Zeitspanne nennen) keine Rückmeldung vom batteriebetriebenen Gerät zurückkommen, dann erfolgt erstmal der Eintrag “Prev. known working route”. Nach weiteren negativen Versuchen erfolgt dann der Eintrag “Unknown”.

Ich hoffe es ist verständlich, ansonsten einfach nachhaken.

Batterie raus, eine Minute warten und dann wieder einlegen.