Z-wave status updates


#1

Hi. I’m having pains in my z-wave…

There seems to be a pattern regarding status updates.
My telldus wallplugs, works perfectly - probably the most reliable device i have, when it comes to updating their status. When switched on by either their local button or a associated device - they simply never fail. Until i install the APP for the device - then it doesn’t work.

And my zipato bulb2’s - same story, different day. No status updates, at all.

Something must be hard for developers to implement - maybe status reports should be handled by Homey, not the app.

I have created issues on github for the apps, but i understand that people don’t want to fiddle around with these things in their spare time. The open nature of Homey just becomes annoying when these things happen. I’m using my telldus devices without the app, to have them working like they should, with the bulbs, this is not an option - i would be missing more or less all the features, without the app.

When changing status via flows, Homey just cheats and updates the device status in the database - but direct associations is what makes z-wave so great. And direct association is still a bit flawed in this regard.

/Kind regards.


#2

Hi. I only use Fibaro devices so far but I agree there could be bugs in Homey’s status of associated devices.

Associations
I have just started with associations and multi-channel associations and I do not feel I fully master the subject. Other than on the forum I have not found a page with Homey instructions on this so maybe the below helps. Input and corrections are welcome.

Associations between my Fibaro devices (mainly “Dimmer 2” and “Double Switch 2”) are great and makes for less dependence on the controller (Homey). In Association Group 1 (the lifeline-report group), I always put 1 (default, Homey) . I also use 1 in Group 2 (S1) and Group 4 (S2) to ensure Homey gets a signal when a switch status changes, but I am not convinced this does anything.

Status of associated devices
Problem is that Homey does not know the status of the devices, eg: When device node 4 S1 button is pressed ON (association group 2 contains 1,14.1,19.2,20) the lights go on at node 4, 14.1, 19.2 and 20, but in Homey/Devices/ only device node 4 shows ON and the other devices are still shown as OFF, even though their lights are on.

This is only a problem if you want to do something with the devices in Homey: eg. if you have a flow to switch the lights off at some time. Then Homey has two problems:
a. The wrong status;
b. Changing status of a device in Homey will not affect associated devices, only devices that are in a call flow.

Workaround
Create flows in Homey that mimic the behaviour in device Associations. It is extra work, error-prone and should not be needed, but works.

In the same example: if node 4 is on, then switch on node 14.1, 19.2 and 20. The result: when pressing S1 button on device node 4, Homey correctly lists the status of each device.
I though the workaround would conflict with device associations, but for some reason it works.

Other factors
I am hoping Homey can solve this but am aware that other factors could be:
a. Distance between devices;
b. Homey’s distance to each device;
c. Multi-association status inconsistencies (14.1 and 19.2 in my case).


Best way to combine z-wave and normal wall switches
Device status not correct