Zigbee network Rebuild / Heal

zigbee

#1

Hi,
Since I have acquired my homey, I have added a lot of zigbee network nodes. Those nodes are both battery operated and 230V operated nodes. Most (all?) of the 230V operated nodes can also act as a router. Is there any possiblity to rebuild the zigbee network so that the routing becomes more efficient?
When I try to do so via the “rebuild network” option in Homey, there is some message stating that all of the devices and insights will be removed. Of course this is no solution.
I have read that taking the power from the “Hub” (homey?) for at least 15mins. might trigger an automatic network rebuild.
Can anyone confirm?
Br,


#2

There is no option called “rebuild network”
There is an option tho called “reset network”


#4

OK; and the answer to the question is… ?


#5

Well, first will be: what do u think is in-efficient?
2nd will be: are the nodes working like they should?
And: Did u try the PTP option like u mentioned urself by powering off Homey for like 15 minutes?
I know these are not answers but first we need to know ur problems aye?


#6

Not a answer, but after reading… strange thing is.

In the Zigbee settings its called in dutch “stel netwerk opnieuw in”

Knipselzigbee

And in the Zwave settings its called in dutch “Reste het Z-wave netwerk”

Knipselzwav

I assume its both the same “reset the network” but it could give some confusion.

@Bram


#7

Thanx Roy, for the confirmation; a reply with some content!
Strange indeed…
I really would hate going for a “rebuild” (Opnieuw instellen) and and up with a “reset” (Fabrieksinstellingen).

Have you tried to “stel netwerk opnieuw in”? Would you guess this option would remove all of the ZigBee nodes (and f*ck up my flows)?

Do you know how to force a ZigBee network Heal?

Br,


#8

I didnt try the option, but i assume with that option you losing all, and have to setup it all again. Only have 2 zigbee devices in use and no problems with it.

Maybe @Bram can confirm it


#9

Bram can confirm that yes. U WILL loose all ur zigbee devices and ALL flows containing this devices WILL be broken.


#10

PTP and wait for like 15 minutes before putting it back in. After that wait another 30 minutes for the network to be build again.
After that can u plz explain why u wanna do this? Is there something not right (besides looking in the developer tools and see that all nodes go to Homey directly, which is probably the shortest way) or is there some nodes not working ok?


#11

I will try the PTP method that i found earlier


And report back.

Most of my nodes are working just fine except for the ones in the garden. Sometimes they miss out on a changed status (Prown to optimisation - ex.1). The developer tools show that they are connecting directly to the homey and not to the closeby router device. The zigbee devices are not connecting to Homey throught the shortest possible routing and therefor probably consuming more energy than they really should (Prown to optimisation - ex.2). Since none of the added router devices is actually functioning as a router, clearly the heal function is not functioning correctly or even at all.

Other than this situation where some of the nodes are missing on some of the updates and a possibility to optimise, I am that odd (as it seems to be for Roccodamelshe) user that will try to understand the full extend of the functionalities of any device at my disposal.

I honestly do hope that my answers to your enquiries are actually answers to your enquiries. I do not understand however, what my motivations to do so might help any future reader of this forum.

Best regards,


#12

Well, the shortest way to Homey is directly to Homey and not thru a router. I have some devices connecting thru a “router” device so it’s not that it is impossible. The device must connect to Homey and when he can do that directly to Homey he’s not gonna connect thru a router device.
And the motivations does help a lot actualy. When the qeustion would just be: “Is there a heal function for zigbee devices in Homey?” the answer would just be :"No, there isn’t.
It’s always good to know what u wanna achieve to find the best answer to ur question aye?


#13

So no automatic heal function.
1.110 words to find the answer in the title.
Me like sundays … a lot … everybody has got loads of time…


#14

Am glad we could be of some help for ya!


#15

Maybe not completely on-topic, but is Athom going to do something with the information that the reset naming convention is not the same with Z-Wave and Zigbee in Dutch?
I can imagine that confusion is possible in the future with other users that use the Dutch language.
I also can imagine that someone who thinks he is just “rebuilding” the network is not amused to find out that all devices are removed and he can start adding them to the network and in existing flows all over again.