Homey Community Forum

Zwave not working

Hi community.

I switched from klik aan klik uit to fibaro
This because several times the shutters did not close or open.
Now i have the fibaro roller shutter 3 and i have the same trouble.
Sometimes 2 shutters don’t close and this evening they all stayed open.
I,ve put a notification in de flow so i can see that the flow started.
The notification comes but the shutters didnt close.
Wat can be the trouble??

Ehm not very much information you share, but lets guess.

  • distance to homey?
  • you have a good mesh in your house
  • wich mean lots of z wave routers , at least one in every room. More is better.

I have on the 2nd floor 4 room within each room a shutter with a fibaro rs3.
De closest rs is 2 meters from homey. And de most distance from a rs3 is 10 meters.

And what says the devolper pages ?

https://developer.athom.com/tools/zwave

Sorry but i’m fairly new at this.
Wat do i suppose to look at

Wel ofcourse the forum has a good search option.

The devolper page shows you the routing of your devices to homey. So you can see if the node is directly connected with homey or it usses a router (a main powerd device) wich extend your range

Hi Karlozz.
Do the roller shutters work as intended if you handle them manually through the Homey app?
Do they work if you test the flow?
If they work some times but not always, can you move Homey closer and test if that helps?
If that helps, can you rule out that there is something inbetween the roller shutters and the original place for Homey that can interfere? Think machines, metal stuff, thick walls, wifi access points, etc.

Hi Johan
Indeed they work manualy with the homey app.
And if i test the flow it works too.
It looks like homey won’t start de zwave in de flow when its time to do so.
It’s not a distance problem because the closest is within 2 meters

This is the routing from the sr3

Hi again.
OK, good information.

Shutter2 might need a “heal”, this is done in that view by clicking the 3 dots to the far right of the device and then clicking Heal. Doing so makes the device update it’s route to Homey. If the device is active?

(If a device do not speak with Homey one can also force it to communicate by pressing the pair button on the device.)

Else I would say you might have an error in your flow(s) that makes this error happen, can you login to https://flow.homey.app/ and select a flow that is not working and click the Share button (on top of the screen) and share that code with us?

And while looking at the flow(s), please make sure they are enabled.

Hi
How can you see that that one did need a heal and the other ones not.
Perhaps the the trouble comes from the app zonnestanden.
That one i’m using to close the shutters on sundown

I see that from “Prev. last working route” vs “Last working route”. This tells me the device is not communicating with Homey right now.

Please share a flow if you need more help.

It seem to be more problem of flow than zwave. Out of 50 communication attempts, only 1 didn’t respond. Try to make simple flow and test it manually. Or make group of blinds (group app) and test the control of all of them at once. You will see if they respond to commands.

It looks like the problem is solved.
I think it was a interference problem.
Relocated the homey and several times and it looks like that everything is working accordingly.
Thanks guys for the support from you.
I learned a few things👍🏻