Homey Community Forum

[App][Pro] Onkyo Receiver

Yup, my issue works or is fixed. (Spotify issue)

Version 3.1.0 on homey 4.2.0.

App does not detect audio turned on. When I use normal remote the application does not change power state to on for Main zone.

@jeroen, the submitted crash log is from version 3.0.0, so please ujpdate to 3.1.0
image

i Assume the ipadress on your receiver is 192.168.1.176? because i do not see the connection buillt up to the receiver?

Version 3.1.0 as alsmo more logging for the connection.
After device is added, please wait for about 15sec so the connection can build up.

Iám pretty sure the state from receiver towards homey is send

found a small bug when changing the setting if devicecard is alreasy added, the connection toward receiver isn’t build up, so in about 15 minuted version 3.1.1 wil be online

Sorry problem was with 3.0.0 and Homey 4.2.0. Pushed the crash log and updated to 3.1.0.
Will check if it improves.

@Jeroen_Tebbens and all others, version 3.1.1. is now in test

Ok updated

Hi Mickel, version 3.1.0 is working fine now! I setup de max volume to 100, that means that the max volume on the receiver is 50. If i put it on 80, than the max on the receiver is 40!

The rest works fine! Thanks!

Great to hear,. There is also at least on my receiver a maxvolumesetting in the receiver menu…this is niot syncd between receiver and honey for this setting.
What is your receiver type?
Is the normal volume setting front 0-100.?
Because there is some different in the protocol description per receiver

And can you do some volume settings and then send me a diagnosticlog?

The maxvolumesetting is there so you dont blow your speakers :slight_smile:

My receiver type is TX-RZ710, the max volume is 95. Normally the receiver play around 45. I will change to max 150 and will test it. With the app i can switch on/off, but when the receiver is out for a longer period i see a warning on the app receiver unavailable


When i switch it manually on, the app will see the receiver after a few seconds. Maybe i have to change a setting on the receiver?

77ff8e16-069b-4612-b18d-c171acdec07a

Hi Arie,

For the error you ineed need to set Network Standby ON setting in your receiver.
This settting makes sure the networkconnectivity is available when the receiver is switch off.
Because now when switchoff the reveiver is not reachable. see tracelog

ERROR: ERROR (server_error) Server error on 192.168.178.45:60128 - Error: connect EHOSTUNREACH 192.168.178.45:60128
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1137:16) {
errno: ‘EHOSTUNREACH’,
code: ‘EHOSTUNREACH’,
syscall: ‘connect’,
address: ‘192.168.178.45’,
port: 60128

Setting the maxvolume in homeyapp to 150 will not work because the range from the slider is now hardcoded from 0-100 and steps by 1.
I think as a read the manual that your receiver do step by 0.5? And that the problem if you set it to the receiver to 50 and homey is shown 100.

Let me think about this how to solve this the best way.
Thanks

My issues seem to be solved now as well, I’ve been playing around only for a few minutes now, but it already is looking good!
In the flow settings I only see;

  • Send custom command (general flow)
  • Send RAW EISCP command (general flow)

not the other options…
Is there a way to add a second receiver? :grimacing:

Up till so far you did a great job Mickel, thank you!

@ehofstede, Thanks. there a more flows on the devicecards, these are the default flows Homey created on the capabiltys , if you select a devicecard like Main Zone in the when - or - then you can see them.

For now there is no way to add a second receiver, other then download de code from GIT change the id (com.onkyo) and name and install it thru CLI.

:heavy_check_mark: found them! :slight_smile:
Thanks!

I have set the maximum volume for my receiver to 40 and the volume steps to 5.
After that it only steps to 35, the step to 40 isn’t made.
After I set the maximum to 41, the step from 35 to 40 is made though.
Works for me… :slight_smile:

I will fix this ,. I only used greather then but need to be greather and equels to maxvolume

1 Like

New version 3.2.0 in store(test)
@ehofstede : fix for maxvolumesetting is made (equals or greater then maxvolume)

@Arie_Ruitenberg : In the gereral setting you find a extra setting called “Receiver Volumestep” you can set this to 1 or 0.5 this should fix your problem.
Basiicly the the maxvolume(and slider) setting will be x2 :slight_smile:

Please let me know if this works?

For the settings page i did some cleanup and code some fieldvalidators.

The option 1 or 0.5 solves the problem, I have now set the Max to 70 and if I now set the slider to Max it is 70 on the receiver.
If I use the following menu with Volume + and Volume -, the Volume + at 35 stops on the Receiver. Furthermore, I had set volume steps to 2 for settings, but with Volume + or -, it does steps of 1.
For the rest, it works fine with me.

@Arie_Ruitenberg, i only did the new setting on the maxvolume not on the volume step , i will fix this also.

@Mickel_Luiten Thanks, running on 3.2.0 now. Most things seem to be working fine now.
PowerOff; selecting modes; volume. However, PowerOn doesn’t seem to work. Also the receiver is marked unavailable in Homey when turned off :confused:. When I manually PowerOn the receiver, all works fine.

Could this be a setting in the receiver (TX-NR646)?