Homey Community Forum

Aqara motion sensor works 9 out of 10 times, what to do

Hi,

I use quite a few Aqara motion sensors to automatically switch on lights (bathroom, kitchen, hallways) For over a year they worked perfectly (besides some user error flows)
For some reason since a couple of monthes they now sometimes won’t work (approximately 1 out of 10 times) They just don’t register the motion and lux for a moment (I checked in the app) . Sometimes a couple of minutes, sometimes longer
The Aqara cube and doorsensors work 100% of the time.

What I already tried:

  • new batteries
  • new motion sensors (wanted to add extra anyway)
  • Remove and install the sensors

Does anyone have an idea what else to check or maybe a solution?

I can’t give you a good solution, because I have the exact same issue at my home. For me range seems to be one thing, having the sensor connect to the Homey directly instead of through a repeater / router seem to have a positive effect on stability, but you can’t always control that. What helps sometimes in my case is to press the connect button once if the sensor fails. The next time it works again then…

But again, no real solution. I think it has to do with the buggy Zigbee implementation that Athom once and for all has to fix…

Maybe @TedTolboom can help? He wrote the Aqara app for Homey…

Perhaps not the solution you are after, for me all the problems related with Aqara motion sensors disappeared once I did the zigbee antenna mod. More info (Homey antenna mod)

Thanks for the replies. MartijnJ are you using Ikea lamps as well? Since they’re the only powered Zigbee devices and antennas in my house. This could be an issue as well.
I regret buying those, since they are horrible to add.
With the tradfri gatweway app it works fine, but you need a dimmer, switch or motion detector to add, and those motion detectors are bulky and horrible.

I think my next steps are replacing a bulb to another manufacturer and install a zwave motion detector.

I have a few tradfri wallplugs, but that’s it. Was a bit difficult to add, but eventually succeeded. My Aqara motion sensors are linked to the Homey directly though, but still issues every now and then, even with Homey being quite close to the sensors, so I don’t know how much an antenna mod would help…? @danone

My setup is made of battery powered zigbee devices 18 of them all Aqara various types and all connected direct to Homey. Latently I’ve added a Philips Hue outdoor strip (without bridge) and since then one of the Aqara motion sensor uses that Philips as repeater.
But no issues at all with any of the battery zigbee units since I put the zigbee antenna. That’s the easiest antenna to add on Homey, no soldering required and 2.4GHz antennas are readily available in almost every computer shop.
Yes, your Homey’s warranty is gone out the window the moment you open the ball.

The only thing I don’t get, i that all the Aqara door sensors work perfectly and I trust them. They’re quite far away from the homey, so I think they’re linked to a Ikea lamp. How can you check on which device they’re linked.?