Homey Community Forum

Chromecast issues after last update.. (beta)

Running 5.0.18 beta now. The “stable” version wasn’t doing anything better.
Sounds good that they’re working on getting groups to work again.
Thanks for your dedication @Rocodamelshe :+1:

I know, however;

  1. (Currently,) This interface seems to be unstable with tunein radio started with homey
  2. the Tunein app ahs differt functionalities (off course) and is build for radio stations. So if i want more control (like easily switchen between stations), Homey is not always the desired go-to interface (which i, off course, do not expect of homey).

My experience now with the latest beta;

Starting a tune in radio station is working fine for Google home devices, but streaming it to a chromecast device (in my case a built in chromecast in an xiaomi android TV box) I see something happen on my TV, the stream seems to be starting, but nothing happened.

Also, when I say to my Google home devices after homey starts a tune in station but after I say; okay Google, stop it doesn’t respond and it keeps playing. Really strange…

1 Like

This is EXACTLY my issue sinds an update one month ago. It really sucks and I’m looking for a way to downgrade, since I had zero issues and everything (including radio casting to multiroom speakers).

Yep terrible downgrade this update… dont fix it when it ain’t broke!
Have to restart Homey trough a flow every night just to keep my chromecast device available

Me too

Discovered I’m also having the same issues with flows that cast to my Google nest hub, as discribed Here. Chipped in by contacting athom. Restarting the chromecast app once in a while makes it managable. At least this way it “isn’t broken” all the time.

I am not sure if this is a fix. But I noticed that the chromecast-switch for the hub was off. Switched it on and it was working again. The switch can be found under devices.

what kind of switch? could you clearafy this?

Does anyone know why there isn’t a way to trigger a flow with “Chromecast paused”. I can see chromecast in “playing” or “paused” on my devices view when my wife start/pauses her tv show (casted via an app) and I would like to trigger something when we pause a movie/tv-show (increase brightness of lights/open our shades/etc). So it’s clever enough to detect whether it’s playing something or not, but it’s not possible to trigger a flow on this?

You’d have to request the developer of the app to add those cards.

Still having the issue even with the latest beta.
When I reboot the app every device becomes available.

1 Like

Hello all,

I have following issue with chromecast app:

I am using the “play audio URL” card and when the URL is provided directly to the card it works (audio is played), but when the URL is provided as a variable it doesn’t (nothing is played).
image

  • I tried both with betterLogic and Homey variables

Anybody tried such a scenario?

@piotro

I tried it with an url in a logic variabele Qmusic (https://icecast-qmusicnl-cdp.triple-it.nl/Qmusic_nl_live_96.mp3) and it works.
So maybe the url you are providing is not okay, or need a little delay on the cast url so you definitely sure that the url is set in the variabele

Try adding a delay to the second card (the one using the variable). Actions are always started concurrently (at the same time), not sequentially (one after the other).

Thank you guys for your input! I found the problem (strange one) when I realized (unfortunatelly not fast enough) that the only difference between our screenshots is the flow editor type.

I tried all the things listed below… but then thought maybe I should try one more thing: to create a flow on a mobile app… and it worked.

When I created a flow using a Web flow editor it behaves strangely, like described below.

I am using chrome web browser and wanted to check if maybe it is the root cause, but on internet explorer the flow editor does not work at all. :hushed:

The “direct” URL works good:

But this is still silent: (The chromecast device gives a signal that it received a command.)

I tried it different ways and everything failed:

  • on 3 chromecast devices
  • setting TestString with a Logic set string card.
  • setting TestString manually on Logic setting page.
  • restarting Homey
  • reinstalling Chromecast app
  • using http and https
  • creating new flow each time
  • at the end I tried to create flow on mobile :smirk:

BTW. small off-top: I found some difficulties in working on Web flow editor with variables. Especially with calculations.

  • In the calculation when the variable is added after the string the whole calculation fails.
    It also fails, when I want to edit the calculation and repace the variable…
    For instance if I want to replace any variable in this calculation I need to create it from scratch, otherwise it will fail with no (empty) result.
    image

  • second thing is during selecting variables and trying to type anything in search field. The whole window dissapears, which is quite annoying as I need to look for a variable scrolling the whole list.
    image

Have you encountered this kind of web flow editor behaviour?

I’m losing my mind with this stupid chromecast crap. Will there ever be a stable version?!
This is the only thing that doesn’t work on my homey, but pretty much the most essential.
PLEASE PLEASE PLEASE HOMEY, FIX THIS ONCE AND FOR ALL

I have done anything above, direct URL, flow starts, Chromecast gives a “hello i am recieving something sound” and no mp3 sounds… I hope someone can help me with this.

I have exactly the same problem. Makes the received command noise, no MP3. I can send the URL to the Chromecast using Home Assistant no problems (which is my reluctant workaround - Homey requests HA to start streaming)

I really hope this gets resolved

I have also experienced the above mentioned problems. Replacing the TuneIn stations with audio URL’s serves as a workaround.

When is the next update of the chromecast app planned? I hope it will fix the issues, because Chromecast is an important part of the automation!

Sidenote: for newbie users it is strange to have flowcards that don’t work.