Homey Community Forum

Correct procedure to disconnect z-wave products

#1

First day with homey, (2.0.4) I’m doing some test.
I added 2 fibaro devices to the homey and after I have reset to default the homey.
I spent a little our doing reset to the devices because I didn’t unpair them form the homey.
After reset to default of them ( very painful ) I wasn’t able to reconnect them with fibaro app and I add them with generic z-wave module in homey.
I would disconnect them from generic and reconnect with fibaro app ( more options ).
The question is:
what is the correct procedure to disconnect z-wave devices?
Form developper page pair/unpair?
From developper page / devices and trash them
From developper page / z-wave remove node
I’m getting confused with those all options
Thank you for your replies

#2

They will all 3 end up in the same result, removed in homey as device, and the device itself reset back to factory defaults, so you can choose whatever you want.

The last one is the most important, that the device itself has been reset to factory defaults

#3

infact I was looking for the correct procedure who assure that the device will be reset at factory setting and ready for pairing again.
Wich one do you suggest to you?

#4

The easiest way is to just delete the device from the device’s overview, and activate the inclusion mode of the device.

But even if that fails to reset the device, you can always reset the device from the developer tools, and remove a zwave device from there, that will reset the device to factory defaults, even if it is not included into homey.