Homey Community Forum

Dim light over time then turn off

Just getting to grips with flows, and I have a basic flow at this stage:

When
Time is…
And
Lamp is turned on
Then
Start dim level change
Decrease dim level during 60min

It works fine, lamp is dimmed over a 1 hr period, but I was expecting the lamp to dim all the way to 0 (off), not stay on 1%.

So, my questions are;
if I add a “turn off” command to the end of the flow, does it wait for the “start dim level change” card to finish and then execute, or do I need to add a 60min delay so that it will execute at the end of the dimming period?

And should I be doing this in the same flow, or use a seperate flow?

Cheers,

Sandy

:+1:
The same flow.
61 min.

1 Like

Because I also have one lamp slowly dim to 0 % in the evening, of course I wanted to know how some of my lamps are behaving. So I made some tests.

Test conditions
– Homey FW v5.0.0-rc.57 (Beta)
– INNR Lighting Devices v2.1.1 (Experimentell)
– Philips Hue ZigBee v.2.0.24 (Experimentell)
– Philips Hue v5.0.3 (Experimentell)
– Start Dimlevel: 100 %
– End Dimlevel: 0 %
– Dimm Duration: 15 s

GateWay/Bridge Manufacturer Device capability “dim” capability “onoff”
Homey Innr Smart Filament Bulb E27 Vintage Edison 0,02 *1 false
Philips Hue LightStrip Plus 0,00 false
Philips Hue Bridge Innr Outdoor Spot Light OSL 130 C 0,00 false
Philips Hue White and Color Ambiance E27 0,00 false
Sunricher Zigbee LED Dimmer Controller 0,00 false

*1 reproducible

Result
All lamps dimmed down until they were visually clearly off. This visual appearance is also confirmed by the “onoff” capability, even if the dimming level was not 0 %.
It seems that the result depends on the used devices and/or apps.

Because the dimming time of my lamp in the evening is of course also longer than just 15 seconds, I will also take a look at the data tonight.

@SandySound, with which lamps/devices have you noticed this? Were the lamps still slightly on after 60 minutes? Or did the dim value show 0,01 % and the lamp was in fact off?

1 Like

How are you getting on with this? I haven’t been brave enough to install it yet. Homey seems to have some difficulty in controlling lots of Hue bulbs at once and I’m wondering whether the latest app is any better. Also can Homey use Hue scenes properly with this app?

I cannot find any problems. However, I switch a maximum of 2 lamps at the same time because I do not need to switch more. I do not actually use Hue Scenes, but I just tested it and it works. However, I also read that there are problems with the scenes.
For the version v5.0.3 Homey FW v5.x (Beta) is required.

1 Like

@fantross I am using Namron downlights with Fibaro Dimmer 2.
I will see how the implementation of the “Turn Off” command with 61mins of delay goes tonight :slight_smile:

This will work, but probably not necessary.
The Namron downlights are normal dimmable GU10 lamps? Or are they Zigbee lamps?

1 Like

They are standard LED downlights controlled by the Fibaro Dimmer 2. I haven’t changed any of the settings for the Fibaro, I suppose I could adjust its values so that dim 0 is equal to off…?

Don’t no, sorry. Because I have no Fibaro Dimmer 2. I just only know, that you have to calibrate the Dimmer. So maybe this could be the problem?

Here are the results:

GateWay/Bridge Manufacturer Device dim time capability “dim” capability “onoff”
Homey Innr Smart Filament Bulb E27 Vintage Edison 30 min 0,03 false
Philips Hue Bridge Innr Outdoor Spot Light OSL 130 C 15 min 0,00 false

Because both lamps are from the same manufacturer, but they are only connected to Homey in a different way, it could be that the INNR app is responsible for this.

Nevertheless, both lamps are switched off at the end.